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S U M M A R Y  
 

The problem of ECDL testing methodologies in approach to quality is disputed in this 

master’s work. This work studies ECDL testing methodologies and their problems, analyses the 

pros and cons of automated test assembly and computer adaptive testing methods. It also analyses 

the advantages and disadvantages of automated and manual testing. The purpose of this work is to 

suggest a new ECDL testing system architecture, which ensures effective and efficient testing of 

people’s computer skills and competence, as the quality of those computer skills is very important. 

The objects of this paper are the possibilities of ECDL manual and automated testing. The 

main goal – is to suggest a new ECDL testing system architecture, after analyzing and evaluating 

ECDL testing possibilities. 

The main tasks of this master’s work are: to evaluate testing methods in approach to 

quality; to suggest a new ECDL testing system conceptual architecture model, which includes best 

practice management sub-system; to find best practice elements according to ECDL Advanced 

Syllabus 1.0; to perform experiments connected with the use of best practice elements in the ECDL 

Advanced testing. 

The main results of the research. The expert survey was conducted in order to find out, 

what experts think about the need to complete ECDL tasks correctly and with a touch of quality. 

The second purpose of this survey was to find out, if best practice elements are needed, and if yes, 

then for which ECDL modules. The results show, that quality is very important in accomplishing 

ECDL tasks, and that best practice elements are mostly important for advanced and specialized 

users. This experiment gave a precondition for a practical experiment for people’s skills. The new 

experiment showed, that people, who use best practice items, complete ECDL tasks more quickly 

and effectively. In accordance to research results, a suggestion for ECDL testing system is made, 

that includes best practice management sub-system items in a new ECDL testing system 

architecture model. 

This master’s work covers 90 pages, it contains 4 tables, 11 pictures and 4 appendixes. 

 



6 
 

ĮVADAS 

Šiais informacinių technologijų pl÷tros laikais atsirado informacin÷s visuomen÷s sąvoka. Ji 

apibr÷žiama taip – tai atvira, išsilavinusi ir besimokanti visuomen÷, kurios nariai geba, gali ir nori visose 

savo veiklos srityse veikti šiuolaikinių informacinių technologijų aplinkoje, naudotis šalies ir pasaulio 

informacijos resursais. Ši sąvoka pabr÷žia informacijos vaidmenį visuomen÷je ir žymi specifinei 

socialin÷s organizacijos formai būdingą bruožą, kai d÷l pasikeitusių technologinių sąlygų informacijos 

kūrimas, apdorojimas bei perdavimas dabartiniu istorijos laikotarpiu tampa pagrindiniu produktyvumo 

ir galios šaltiniu. Profesinis kompiuterinis raštingumas turi suformuoti konkrečios profesijos 

kompiuterio vartotojui aiškią kompiuterio taikymo savo profesin÷je veikloje motyvaciją – kokią naudą 

ir naujas profesines galimybes suteikia kompiuteris darbo vietoje ir kokios problemos gali iškilti 

informacinių technologijų ignoravimo atveju. 

Kompiuterinio raštingumo įgūdžiams formuoti ir tobulinti skirta ECDL programa. Tai Europos 

komisijos ir Europos šalių informatikos specialistų sąjungų tarybos CEPIS inicijuota programa. Šios 

programos pasiekimas yra tai, kad nustatytas standartas kompiuterio vartotojo žinioms ir įgūdžiams 

sertifikuoti. ECDL standartas remiasi tuo, ką kompiuterio vartotojas turi žinoti apie informacijos 

technologiją ir asmeninius kompiuterius bei kokius asmeninių kompiuterių ir populiariausios jų 

taikomosios programin÷s įrangos panaudojimo įgūdžius jis turi įgyti (ECDL Lietuva, 2006). 

ECDL sertifikavimas iš pradžių buvo atliekamas rankiniu būdu. V÷liau buvo pereita prie 

kompiuterizuoto testavimo, tam sukuriant specialias testavimo sistemas. Pirmosios kompiuterizuotos 

testavimo sistemos buvo labiau grindžiamos teorinių žinių patikrinimu. ECDL programoje įgytų įgūdžių 

įvertinimui Lietuvoje naudojama testavimo sistema dirba su interneto klientais. Teisę prie jos jungtis 

turi tik įgaliotieji ECDL testavimo centrai. Testavimo sistemos užduotys yra keleto tipų: pagrįstos 

tiesioginiu atlikimu, imitavimu, spragtel÷jimo ir tempimo, „tiesa/netiesa“ pasirinkimu bei daugybiniu 

pasirinkimu. 

Iki šiol n÷ra spręsta problema, ar efektyviai realizuotoje testavimo sistemoje atliekamas įvairių 

užduočių tipų tikrinimas, ar testuojant atsižvelgiama į žmogaus įgūdžių kokybę. Kadangi ECDL testų 

tikrinimas vykdomas tiek rankiniu būdu, tiek automatizuotu būdu, tod÷l būtų labai naudinga išanalizuoti 

įvairius testavimo būdus ir įvertinti rankinio ir automatizuoto testavimo būdų galimybes kokyb÷s 

požiūriu. Pasirinkta tyrimų sritis yra pakankamai plati, apimanti efektyviausių testavimo metodų, 

vartotojų reakcijos į testus problemas. Tiek užsienyje, tiek Lietuvoje yra atlikta nemažai tyrimų, siekiant 

sukurti efektyvų vartotojų testavimo metodą ar patobulinti jau esamus. Įvairias kompiuterizuoto 

testavimo problemas gvildena šie mokslininkai: J.M. Linacre, R. Hambleton, C.G. Parshall, J. A. Spray, 

J.C. Kalohn, T. Davey, S. Maciulevičius, E. Telešius, R. Danielien÷  bei daugelis kitų. 

Apžvelgus šių mokslininkų literatūrą, galima pasteb÷ti, kad n÷ra vieningos nuomon÷s, kuris 

testavimo metodas yra efektyviausias, visi mato vis kitus testavimo sistemų aspektus, išskiria skirtingas 

testavimo galimybes bei paskirtį. Pasteb÷ta viena bendra tendencija, kad paprasčiausias testavimo 
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metodas, atitinkantis paprastą popierinį testą, netur÷tų būti naudojamas vartotojų įgūdžių lygio 

įvertinimui nustatyti. 

Problemos ištyrimo lygis rodo, kad nepakankamai ištirtos įvairių testavimo būdų galimyb÷s. 

Tod÷l šio tyrimo objektas – ECDL rankinio ir automatizuoto testavimo būdų galimyb÷s. Tyrimo tikslas 

– išanalizavus ir įvertinus ECDL testavimo būdų galimybes kokyb÷s požiūriu patobulinti testavimo 

sistemos modelį. Tyrimo tikslui pasiekti, suformuluojami tokie uždaviniai: 

1. Išnagrin÷ti esamus įvairius ECDL testavimo būdus. 

2. Išskirti rankiniam ir automatizuotam testavimui būdingas užduotis. 

3. Pasiūlyti naują ECDL testavimo sistemos architektūros koncepcinį modelį, įjungiantį gerosios 

praktikos elementų valdymo posistemę. 

4. Sudaryti gerosios praktikos elementus ECDL Advanced modulių testavimui. 

5. Atlikti eksperimentus, susijusius su ECDL Advanced testavimo gerosios praktikos elementų 

panaudojimu. 

Tyrime bus taikomi tokie tyrimo metodai – mokslin÷s literatūros analiz÷ ir apibendrinimas, 

testavimo būdų lyginamoji analiz÷ ir apibendrinimas, kiekybinis ir kokybinis tyrimo metodai. Remiantis 

pirmuoju metodu buvo rašoma darbo teorin÷ dalis. Lyginamoji analiz÷ naudojama testavimo būdų 

galimybių įvertinimui. Darbo teorin÷je dalyje nagrin÷jami Lietuvoje egzistuojantys rankinio ir 

automatizuoto testavimo būdai. Aptariami kiekvieno iš būdų ypatumai, galimyb÷s bei sunkumai. 

Lyginamosios analiz÷s dalyje nagrin÷jamos realios užduotys bei jų testavimo būdai. Čia analizuojamos 

testų užduotys ir svarstoma, galbūt tam tikrą užduotį būtų geriau ir efektyviau testuoti kitu būdu. 

Eksperimentin÷je dalyje įvertinamos tiriamo ECDL testavimo būdo galimyb÷s ir nustatomas jo kokyb÷s 

lygis. Testavimo būdo kokybiškumas įvertinamas atsižvelgiant į konkretaus testavimo būdo galimybių 

panaudojimą konkrečioms užduotims įgyvendinti. Darbo teorin÷ reikšm÷ yra ta, kad išnagrin÷ti įvairūs 

ECDL testavimo metodai, išanalizuoti automatizuoto bei rankinio testavimo privalumai bei trūkumai.  

Taip pat pasiūlyta nauja ECDL testavimo sistemos architektūra, įjungianti gerosios praktikos elementų 

valdymo posistemę. Darbo praktin÷ reikšm÷ yra ta, kad sudaryti gerosios praktikos elementai ECDL 

Advanced MS Excel modulio testavimui bei atlikti du eksperimentiniai tyrimai – ekspertų apklausa bei 

praktinis eksperimentas, susijęs su MS Excel bei MS Word užduočių atlikimu. 

Magistro darbą sudaro įvadas, trys pagrindin÷s dalys ir išvados, kurios apima 90 puslapių. 

Pagrindin÷se dalyse pateiktos 4 duomenis susisteminančios lentel÷s ir 11 informaciją grafiškai 

pateikiančių paveikslų. Taip pat pateikiami 4 priedai. 
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1. ECDL TESTAVIMO TEORINIAI ASPEKTAI 
Šiame darbe svarbu įsigilinti ne tik į naudojamus testavimo būdu, bet ir suprasti ECDL 

Fondo veiklos ypatybes, susipažinti su darbo specifika. Šiuo būdu galima lengviau surasti optimalų 

testavimo metodą, pateikti geresnį testavimo sistemos architektūros modelį, atitinkantį ECDL 

testavimo metodikos reikalavimus, o kartu padedantį efektyviau organizuoti testavimo procesą. 

1.1. ECDL Fondas 

European Computer Driving Licence Foundation yra tarptautin÷ organizacija bei ECDL ir 

ICDL licencijavimo institucija. Europos kompiuterio vartotojo pažym÷jimas ECDL ir tarptautinis 

kompiuterio vartotojo pažym÷jimas ICDL yra tarptautiniai vartotojo darbo kompiuteriu įgūdžių 

sertifikavimo standartai. ECDL Fondas yra nepelno siekianti organizacija, padedanti kelti bendrą 

kompiuterinio raštingumo įgūdžių lygį bei suteikianti galimybę integruotis Informacin÷je 

Visuomen÷je. Šios fondo siūlomos programos veikia daugiau 148 šalyse. ECDL Fondo misija: 

„Suteikti galimybę žmon÷ms, organizacijoms ir visuomenei gauti įgūdžius naudojant informacines 

komunikacines technologijas, kurie pasiekiami per kokybiškų sertifikavimo programų vystymą, 

skatinimą ir pateikimą visame pasaulyje (ECDL Fondas, 2008)“. 

S÷kmingą šio fondo veiklą sąlygoja ir aukšti kokyb÷s standartai, taikomi ECDL 

sertifikavimo programoms. Taip pat yra specialiai sukurta Kokyb÷s Užtikrinimo sistema, 

susidedanti iš Licencijų tur÷tojų Auditavimo Programos ir Kokyb÷s Valdymo Sistemos. 

Remdamasis šia Licencijų tur÷tojų Auditavimo Programa ECDL Fondas periodiškai atlieka 

auditavimą Licencijų tur÷tojų testavimo centruose, kad pad÷tų išlaikyti aukštus testavimo programų 

standartus. Kokyb÷s valdymo sistema užtikrina, kad visa vidin÷ veikla atliekama struktūrizuotai 

siekiant dirbti efektyviai, našiai ir nuolat tobul÷ti. 

ECDL Fondas siūlo daug įgūdžių sertifikavimo programų. Jas galima suskirstyti į bazines – 

EqualSkills, e-Citizen, ECDL, ECDL Advanced; bei specializuotas – ECDL CAD, ECDL 

WebStarter, EUCIP, ECDL ImageMaker, ECDL Health, CTP. Plačiau apie šias programas 

skaitykite ECDL Fondo internetiniame tinklalapyje. 

1.2. ECDL Lietuva 

Lietuvoje yra ECDL Fondo atstovyb÷ ir sertifikuoti testavimo centrai, kuriuose išduodami 

ECDL pažym÷jimai. ECDL Lietuva organizacijai priklauso beveik šimtas testavimo centrų 31 

Lietuvos mieste bei vienas Minske, Baltarusijoje. Iki 2009 m. sausio pradžios išduota (ECDL 

Lietuva, 2009): 

• 22433 ECDL pažym÷jimai; 

• 19450 ECDL Pradmenų pažym÷jimai. 
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Pateikiami statistiniai duomenys apie testavimo centruose išduotų ECDL Pradmenų bei 

ECDL pažym÷jimų skaičių rodo, kiek procentų tai sudaro nuo visų išduotų pažym÷jimų skaičiaus. 

Jeigu asmuo yra išlaikęs pilną ECDL pažym÷jimą, jam ECDL Pradmenų pažym÷jimas 

neskaičiuojamas. 

Kaip matyti iš ECDL Lietuva tinklalapyje pateiktos statistikos, ECDL testavimo apimtys 

auga, tod÷l šios paslaugos kokyb÷s užtikrinimui bus skiriamas išskirtinis d÷mesys. Yra įsteigta 

ECDL Kokyb÷s valdymo komiteto Testavimo priežiūros komisija. Ji prad÷jo dirbti nuo 2006 metų 

liepos 1 dienos. Komisijos nariai iš anksto nepranešę lanko testavimo centrus ir stebi testavimo 

eigą. Už pasteb÷tus pažeidimus yra numatytos atitinkamos sankcijos (ECDL Lietuva, 2008 m. 

geguž÷s 18 d.]). 

Lietuvoje ECDL sklaidos darbus koordinuoja Lietuvos kompiuterinink ų sąjunga ir jos 

Kaune įkurta viešoji įstaiga „Informacini ų technologijų institutas" (ITI) . Ši viešoji įstaiga nuo 

2000 metų sausio m÷nesio yra oficiali ECDL Fondo atstovyb÷ Lietuvoje. Jų pagrindinis tikslas yra 

– skatinti informatikos kaip perspektyvaus šiuolaikinio mokslo ir svarbios ūkio šakos pl÷trą 

Lietuvoje (Lietuvos kompiuterininkų sąjunga, 2008). 

1.3. ECDL Core ir ECDL Advanced 

ECDL yra visame pasaulyje pripažįstamas dokumentas. Jis skirtas palengvinti įdarbinimo 

procedūras ir užtikrinti darbdavį, kad pretendentai į darbo vietą ir jau dirbantys asmenys sugeba 

dirbti kompiuteriu ir naudotis įprastomis programomis. ECDL yra žinias ir kompetenciją 

patvirtinantis pažym÷jimas, kuris remiasi vieninga pripažinta ECDL programa. ECDL tikslai 

(ECDL Lietuva, 2006): 

• Remti ir skatinti visuotinį kompiuterinį raštingumą. 

• Tobulinti pagrindinių žinių apie informacijos technologiją lygį ir asmeninių kompiuterių bei 

jų taikomosios programin÷s įrangos panaudojimo kompetencijos lygį visoje Europoje ir 

pasaulyje. 

• Garantuoti, kad visi kompiuterių vartotojai suprastų asmeninių kompiuterių naudojimo 

pranašumus ir privalumus. 

• Padidinti visų darbuotojų, kuriems reikia naudotis kompiuteriu, darbo našumą. 

• Leisti gauti didesnį pelną iš investicijų į informacijos technologiją. 

• Suteikti bazinę kvalifikaciją, kuri leistų visiems žmon÷ms jaustis informacin÷s visuomen÷s 

dalyviais. 

Šiais laikais darbo kompiuteriu įgūdžiai žmon÷ms tampa vis svarbesni visose gyvenimo 

srityse. ECDL yra informacijos technologijos pažym÷jimas visiems piliečiams. Jis skirtas tiems, 

kam reikia arba kurie nori žinoti, kaip naudotis asmeniniu kompiuteriu. Šis pažym÷jimas tinka visų 
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specialybių darbuotojams – ir tik žengiantiems į darbo rinką, ir bet kokio amžiaus žmon÷ms. 

ECDL standartas remiasi tuo, ką kompiuterio vartotojas turi žinoti apie informacijos 

technologiją ir asmeninius kompiuterius bei kokius asmeninių kompiuterių ir populiariausios jų 

taikomosios programin÷s įrangos panaudojimo įgūdžius jis turi įgyti. ECDL standarto numatytos 

būtinos žinių sritys ir įgūdžių grup÷s yra aprašytos ECDL programoje. ECDL programos tikslas – 

išvardinti faktus, kuriuos reikia žinoti, bei įgūdžius, kuriuos reikia įgyti pagal standarto 

reikalavimus. ECDL programoje nekalbama apie mokymo metodus, technologiją ir programas. Joje 

yra numatyti vieningi visai Europai kompiuterinio raštingumo egzaminų reikalavimai ir tų 

egzaminų laikymo tvarka. Standartines programas (Syllabus 4.0 ir 5.0) galima peržiūr÷ti ECDL 

Fondo internetiniame tinklalapyje (ECDL Fondas, 2008). 

1.3.1. ECDL Core programa 

ECDL Core yra praktinių įgūdžių ir geb÷jimų testai, kurie susideda iš septynių atskirų 

modulių, padengiančių tiek teorinius, tiek praktinius aspektus. Norint gauti ECDL pažym÷jimą, 

reikia s÷kmingai išlaikyti visų septynių modulių testus. ECDL Core sudaro šie septyni moduliai: 

• Modulis 1. Pagrindin÷s informacinių technologijų sąvokos 

• Modulis 2. Kompiuterio naudojimas ir bylų tvarkymas 

• Modulis 3. Tekstų tvarkymas 

• Modulis 4. Skaičiuokl÷s 

• Modulis 5. Duomenų baz÷s 

• Modulis 6. Pateikčių rengimas 

• Modulis 7. Informacija ir komunikacija 

Pirmasis modulis yra pagrindinių informacinių technologijų sąvokų teorinis testas, likę šeši 

moduliai yra praktinių įgūdžių testai. 

1.3.2. ECDL Advanced programa 

ECDL Advanced yra aukštesnio lygmens programa, skirta pažengusiems vartotojams, kurie 

jau turi ECDL Core lygio įgūdžius ir nori dar padidinti savo naudojimosi kompiuteriu įgūdžius. 

ECDL Advanced sudaro keturi moduliai: 

Modulis AM3. Tekstų tvarkymas (pažangesniu lygiu) 

Modulis AM4. Skaičiuokl÷s (pažangesniu lygiu) 

Modulis AM5. Duomenų baz÷s (pažangesniu lygiu) 

Modulis AM6. Pateikčių rengimas (pažangesniu lygiu) 
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ECDL Advanced moduliai suteikia galimybę tapti šių programų naudojimo ekspertais, kurių 

darbas yra organizuotas, efektyvus, produktyvesnis, jie gali išnaudoti visas taikomųjų programų 

galimybes ir šiuo būdu pateikti profesionaliai kokybišką darbo rezultatą. 

1.4. ECDL testavimas 

Lietuviškoji ECDL testavimo sistema sukurta 2000 metais, o pirmieji testai užfiksuoti 2000 

metų gruodį. Tad per pra÷jusius aštuonerius metus sukaupta nemaža šios sistemos naudojimo 

patirtis, leidžianti apibendrinti kai kuriuos testavimo dalykus, nurodyti sistemos trūkumus ir 

numatyti jos testavimo tolesnio tobulinimo poreikius ir galimybes. Galima analizuoti testavimo 

sistemos funkcionavimo ir kokyb÷s užtikrinimo klausimus, galimyb÷s pereiti prie testavimo 

taikomųjų programų aplinkose. Toks per÷jimas gali būti siejamas su testuojamojo atliekamų 

veiksmų įvertinimu, klausimų ar užduočių formulavimu. 

Oficialiuose testavimo centruose įdiegta automatizuota ECDL testavimo sistema. Ji 

integruota kartu su nuotolinio testų administravimo sistema. Testų administravimo sistemoje 

realizuotos statistikos rinkimo priemon÷s. Tai leidžia rinkti ir analizuoti testavimo kokybę 

apsprendžiančius rodiklius. 

S. Maciulevičius ir T. Lygutas (2007) rekomenduoja atsižvelgti į tai, kad ECDL testus 

laikantys asmenys yra labai skirtingo amžiaus, išsilavinimo, nevienodas jų pasirengimo būdas, 

tikslinga parengti ir naudoti: 

• demonstracinius testus, kurie leistų susipažinti su testo klausimų tipais, atsakymų 

pateikimo technika, supažindintų su testavimo aplinka; 

• bandomuosius testus, kurie sudarytų sąlygas pasitikrinti žinias ir įgūdžius prieš laikant 

tikruosius testus; 

• tikruosius ECDL testus, skirtus žinių ir įgūdžių atitikčiai ECDL Programos 

reikalavimams patikrinti ir ECDL pažym÷jimui išduoti. 

Be abejo, demonstraciniams testams keliami kiek mažesni reikalavimai, nes tai lemia 

nurodyta jų paskirtis. Svarbiausia – jie turi atitikti tikrųjų ECDL testų klausimų tipus ir struktūrą. 

Bandomieji testai dažniausiai siejami su pasirengimu laikyti ECDL testus, tad paprastai juos 

rengia mokymo organizacijos. Bandomuosius ECDL testus yra parengę mokymo centrai Lietuvoje, 

pavyzdžiui, Viešoji įstaiga Informacijos technologijų mokymo centras (Testai, 2008), A. 

Baltrukaičio kompiuterių mokykla (Navigatorius, 2008) bei UAB „Virtuali tikrov÷“ (E-kursai, 

2007). Tikrieji ECDL testai Lietuvoje laikomi siekiant įgyti ECDL ar ECDL pradmenų 

pažym÷jimą. Jų turinys nustatomas vienodas visoms šalims, kad ECDL pažym÷jimas gal÷tų būti 

pripažintas kiekvienoje Europos (ir ne tik Europos) šalyje. 
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1.5. ECDL testavimo problemos 

Kiekviena testavimo sistema yra svarbi konkrečios srities (technin÷s ar programin÷s įrangos, 

žinių patikrinimo ir pan.) pl÷tot÷s sudedamoji dalis. Renkantis tinkamą ar kuriant naują testavimo 

sistemą būtina atidžiai išnagrin÷ti tą sritį ir sudaryti sistemai keliamų reikalavimų sąrašą. Į tokių 

reikalavimų sąrašą įeina šie (AutomatedQA, 2008): 

• skirtingų platformų ir operacinių sistemų palaikymas, 

• tinkamų testavimo būdų palaikymas, 

• testavimo rezultatų registravimas. 

ECDL sertifikavimas iš pradžių buvo atliekamas rankiniu būdu. Testuojamajam buvo 

pateikiamos užduotys, kurių kiekviena vertinama tam tikru balų skaičiumi. Praktinių testų, kurie 

skirti naudojimosi kompiuteriu ir raštin÷s programomis įgūdžiams patikrinti, užduotys siejamos su 

veiksmais, atliekamais naudojant atitinkamas programas („My Computer“, „Internet Explorer“, 

„Outlook Express“, „Word“ ir pan.). Atliktų užduočių rezultatai fiksuojami laikmenoje (diskelyje), 

ir ji perduodama testavimo centro specialistams testavimo rezultatams įvertinti (S. Maciulevičius, 

T.Lygutas, 2007). 

Reikiamai testų kokybei užtikrinti buvo sukurta testų baz÷ (European Examinational 

Questions Base). Parengti testai buvo atsieti nuo konkrečios programin÷s įrangos („Microsoft“, 

atvirojo kodo ir pan.), sudarant sąlygas testuojamajam pasirinkti atitinkamas programas. 

V÷liau buvo pereita prie automatizuoto (kompiuterinio) testavimo, tam sukuriant specialias 

testavimo sistemas. Siekiant ir toliau išlaikyti reikiamą testų kokybę, ECDL fondas suformulavo 

reikalavimus testams ir testavimo procesui (Quality Standards, 2007; Quality Assurance, 2002), kai 

naudojamos kompiuterizuotos testavimo sistemos. Šie standartai paprasčiausiai tik siekiami. ECDL 

Fondas naudoja visapusišką Kokyb÷s užtikrinimo sistemą, kurią sudaro licencijų tur÷tojų Audito 

programa bei Kokyb÷s valdymo sistema. Pastaroji sistema užtikrina, kad visos vidin÷s organizacijos 

veiklos būtų vykdomos, užtikrinant efektyvumo, produktyvumo bei nuolatinį tobulinimosi 

principus. Ši sistema atitinka tarptautiniu mastu pripažįstamą ISO 9001:2000 standartą. 

Pirmosios kompiuterizuotos testavimo sistemos (taip pat ir sukurtoji Lietuvoje) labiau 

grindžiamos teorinių žinių patikrinimu. Praktiniuose testuose, be teorinių, pateikiami ir su 

atitinkamų programų praktiniu naudojimu susiję klausimai. Visgi testavimo sistemoje realizuotos 

galimyb÷s kiek riboja užduočių formulavimą ir:  

• iš testuojamojo reikalauja įsiminti įrankių, meniu komandų paskirtį, klavišų derinius, 

skirtus dažniausiai naudojamiems veiksmams inicijuoti; 

• sunkina dažnai reikalingų ir konkretiems dokumentams kurti bei koreguoti naudojamų 

veiksmų sekų formavimą; 
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• riboja atsakymo alternatyvų naudojimą. 

Rankinis ir automatizuotas testavimo būdai palyginti toliau pateikiamoje 1 lentel÷je. 

Lietuviškoji ECDL automatizuoto testavimo sistema naudojama jau daugiau nei aštuonerius 

metus. Ši testavimo sistema kartu vykdo ir administravimo funkcijas (testavimo centrų ir testuotojų 

registravimas, ECDL ar ECDL pradmenų pažym÷jimų išdavimas ir t. t.). Sukaupta testavimo 

sistemos eksploatavimo patirtis, susitikimai su testavimo centrų darbuotojais parod÷, kad sistema 

funkcionuoja patikimai, tačiau testavimo principas d÷l anksčiau pamin÷tų ribojimų tenkina ne visus 

jos naudotojus. 

 
1 lentel÷ 

Rankinio ir automatizuoto testavimo palyginimas 

 Rankinis testavimas Automatizuotas 
(kompiuterinis) testavimas 

Sąryšis su programine įranga 

Testai atsieti nuo konkrečios 
programin÷s įrangos; klausimai 
ar užduotys formuluojami taip, 
kad juos būtų galima atsakyti ar 
įvykdyti remiantis bet kuria 
programine įranga 
(„Microsoft“, atvirojo kodo ir 
pan.) 

Testai pritaikyti konkrečiai 
programinei įrangai 
(„Microsoft“, atvirojo kodo ir 
pan.); kiekvienai programin÷s 
įrangos versijai turi būti 
parengti atskiri klausimų ar 
užduočių rinkiniai 

Žinių ir įgūdžių tikrinimo 
ypatumai 

Praktiniams testams 
naudojamos atitinkamos 
programos, tod÷l testuojamasis 
gali laisvai pasirinkti užduoties 
atlikimo būdą ir priemones 

Testuojamasis privalo žinoti 
(įsiminti) užduoties atlikimo 
būdą, nurodyti pirmąjį žingsnį 
(veiksmą) ir tam reikalingą 
priemonę ar priemones 

Testavimo rezultatų įvertinimas 

Atliekamas rankiniu būdu, 
baigus testą ar vieno seanso 
metu laikytus testus. Tam 
reikia gana daug laiko, 
pasitaiko, kad rezultatai 
interpretuojami 
nevienareikšmiškai 

Atliekamas automatiškai baigus 
laikyti kiekvieną testą 

Reikalingi ištekliai 

Reikalingos laikmenos 
kiekvieno testuojamojo 
atsakymams ar testų užduočių 
rezultatams įrašyti ir saugoti 

Būtinas kompiuteris ir interneto 
ryšys 

Administravimas 

Atliekamas atskirai nuo 
testavimo; testavimo rezultatai 
įvedami rankomis 

Atliekamas automatizuotai; 
testavimo rezultatai fiksuojami 
automatiškai, baigus kiekvieną 
testą 

Šaltinis: MACIULEVIČIUS S., LYGUTAS T. (2007) Informacijos Mokslai, p. 42–43. 
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1.5.1. Testavimas taikomųjų programų aplinkoje 

Testavimo apimtys bei sistemos vartotojų testų kokyb÷s poreikiai nuolat did÷ja. Testų 

klausimus stengiamasi formuluoti taip, kad jie būtų kiek įmanoma artimesni realiame darbe 

atliekamiems veiksmams ar jų sekoms, kuriamos testavimo sistemos, tenkinančios augančius 

poreikius. Pasitelkus naujas technologijas buvo žengti pirmieji žingsniai kuriant naujo tipo 

testavimo sistemą taikomųjų programų aplinkoje. 

Dauguma šiuolaikinių taikomųjų programų turi specialias programavimo bibliotekas (API), 

leidžiančias valdyti visas programos aplinkoje realizuotas funkcijas. Šios bibliotekos įgalina 

fiksuoti įrankių juostos elementų ar meniu komandų pasirinkimus, apriboti tam tikras funkcijas (taip 

tikrinant vartotojo įgūdžius sprendžiant iškilusias problemas) ir pan. Taip pat galima sekti taikomąja 

programa tvarkomo dokumento turinio (pvz., teksto ar paveiksl÷lio) redagavimo eigą, dabartinę 

redaguojamo objekto būseną ir taip nustatyti, kada užduotis įvykdyta. Kaip pavyzdį galima pateikti 

tokį scenarijų: vartotojas gauna užduotį sukurti naują „MS Word“ dokumentą su „Header“ stiliaus 

antrašte „KAUNAS“ ir paryškintu tekstu „Kaunas yra miestas dviejų upių santakoje“ kitoje eilut÷je. 

Vartotojas „MS Word“ aplinkoje sukuria naują dokumentą, įveda užduotyje nurodytus tekstus, 

sutvarko jų formatus taip, kaip nurodyta užduotyje. Testavimo sistema stebi kiekvieną vartotojo 

žingsnį ir fiksuoja galutinį rezultatą. 

Tokios ECDL testavimo sistemos pavyzdžiu gali būti „Activ Training Limited“ (2008), 

„Litmus Learning (2008)“ naudojamos sistemos. Sistemų demonstracin÷s versijos testų užduoties 

pavyzdžiai pateikiami žemiau pirmame bei antrame paveiksluose. 
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Šaltinis: Activ Training (2008) [žiūr÷ta 2009 05 09]. Prieiga per internetą: 
<http://www.activ-training.com/Activ2007/DemoVideoLink.htm> 

1 pav. Activ Training testavimo sistemos darbo vaizdas. 
 

 
Šaltinis: Litmus Learning (2008) [žiūr÷ta 2008 06 06]. Prieiga per internetą: <http://213.132.41.74/atsdemo/english/> 

2 pav. Litmus Learning ATS testavimo sistemos darbo vaizdas. 
 

Testuojamajam pateikti „Word“ programos langai. Pirmuoju atveju testuojamasis turi 

išjungti automatinę Hyphenation (žodžių k÷limo) funkciją (1 pav.). Tai tik viena užduotis iš keleto 

šiame teste, pereiti prie kitos užduoties galima paspaudus mygtuką „Next“, tačiau jis aktyvuojamas 

tik atlikus šią užduotį. Pirmame paveiksle testuojamasis jau iškvietęs Hyphenation funkcijos 
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dialogo langą, jam reikia įsitikinti, ar teisingai sud÷ti paukščiukai prie pasirinkimo galimybių. 

Antruoju atveju jis turi pereiti į nurodytą atvertą dokumentą, po to jį įrašyti aplanke 

„My-Documents\nccwork“ internetinio puslapio formatu (2 pav.). Tai padaręs jis gal÷s pereiti prie 

kitos užduoties, paspausdamas mygtuką „Next Question“. Pirmame paveiksle matome prad÷tą 

vykdyti užduotį: testuojamasis jau išskleid÷ atvertų failų sąrašą ir iš jo gali pasirinkti reikiamą 

dokumentą. Kaip matyti iš pirmojo ir antrojo paveikslų, šios sistemos veikia taikomųjų programų 

aplinkoje, MS Word programos lange. Tai visiškai atitinka realią situaciją, kai žmogus naudojasi 

MS Word programa. 

Tačiau yra ir paprastesnių testavimo sistemų, kurios testuojamajam pateikia klausimus su 

galimais atsakymų variantais, arba su aktyvia programos lango paveiksl÷lio sritimi.. Tokias 

testavimo sistemas siūlo  „Third Force“ (2009) bei „Enlight“ (2008) e-mokymosi sistemos. 

Trečiame paveiksle testuojamajam pateikiamas klausimas, kur jis turi pasirinkti vieną 

atsakymo variantą iš keturių galimų. Kaip matome, testuojamasis yra pažym÷jęs ketvirtąjį atsakymo 

variantą, kuris nurodo, kaip pasikeis B2 cel÷je esančio skaičiaus rodymas paspaudus raudonai 

apvestą mygtuką. Ketvirtajame paveiksle testuojamajam pateikiamas klausimas, kur jis turi 

pažym÷ti aktyvią programos lango vaizdo sritį. Jam pateiktas klausimas apie failo išsaugojimą. 

Kaip matome, testuojamasis jau pažym÷jęs meniu punktą File, kurį reikia spausti, norint išsaugoti 

failą kietajame diske. Tokios testavimo sistemos yra paprastesn÷s, reikalauja įsiminti klavišų 

paskirtį, yra gan primityvios. 

 
Šaltinis: Third Force (2009) [žiūr÷ta 2009 05 22]. Prieiga per internetą: <http://www.thirdforce.com/products/it-
user-skills/ecdl-testing-solution/resources/demo/> 

3 pav. Third Force testavimo sistemos darbo vaizdas. 
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Šaltinis: Enlight (2008) [žiūr÷ta 2009 05 22]. Prieiga per internetą: 
<http://enlight.net/main/solutions/Enlight_Demo_Centre/ECDL_ICDL_Demo/index.html> 

4 pav. Enlight testavimo sistemos darbo vaizdas. 
 

Siekiant realizuoti tokio tipo sistemas, kaip Activ Training ar Litmus Learning, pirmiausia 

būtina išspręsti keletą svarbių klausimų. Vienas toks – kaip vertinti vartotojo veiksmus taikomosios 

programos aplinkoje. Būtina ištirti, ar yra svarbu, kiek laiko truko užduoties sprendimas, o gal šiam 

parametrui didesnę įtaką daro žmogaus charakterio bruožai. Neaišku, ar reikia vertinti, kiek 

veiksmų (mygtukų paspaudimų, meniu komandų parinkimo ir pan.) atliko vartotojas, ar jis, 

pavyzdžiui, klaidžiojo meniu juostoje, ieškodamas reikiamos komandos. O gal pakanka fiksuoti, 

kad užduotis atlikta teisingai, nekreipiant d÷mesio į atlikimo spartą, užtikrintą komandų žinojimą, 

reikalaujant tik to, kad visos užduotys turi būti atliktos per testui skirtą laiką. 

Kitas neaiškus klausimas – kaip geriau formuluoti užduotis vartotojui. Būtina išanalizuoti ir 

nustatyti, ar nekils situacijų, kai vartotojas bus įsitikinęs, kad užduotį atliko taip, kaip reikalaujama, 

o sistema nenustat÷, kad užduoties sprendinys yra tinkamas. 

VšĮ Informacinių technologijų institute buvo sukurtas daug galimybių atskleidęs tokios 

sistemos prototipas. Prototipo demonstracijos tik sustiprino įsitikinimą, kad tokio tipo testavimo 
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sistema yra labai reikalinga. Didelis susidom÷jimas šiuo nauju testavimo būdu užtikrina, kad 

anksčiau ar v÷liau tokia ji tikrai bus realizuota. Pirmieji žingsniai šia linkme jau žengti, realizacijos 

terminus lems taikymo galimybių tyrimų rezultatai. 

1.6. ECDL testavimo modelis 

Pastaraisiais metais tradicinius neautomatizuotus testus pakeičia kompiuteriniai testai. 

Kompiuteriniai testai turi daug pranašumų. Testuotojai gali laisvai prižiūr÷ti testavimą, tod÷l 

nusirašin÷jimo galimyb÷s tampa minimalios. Taip pat testuotojui nereikia skaičiuoti testuojamojo 

įvertinimo – vos baigus testą tai padaro kompiuteris. Naudojant internetą, testus galima atlikti bet kur 

– tai svarbu nuotolin÷ms studijoms. Tai tik keletas pagrindinių kompiuterinio testavimo privalumų. 

Tačiau norint patobulinti tokias testavimo sistemas, reikia išspręsti keletą problemų. 

Yra keletas testų pateikimo metodų, kiekvienas jų turi savo savybes, kurios bus aptartos 

v÷liau. Išanalizavus testų pateikimo metodus, bus pateikta informacija, kaip pagerinti lietuviškąją 

ECDL (European Computer Driving Licence) testavimo sistemą (Lithuanian ECDL TestEngine) ir 

kurie testavimo metodai geriausiai tinka konkrečiam ECDL produktui. ECDL pažym÷jimai 

išduodami atlikus tam tikrą vienos temos testų skaičių. Testai atliekami neautomatizuotai arba 

naudojant automatizuotas sistemas. Šioje srityje dabar – pasikeitimų metas. 

1.6.1. Lietuviškosios ECDL internetin÷s testavimo sistemos testų analiz÷ 

ECDL Core yra kompiuterinių įgūdžių pažym÷jimas, pripažįstamas daugyb÷s organizacijų 

visame pasaulyje. Šis pažym÷jimas parodo, kad jo savininkas turi pakankamai informacinių 

technologijų įgūdžių ir gali dirbti asmeniniu kompiuteriu bei atlikti įvairias užduotis, naudodamas 

labiausiai paplitusią programinę įrangą. 

ECDL Fondas paruoš÷ ECDL testavimo sistemų kokyb÷s valdymo dokumentaciją, kurioje 

apibūdinami technologijų ir įrangos reikalavimai, užsi÷mimų vykdymas, taip pat informacija, kaip 

turi būti atliekamas testavimas (tiek automatizuotas, tiek neautomatizuotas). Naudodami šią kokyb÷s 

valdymo dokumentaciją, ECDL Fondo nariai gali sukurti savo testavimo sistemas. 

ECDL Fondo atstovyb÷ kiekvienoje šalyje (ECDL Licensee) vykdo ECDL programą. 

Kiekvienos šalies Licensee patvirtina savo šalies testavimo centrus ir prižiūri, kad jie atitiktų 

reikalavimus. Testavimo centrai atlieka ECDL testavimą. Kai kuriose šalyse Licensees kuria savo 

testavimo sistemas, kitos naudoja komercinių programin÷s įrangos kompanijų sukurtas sistemas. 

ECDL fondas patvirtino tam tikras automatinio testavimo sistemas. Lietuviška internetin÷ ECDL 

testavimo sistema (Lithuanian ECDL TestEngine) yra viena jų. Tačiau abu testavimo sistemų tipai – 

sukurti vietoje ir komercinių gamintojų, turi privalumų ir trūkumų. Šiame dokumente išanalizuota 

lietuviška ECDL testavimo sistema TestEngine (ECDL Fondas, 2008). 
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1.6.2. Testo pateikimas testuojamam asmeniui 

Šiuo metu lietuviški ECDL TestEngine testai generuojami dviem skirtingais būdais 

(Analysis of ECDL testing, 2008). Kai LOTF testams klausimai pateikiami atsitiktiniu būdu, jie 

sugrupuojami pagal aukščiausią ECDL programos lygį (tema). Testų metu klausimai parenkami iš 

šių rinkinių. Tai iliustruoja 5 paveikslas. 

 
Šaltinis: DANIELIENö R., TELEŠIUS E. (2008) Analysis of Computer-Based ECDL Testing. 

5 pav. Atsitiktin ÷ klausimų tvarka (I būdas). 
 

Lietuviškas TestEngine taip pat naudoja kitą geresnį būda generuoti testų klausimams. 

Klausimai taip pat sukuriami naudojantis egzistuojančiomis ECDL programos versijomis. 

Šių testų metu klausimai atsitiktinai pasirenkami iš skirtingų ECDL programų. Tokiu būdu 

(pagerintu ATA) klausimų rinkiniai kiekvienam studentui bus skirtingi. Tai iliustruoja 6 paveikslas. 
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Šaltinis: DANIELIENö R., TELEŠIUS E. (2008) Analysis of Computer-Based ECDL Testing. 

6 pav. Atsitiktin ÷ klausimų tvarka (II b ūdas). 

1.6.3. Naujoviški lietuviškosios ECDL testavimo sistemos bruožai 

Sunku nuspręsti, kuris testų pateikimo metodas tur÷tų būti naudojamas. Kiekvienas metodas 

turi savo privalumų. Pirmosioms lietuviškoms ECDL testavimo sistemos versijoms buvo 

naudojamas CFT metodas. Pagrindin÷ to priežastis buvo „nuo nulio“ prad÷ti darbai – testavimo 

sistemas, naudojančias CFT metodiką, galima greitai įdiegti. Pradedant nuo antrosios versijos, tapo 

aišku, kad testavimą reikia atlikti įvertinant daugiau veiksnių. To pasiekti negalima naudojant 

klasikinį CFT testavimą. 

Lietuviškoje ECDL testavimo sistemoje buvo keturi užduočių tipai: 

• Teisinga – neteisinga pasirinkimas: šiuo atveju pateikiami du atsakymo variantai ir 

testuojamasis turi pasirinkti teisingą atsakymą 

• Keli pasirinkimai: šiuo atveju pateikiami keturi atsakymo variantai, ir testuojamasis turi 

pasirinkti teisingą atsakymą 

• Vieno pasirinkimo variantas spustelint paveiksl÷lio sritį 

• Keletas pasirinkimų paveiksl÷lyje: pateikiamas klausimas ir paveiksl÷lis, testuojamasis gali 

pasirinkti vieną iš keleto teisingų paveiksl÷lio sričių. 
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Testai gali būti grindžiami klausimais arba užduotimis. CFT testuose užduotimis grįstas 

testavimas neleidžiamas ECDL kokyb÷s užtikrinimo dokumentacijoje. Tod÷l sudarant testus 

prad÷tos kurti in-application dalys. Dar vienas naujas sprendimas lietuviškame TestEngine – 

išsaugoma informacija, kiek laiko testuojamasis užtruko atsakydamas į kai kuriuos klausimus, 

teisingų ir neteisingų atsakymų skaičius, tai panaudojama testų tobulinimui. 

Tačiau įmanoma išsaugoti informaciją apie pasirinktus ir pakeistus atsakymo variantus, 

praleistus klausimus, atsakymų trukmę – šios charakteristikos gal÷tų leisti nustatyti atsakymo 

efektyvumą. Toks efektyvumo įvertinimas gal÷tų būti svarbesnis, nei tradicinis teisingų atsakymų 

skaičiumi pagrįstas vertinimas. 

Dar viena naujov÷ internetin÷je TestEngine: pereita nuo d÷mesio sutelkimo klientinei pusei į 

serverio pusę. Tokiu būdu sukčiavimo rizika tampa minimali, visi duomenis yra Licensee pus÷je. 

Išnagrin÷jus internetinį testavimą ir įprastines testavimo sistemas, buvo pasirinktas ATA metodas 

pradinio lygio ECDL testams ir CAT metodas specializuotiems produktams. 

CAT testavimo metu klausimai testuojamiesiems pateikiami dinamiškai, pagal jų žinių lygį. 

CAT į testavimo procesą įtraukia naują komponentą, pagerindama kompiuterizuoto įvertinimo 

galimybę greitai ir tiksliai gauti ir saugoti informaciją apie testuojamo asmens rezultatus. Skirtingai 

nei tradicinis testavimas, CAT sistemose testuojamojo žinių lygis stebimas viso testo metu, po 

kiekvieno atsakymo. Šis rodiklis yra svarbus, nes kitas klausimas parenkamas pagal teisingą ar 

neteisingą prieš tai buvusio klausimo atsakymą. D÷l to kiekvienam klausimui automatin÷je 

klausimų ir testų baz÷je (AQTB) turi būti suteikiamas sud÷tingumo lygis. 

Klausimai pasirenkami Item response theory (IRT) metodu (Downing, 2006). Naudojant 

IRT, testuojamojo žinių lygio įvertinimas atnaujinamas po kiekvieno klausimo atsakymo ir pagal tai 

naujas klausimas parenkamas iš AQTB. 

CAT paprastai pradeda testą nuo vidutinio sunkumo klausimų. Jei atsakymas teisingas 

programa pateikia truput÷li sunkesn÷s kategorijos klausimą. Ir atvirkščiai, jei atsakymas 

neteisingas, pateikiamas lengvesnis klausimas. Šis procesas kartojamas, kol pasiekiama testo 

užbaigimo sąlyga. 

Naudojant adaptyvaus kompiuterinio testavimo būdą skiriami du klausimų tipai – dvilypiai 

(angl. dichotomous) ir daugialypiai (angl. polytomous) (J.M.Linacre, 2000). Naudojant dvilypius 

klausimus teisingas tik vienas atsakymas. Šiuo atveju naudojami skirtingi variantai su vienu 

teisingu atsakymu arba tiesa – netiesa tipo klausimas. Naudojant daugialypius klausimus galima 

pasirinkti keletą teisingų atsakymo variantų. Jei testuojamasis pažym÷jo ne visus teisingus 

atsakymus, jis gaus tik dalį už klausimą numatyto įvertinimo. Prieš naudojant CAT reikia tur÷ti 

pagrindinius adaptyvaus įvertinimo sistemos komponentus (E. Gouli, 2001): 

• Automated Tests and Questions Base (AQTB), 
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• Learner Assessment module (LA), 

• Question and Test Editor (QTE), 

• Presentation module (PM), 

• Test Adaptive Generation module (TAG). 

Šiame kūrimo etape paruošos pirmosios trys dalys, o paskutin÷s dvi dar kuriamos. 

1.7. Kompiuterizuoto testavimo naujov÷s 

Nepaisant did÷jančio kompiuterizuotų vertinimo sistemų sud÷tingumo, jų turimi testai 

dažniausiai yra senųjų popierinių testų kompiuterin÷s realizacijos. Vis d÷l to, šioje srityje atsirado 

naujovių ir šių naujovių pasekm÷s sparčiai skverbiasi į komercinę veiklą. Testai gali būt naujoviški 

keletu būdų. Naujoviškumas akivaizdus, kai testų turinys yra naujoviškas. Tačiau naujov÷s gali 

atsirasti ir ne tokiais akivaizdžiais būdais. Pats testo konstravimo metodas gali būti naujoviškas ir 

remtis kompiuterių technologijomis, taip pat ir taškų skaičiavimo metodas gali būti naujoviškas. 

Realyb÷je šie du naujoviškumo aspektai sąveikauja tarpusavyje, ir kai kurie įdomiausi testų turinio 

patobulinimai apima naujoves, kaip tas turinys yra kuriamas. 

Labiausiai akivaizdūs turinio naujovių pavyzdžiai kompiuterizuotame testavime yra testai, 

naudojantys garsą ar video vaizdą kaip daugialyp÷s terp÷s (angl. multimedia) elementus. Pavyzdžiui, 

interaktyvus video įvertinimas, kur naudojami video klipai ir po jų einantys daugialypio pasirinkimo 

klausimai. Modeliavimas kompiuteriu taip pat naudojamas vertinant realių darbų pavyzdžius. 

Pavyzdžiui, kompiuterizuota oro eismo veiklos efektyvumo matavimo sistema, arba supaprastintas 

nusileidimo stimuliatorius, naudojamas pilotų atrankose. 

Testų turinio naujov÷s reiškia labiau dinamiškų elementų naudojimą, tokių kaip drag-and-

drop elementai ar kitos panašios Windows pagrindu operacijos. Šie elementai naudojami dažniau nei 

paprasti point-and-click elementai popierinių testų daugialypio atsako modeliavimui. Testų turinio 

naujov÷s dažnai siejamos su naujais turinio generavimo metodais. Elementų generavimo metodai 

suteik÷ naujų tipų elementų palaikymo galimybę ir efektyvesnių įprastų elementų kūrimo galimybę. 

Programin÷ įranga leidžia gali pateikti itin detalią informaciją apie testuojamojo testo 

užduočių atlikimą. PĮ pateikia ne tik pateiktą atsakymą į klausimą, bet kiek testuojamasis užtruko 

atsakydamas konkretų klausimą, taip pat informaciją apie pasirinktus ir v÷liau pakeistus atsakymų 

variantus atsakymo į klausimus proceso metu. Sud÷tingesniems elementų tipams galima fiksuoti 

informaciją apie asmens veiksmus sprendžiant užduotį ar dalinių užduočių grupę. Kai kuriuose 

kompiuterizuotuose geb÷jimų testuose, kurie vykdomi be jokių laiko apribojimų, atsakymų laikas 

buvo normuojamas atskirai kiekvienam elementui, o atsakymo laukimo trukm÷ sumuojama kartu su 

tikslumu ir gaunamas efektyvumo matas. Šis efektyvumo matas buvo laikomas svaresnis nei įprastas 

teisingų atsakymų įvertinimas. Tačiau atlikus keletą eksperimentų su atsakymų laukimo trukm÷s 
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duomenų panaudojimu matuojant atsakymų stabilumą, buvo nuspręsta jo praktiškai nenaudoti 

personalo atrankos ir kitose I/O sistemose. 

Elementų atsako teorija (IRT) atsirado dar 1980-aisiais, tačiau jos taikymo sritis buvo 

apribota iki mokymo ir profesinių sričių. Ši teorija palyginus neseniai prad÷ta taikyti profesinio 

vertinimo srityje, nes atsirado galimyb÷ rinkti duomenis ir juos valdyti. IRT laikoma žymiu 

privalumu nagrin÷jant testų konstravimą elementų lygiu (Haladyna, 2004). IRT turi daug privalumų 

lyginant su tradiciniais metodais. Nors su ja susiję ir tam tikros sąnaudos: didesnių duomenų 

pavyzdžių poreikis, pagal kuriuos nustatomos elementų savyb÷s. Nors kompiuterin÷s technologijos 

suteik÷ galimybę įgyvendinti adaptyvųjį testavimą, tačiau profesin÷je srityje testų praktika buvo 

nežymi. Pagrindin÷ priežastis, kod÷l tradiciniai klasikiniai fiksuotų elementų rinkinio testai taip ilgai 

išsilaik÷, buvo infrastruktūra. Nei popieriniai, nei kompiuterizuoti testai n÷ra tinkami adaptyviam 

testavimui ir didelių elementų bankų naudojimui. Visa taip pakeit÷ Internetas. Aiškiai matyti, kad 

keičiasi žmonių požiūris į kompiuterizuotą testavimą, kai jie įvertina realią technologinio vertinimo 

naudą, bei kai šias taikomąsias programas palaikanti infrastruktūra plačiai paplinta. 

1.7.1. Praktin ÷s problemos 

Besivystant Internetu teikiamam kompiuterizuotam testavimui ir augant technologiniam 

produktų sud÷tingumui, iškyla problema užtikrinti, kad tie, kurie naudoja tokius testus ir įvertinimo 

įrankius, vadovautųsi gerąja praktika. Aptariamos ir kitos problemos (D.Bartram, 2005): 

• Interneto, kaip testų pateikimo terp÷s, efektyvumo charakteristikos ir techniniai 

apribojimai: greitis, tinklo vientisumas, patikimumas, pralaidumas ir kita; 

• Apsauga: leid÷jo intelektualin÷s nuosavyb÷s teisių apsauga, testų prieigos ir sklaidos 

kontrol÷, testų rezultatų ir taisyklių konfidencialumas; 

• Privatumas: prieigos prie testo rezultatų kontrol÷, teisiniai klausimai, susiję su duomenų 

apsauga, privatumas ir saugyklos; 

• Objektyvumas: prieigos prie tinklo lygiateisiškumas visoms grup÷ms – skaitmeninio 

padalinimo panaikinimas. 

Efektyvumas. Būtent efektyvumo srityje slypi pagrindiniai Interneto apribojimai. 

Testavimas kelia du pagrindinius reikalavimus pateikimo terpei. Pirma, ji turi suteikti testų 

pateikimo laiko skaičiavimo kontrol÷s priemones. Antra, ji turi būti tvirta ir nesugesti viduryje testo. 

Spartus puslapių pateikimo vartotojui negalima tik÷tis d÷l keleto priežasčių. Dauguma vartotojų vis 

dar naudoja l÷tą ryšį. Nors testų tiek÷jai gali užtikrinti, kad jų serveriai pateikia puslapius greičiau 

nei vartotojai jų užklausia, tačiau l÷tas ryšys vartotojo pus÷je ar kitos v÷linimas d÷l paties Intraneto 

gali iššaukti labai l÷tą puslapių vartymą vartotojo naršykl÷je. 
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Net jei vartotojas turi plačiajuostį ryšį ir Internete n÷ra jokio v÷linimo, pats sparčiausias 

atsiuntimas yra tiek vertingas, kiek juo galima pasitik÷ti. Pakibimas ir prarastas Interneto ryšys gali 

nutraukti testo sesiją per patį vidurį. Kai kuriais atvejais n÷ra praktiška tęsti testą nuo tos vietos, 

kurioje įvyko trikdis. Pavyzdžiui, n÷ra saugu pasikliauti Interneto vientisumu tuo mastu, kurio mums 

reikia testavimui laiko atžvilgiu, net jei esame tikri, kad puslapių srauto sparta yra pakankamai 

greita. 

Lengviausias būdas įveikti šias efektyvumo problemas yra parsisiųsti bet kokią laikui jautrią 

medžiagą kaip Java program÷lę (angl. applet). Tai bent jau užtikrina, kad testo administravimas laiko 

atžvilgiu nepriklauso nuo Interneto. Tačiau vartotojo požiūriu, tai gali sukelti kitą problemą: jei yra 

l÷tas ryšys ar program÷l÷ yra didel÷s apimties, gali užimti nemažai laiko jį parsisiųsti. Be to, daugelis 

organizacijų nepraleidžia program÷lių pro savo įmon÷s ugniasienes. 

Vaizdo darna. Internetas sudaro keletą problemų kaip autonomin÷ kompiuterizuota 

testavimo priemon÷. Pavyzdžiui, testų platintojas negali tiesiogiai valdyti vartotojo ekrano dydžio ar 

raiškos. Autonomin÷se sistemose programin÷s įrangos kontrol÷ gali būti panaudota ekrano 

nustatymų kitimo kraštutinumų sušvelninimui ar valdymui. Nors naršykl÷s pagrindu vykdomam 

testavimui kontrol÷s lygis yra žymiai mažesnis. Naršykl÷s yra sukurtos taip, kad navigacijos kontrol÷ 

naršant tinkle paliekama vartotojui, kad jis gal÷tų tirti ir modifikuoti puslapių vaizdavimo parametrus 

tokiu būdu, kuris tur÷tų būti neleistinas normalioje testo laikymo situacijoje. 

Be to, n÷ra vienos standartin÷s naršykl÷s. Šiuo metu rinkoje dominuoja dvi naršykl÷s: 

Internet Explorer ir FireFox (Internetinių naršyklių statistika, 2008). Deja šios abi naršykl÷s informaciją 

pateikia ne tokiu pačiu būdu. Taigi, testai gali atrodyti ir veikti skirtingai, priklausomai nuo 

naudojamos naršykl÷s. Šią problemą apsunkina faktas, kad visos egzistuojančios naršykl÷s dar turi 

skirtingas versijas, kuriose taip pat skiriasi, kaip jos atvaizduoja informaciją. 

Šių problemų sprendimas yra sukurti testą Java program÷l÷je, kurią būtų galima pasisiųsti į 

vartotojo kompiuterį ir įvykdyti. 

Apsauga. Apsaugos klausimai yra labai svarbūs tiems, kurie nerimauja d÷l Interneto 

naudojimo testavimui. Apsaugos reikalai turi būti apsvarstyti įvairių duomenų rinkinių atžvilgiu: 

• Pats testas (elementų turinys, taškų skaičiavimo taisykl÷s, normos, ataskaitų 

generavimo algoritmai, ataskaitų turinys). 

• Testo laikytojų tapatyb÷s – tiek jų autentiškumo patvirtinimas, tiek konfidencialumo 

išsaugojimas. 

• Testo rezultatai – užtikrinimas, kad tik turintys teisę prieiti prie testų rezultatų gal÷tų tą 

daryti. 
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Nepaisant visų aukščiau išvardintų sričių, į visa tai reikia atsižvelgti nagrin÷jant, kokiomis 

savyb÷mis pasižymi Internetas, kaip testavimo terp÷, lyginant jį esamomis alternatyvomis: popierinis 

testavimas ir autonominis kompiuterizuotas testavimas. 

Testų apsauga. Esminis Interneto bruožas yra tas, kad, išskyrus pačią naršykl÷s programinę 

įrangą, visos taikomosios programos ir visi duomenys glūdi serveryje, o ne vartotojo kompiuteryje. 

Čia slypi pagrindiniai Internetinio testavimo privalumai: 

Visa svarbi intelektualin÷ nuosavyb÷, susijusi su testu (taškų skaičiavimo taisykl÷s, normos, 

ataskaitų generavimo taisykl÷s ir kt.) lieka serveryje, valdomame testų platintojo. 

1.8. Kompiuterinio testavimo įgyvendinimo metodai 

Kompiuterinis mokymas yra toks mokymo tipas, kai studentas mokosi atlikdamas specialias 

programas, naudodamas kompiuterį. Toks ugdymo procesas ypatingai efektyvus mokant žmones 

naudotis kompiuterių programomis ir besimokantieji taip gali gauti naujos informacijos bei 

pagerinti savo žinias. Kompiuterinis mokymas paprastai kaip vieną sudedamųjų dalių apima ir 

kompiuterinį testavimą. 

1.8.1. Computer fixed testavimas 

Computer fixed testavimas (CFT) naudoja paprasčiausią testų pateikimo metodą, kuris 

grindžiamas įprastinio neautomatizuoto testavimo modeliu. CFT pateikiamas nuosekliai, tod÷l tokie 

testai dar vadinami tiesiniais kompiuterizuotais testais. CFT pagrindiniai bruožai yra: 

• Testas yra fiksuoto ilgio (trukm÷s) 

• Klausimai gali būti pateikiami fiksuota arba atsitiktine tvarka 

• Paprastai vertinama pagal teisingų atsakymų skaičių 

Kaip C. Parshall ir kiti (2002) teigia savo darbe, fraz÷ „kompiuterizuotas testavimas“ tapo 

viską apimančia fraze, kuri apima įvairias kompiuterizuoto vertinimo rūšis, pavyzdžiui, 

elektroninius puslapių vartykles, kompiuterizuotus testus, kompiuterinius adaptyvius testus ir kita. 

Tačiau autoriai CFT testus apibr÷žia kaip fiksuotus tiek testo formos, tiek testo apimties prasme. 

CFT testai apima tokius pat elementus kaip ir atitinkantys popieriniai testai, dar žinomi kaip 

elektronin÷s puslapių vartykl÷s. CFT privalumas yra tai, kad jie kiek įmanoma pam÷gdžioja 

popierinius testus, tačiau taip apriboja gluminančių faktorių kiekį lyginant šių dviejų testų metodų 

rezultatus. Pavyzdžiui, CFT testai leidžia testuojamiems asmenims praleisti elementus, taip pat 

pakeisti atsakymo variantą ankstesniame klausime, kaip ir popieriniame teste. Tai leidžia išlaikyti 

pastovias testų laikymo strategijas taikant įvairius modelius. CFT testavimo trūkumas yra tai, kad 

testuojami asmenys turi susidurti su per lengvais, arba per sunkiais elementais, kadangi testo forma 

yra fiksuota trukm÷s atžvilgiu ir gali apimti plačią elementų sunkumo lygių sritį. Nors CFT ir 
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naudojasi specialiomis kompiuterių galimyb÷mis, tačiau gali būti sunku išlaikyti testų saugumą, 

kadangi yra labai ribotas CFT testų formų kiekis. 

1.8.2. Linear-on-the-fly testavimas 

Linear-on-the-fly testavimas (LOTF) testai turi nustatytą trukmę ir yra unikalūs ir neadaptyvūs. 

LOTF pagrindiniai bruožai yra: 

• Testas yra fiksuoto ilgio (trukm÷s) 

• Testas unikalus kiekvienam testuojamajam, tod÷l reikalinga didel÷ užduočių baz÷ 

• Naudojant šį testavimo metodą, pager÷ja saugumas 

Linear-on-the-fly testavimas naudojamas mokomiesiems arba profesionaliems testams. 

LOFT metodas yra tarsi kompromisas tarp tradicinio fiksuotos formos ir kompiuterizuoto 

adaptyvaus testavimo. Šis metodas išlaiko testuojamojo matomo elementų rinkinio 

ekvivalentiškumą ir kartu mažina elementų atkleidimo galimybę bei padidina testo saugumą 

(LOFT, 2008). 

Plačiausiai žinomus fiksuotos formos testus naudojančios organizacijos nustato vieną ar 

kelis elementų rinkinius, kurie testų metu pateikiami kartu. Pavyzdžiui, tarkim teste yra 100 

elementų, o organizacija pageidavo dviejų testo formų. Sukuriamos dvi formos, kiekviena su 

fiksuotu 100 elementų rinkiniu, kai kurie iš jų tur÷tų sutapti, kad būtų galima palyginti. Visi 

testuojamieji, laikantys testą, gauna vieną iš dviejų sukurtų formų. 

Jei testą laiko didelis asmenų skaičius, testo saugumui gali iškilti pavojus. Daugelis testo 

elementų taps gerai žinomi testuotojų tarpe. Siekiant to išvengti, reikia sukurti žymiai daugiau 

formų. 

LOFT metodas viską iš esm÷s pakeičia ir sukuria unikalų testą kiekvienam testuojamajam, 

atsižvelgiant į testavimo programos apribojimus. Vietoj to, kad būtų pateiktas fiksuotas elementų 

rinkinys, kompiuteriui, prie kurio laikomas testas, pateikiamas didelis elementų telkinys. 

Kompiuteriniai programai pateikiami pseudo-atsitiktinai parinkti tokie elementai, kad kiekvienam 

testuojamam asmeniui pateikiamas testas yra lygiavertis turinio ir statistinių charakteristikų 

atžvilgiu, net jei jis sudarytas iš skirtingo elementų rinkinio. Tai sukuriama elementų atsako teorijos 

IRT pagalba. 

Taigi, LOFT testai yra unikalūs ir fiksuoto ilgio, konstruojami kiekvienam vartotojui. 

Konstruojant tokius testus reikia atsižvelgti į turinio objektą ir kitas specifikacijas. Kadangi 

konstruojant testo formas į testuojamo asmens kvalifikaciją n÷ra atsižvelgiama, taigi šie testai n÷ra 

adaptyvūs (M. Al-A‘ali, 2007). LOFT testų konstravimo privalumas yra tas, kad jie tenkina 

elementų atskleidimo galimybių mažinimo ir griežtus turinio reikalavimus. Tačiau pagrindinis 
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privalumas yra padidintas saugumas, kuris sukuriamas pateikiant skirtingus elementus testų 

formose. 

1.8.3. Automatizuotas testų surinkimas 

Automated test assembly (ATA) testai turi nustatytą trukmę ir testų pateikimas n÷ra 

adaptyvus. Pagrindiniai ATA bruožai yra: 

• Testas yra fiksuoto ilgio (trukm÷s) 

• Testuojamieji gauna skirtingus testo variantus 

• Testo formos gali būti sukurtos prieš jam prasidedant 

Kadangi kompiuteriai prad÷ti plačiai taikyti tiek mokomiesiems, tiek kvalifikaciniams 

tikslams, atsirado poreikis automatizuotam testų surinkimui, kuris naudingas didel÷s apimties 

testavimui. Testai gali būti konstruojami automatiškai taikant matematinius programavimo 

modelius. Matematiniai modeliai turi tur÷ti optimalų sprendinį, kuris tenkina ir problemos sąlygas, 

ir užduoties tikslus. 

Tokiuose testuose vietoj to, kad vienu metu būtų sukuriama viena individuali testo forma, 

yra įprasta surinkti rinkinį iš analogiškų testo formų iš elementų telkinio (K.Soojin, 2004). Kadangi 

didel÷s apimties vertinimai reikalingi didel÷ms grup÷ms, labai svarbu pateikti analogiškas testų 

formas visoms testavimo sesijoms įvairiose vietose. Jei vertinimas pagrįstas IRT, formos gali būti 

analogiškos tiek, kiek kiekviena jų apima reikalingų elementų kombinacijų, kurie reikalingi atitikti 

visas testo specifikacijas. 

Kaip min÷ta, testų specifikacijos naudojamos kaip testų surinkimo pagrindas. Yra dvi 

specifikacijų rūšys – tikslų ir apribojimų [kims]. Tikslai reikalauja, kad testo atributai ar elementų 

funkcijos atributai įgytų minimalią ar maksimalią vertę. Tod÷l tikslai gali būti formuluojami kaip 

matematin÷s funkcijos, kurias reikia optimizuoti. Apribojimai reikalauja, kad testų atributai ar 

elemento funkcijos atributai atitiktų viršutinę arba apatinę ribą. Šie apribojimai gali būti 

formuluojami kaip matematin÷s lygyb÷s ar nelygyb÷s. Apribojimų kiekis, priešingai nei tikslų, yra 

neribotas, priklausomai nuo testo specifikacijų ir sąlygų. Yra trys pagrindiniai apribojimų tipai – 

kategorin÷s elementų charakteristikos, kiekybin÷s elementų savyb÷s ir elementų tarpusavio 

priklausomyb÷s. 

Taigi, testų surinkimas pasižymi tuo, kad testai yra sudaromi iš elementų telkinio pagal 

konkrečias testavimo reng÷jų sukurtas specifikacijas. Dauguma ATA modelių yra pagrįsti 

matematin÷mis programavimo technologijomis. Dažniausias tikslas – kaip įmanoma tiksliau 

išmatuoti testuojamųjų geb÷jimų lygį, atsižvelgiant į testo specifikacijų pateiktus apribojimus. 

Apribojimai gali apibr÷žti testo turinį, elementų tipus, laiko limitą, bendrą žodžių kiekį ir kita 
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(H.A.Huitzing, 2006). Buvo sukurta daug ATA modelių, kurių dauguma įgyvendinami tiesinio 

programavimo modeliais. 

ATA trūkumas – jei apribojimai prieštarauja vienas kitam, negalima sukurti jokio testo. 

Tuomet testo surinkimo modelis laikomas neįvykdomu. 

1.8.4. Kompiuterinis adaptyvusis testavimas 

Computer adaptive testavimas (CAT) pateikimo metodo testai sukuriami kiekvienam 

testuojamajam individualiai. Kitas klausimas parenkamas priklausomai nuo prieš tai pateiktų 

atsakymų. CAT testavimo pagrindiniai bruožai: 

• Užduočių eiliškumas ir testo ilgis (trukm÷) priklauso nuo atsakymų į klausimus 

• Tikslus kiekvieno testuojamojo žinių įvertinimas 

• Užduotys skirstomos pagal sunkumo lygius 

Adaptyvusis testavimas „prisitaiko“ prie testuojamojo įgūdžių lygio. Klausimai iš eil÷s 

parenkami taip, kad testo tikslumas maksimaliai atitiktų tai, kas žinoma apie testuojamą asmenį iš 

ankstesnių klausimų. Testo sunkumas adaptuojasi priklausomai nuo geb÷jimų lygio. Pavyzdžiui, jei 

testuojamas asmuo gerai atsako į vidutinio sunkumo kausimą, jam toliau bus pateiktas sunkesnis 

klausimas. Arba, jei jis atsak÷ prastai, jam bus pateiktas lengvesnis klausimas. Palyginus su 

statiniais daugybinio pasirinkimo testais, adaptyvūs testai reikalauja mažiau testo elementų, kad 

pasiektų vienodai tikslius rezultatus (CAT, 2008). 

Kaip ir daugeliu kitų metodų atveju, skirtingiems vartotojams pateikiami skirtingi testai. 

Teisingas rezultatų įvertinimas tarp skirtingų elementų rinkinių apskaičiuojamas remiantis IRT. 

Remiantis šia teorija taip pat parenkami optimalūs elementai. 

Adaptyvus testavimas pateikia vieningus, tikslius rezultatus. Adaptyvių testų apimtis gali 

būti sumažinta 50%, tačiau jie vis tiek išlaikys aukštesnį tikslumo lygį, nei fiksuoti testai. CAT 

testai rezultatus pateikia iš karto atlikus testą. Šis metodas taip pat sumažina elementų atskleidimo 

galimybę, nes testuojamiems asmenims patiekiami skirtingi variantai. 

Tačiau CAT pagrindinis trūkumas yra tas, kad sunku sukalibruoti elementų telkinį. 

Modeliuojant elementų charakteristikas, visi testo elementai turi būti suskirstyti yra apibr÷žto 

dydžio imtį ir tuomet analizuojami. Tam į operacinius testo elementus reikia įterpti naujus 

elementus. Tai sukelia logistines, etines ir apsaugos problemas. CAT draudžiama atsakytų elementų 

peržiūra dažnai sukelia vartotojų nepasitenkinimą. 
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2 lentel÷ 

Testavimo metodų analiz÷s apibendrinimas 
Metodas Privalumai Trūkumai 

Computer fixed testavimas 

Testas kompiuterizuotas. 
Testas yra fiksuoto ilgio 
(trukm÷s). 
Klausimai gali būti pateikiami 
fiksuota arba atsitiktine tvarka. 
Paprastai vertinama pagal 
teisingų atsakymų skaičių. 

Primityvus metodas. 
Žemas saugumo lygis. 
Labai mažai skirtingų testų 
variantų. 

Linear-on-the-fly-testavimas 

Unikalūs ir fiksuoto ilgio, 
konstruojami kiekvienam 
vartotojui testai. 
Didesnis saugumo lygis. 

Mažai skirtingų testų variantų. 
Netinka sud÷tingesn÷ms 
testavimo sistemoms ar 
didel÷ms testavimo apimtims. 

Automatizuotas testų 
surinkimas 

Testas yra fiksuoto ilgio 
(trukm÷s). 
Testuojamieji gauna skirtingus 
testo variantus. 
Testo formos gali būti sukurtos 
prieš jam prasidedant. 
Apribojimai ir specifikacijos 
leidžia kurti testus pagal 
unikalius reikalavimus. 
Testų variantų įvairov÷. 

Jei apribojimai prieštarauja 
vienas kitam, negalima sukurti 
jokio testo. Tuomet testo 
surinkimo modelis laikomas 
neįvykdomu. 

Kompiuterinis adaptyvusis 
testavimas 

Užduočių eiliškumas ir testo 
ilgis (trukm÷) priklauso nuo 
atsakymų į klausimus. 
Tikslus kiekvieno testuojamojo 
žinių įvertinimas. 
Užduotys skirstomos pagal 
sunkumo lygius. 
Adaptyvus testavimas pateikia 
vieningus, tikslius rezultatus. 
Išlaiko aukštesnį tikslumo lygį, 
nei fiksuoti testai. 
Testai rezultatus pateikia iš 
karto atlikus testą. 
Sumažina elementų atskleidimo 
galimybę. 

Sunku sukalibruoti elementų 
telkinį. 
Modeliuojant elementų 
charakteristikas, visi testo 
elementai turi būti suskirstyti 
yra apibr÷žto dydžio imtį ir 
tuomet analizuojami. 
Draudžiama atsakytų elementų 
peržiūra dažnai sukelia 
vartotojų nepasitenkinimą. 

Šaltinis: sudaryta autoriaus. 

Kompiuterizuoto testavimo privalumai  yra kaštų taupymas spausdinimui ir siuntimui, testų 

saugumo pagerinimas, kadangi yra sąlyginai paprasta valdyti ir saugoti elektroninius failus, 

priešingai nei testų formų krūvas ir knygeles. Dar vienas privalumas yra tai, kad testų duomenys 

kompiuteriu automatiškai surenkami testo administravimo metu, taip supaprastinamas testo 

įvertinimo procesas. 

Kitos kompiuterizuotų testų valdymo savyb÷s naudingos testuojamiesiems. Pavyzdžiui, 

dauguma kompiuterizuotų testų siūlo tiesioginį testų rezultatų pateikimą. Kompiuterizuotas 
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valdymas taip pat suteikia didesnį vertinimo efektyvumą, tai dažniausiai reiškia trumpesnius testus. 

Dar vienas privalumas testuojamiesiems yra tas, kad  dauguma kompiuterizuotų testavimo 

programų suteikia galimybę dažnai laikyti testus, palyginus su paprastais popieriniais testais. 

Dar vienas svarbus kompiuterizuoto testavimo privalumas yra galimyb÷ naudoti naujoviškus 

elementų tipus. Kompiuterizuotas valdymas leidžia išpl÷sti vertinamų  pažinimo įgūdžių ir procesų 

tipų formas, taip pat leidžia rinkti papildomus duomenis testo metu. Pavyzdžiui, galima aiškiai 

atskirti elementus, kurie buvo praleisti, neatlikti nuo tų, kurie buvo nepasiekti. Taipogi, galima 

steb÷ti, kiek laiko testuojamasis praleidžia prie kiekvieno elemento, arba jo atsako laukimo trukmę. 

Kompiuterizuoti testai labai svarbūs savo technologiniu pateikimu neįgaliems 

testuojamiesiems. Tai ir stambaus šrifto ar garso pateikimas regos negalią turintiems 

testuojamiesiems, alternatyvios įvesties prietaisai testuojamiesiems, kurie negali rašyti bei kiti 

specialūs pritaikymai. 

1.8.5. Vartotoj ų požiūris į adaptyviuosius testavimo metodus 

Nors kompiuteriniai testai turi daug savybių, kurių negali pasiūlyti popieriniai testai, jie taip 

pat turi apribojimų. Vienas pavyzdžių, kad adaptyvūs testai dažniausiai neleidžia testuojamiesiems 

praleisti klausimų bei peržiūr÷ti ar pataisyti savo atsakymų į ankstesnius klausimus. Testuojamieji 

linkę griežtai nesutikti su šiuo apribojimu. Jiems nepatinka nelankstus testo įgyvendinimo metodai, 

kurie neleidžia praleisti klausimų, peržiūr÷ti ar pataisyti atsakymų į ankstesnius klausimus. Iš 

esm÷s, kai kurie testuojamieji nurod÷, kad jų noras laikyti testą kompiuterio pagalba priklauso nuo 

galimyb÷s peržiūr÷ti klausimus. Nors ir yra įmanoma struktūriškai įgyvendinti adaptyvų testo 

metodą taip, kad būtų įtraukta peržiūros galimyb÷, tačiau tai yra problematiška. Tai gali sumažinti 

vertinimo efektyvumą ir gali sąlygoti dirbtinai padidintus geb÷jimų vertinimus. Vienas variantas 

gali pelnyti pripažinimą yra – leisti testuojamiesiems peržiūr÷ti ribotą klausimų kiekį, pavyzdžiui, 

nedidelį 5 klausimų rinkinuką. Šis požiūris tenkina testuojamųjų norą peržiūr÷ti klausimus 

nepaveikiant geb÷jimų vertinimo. 

Testuojamieji taip pat išreišk÷ norą peržiūr÷ti būsimus klausimus, kad gal÷tų įvertinti likusių 

testo klausimų kiekį ar sud÷tingumą ar atitinkamai steb÷ti savo testo atlikimo laiką. Tik keletas 

CAT testavimo programų šiuo metu leidžia peržiūros ir atsakymo pakeitimo režimus, nors kai 

kurios kompiuterin÷s klasifikavimo testavimo programos leidžia. Dauguma adaptyvių testų negali 

leisti testuojamiesiems peržiūr÷ti klausimų, bet kuriuo atveju, būsimi adaptyvaus testo klausimai 

nebuvo nustatyti. 

Testuojamųjų reakcija į kitus konkrečius adaptyvių testų aspektus gali būti labai apgaulinga. 

Pavyzdžiui, tipinis CAT gali sąlygoti testuojamąjį atsakyti teisingai tik į pusę  pateiktų klausimų. 

Taigi, adaptyvus testas tik÷tina taps sunkesniu testavimo išbandymu nei dauguma testuojamųjų 
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tikisi, ypač gabių testuojamųjų. Žinant, kad dauguma adaptyvių testų neleidžia peržiūr÷ti ir pakeisti 

atsakymų į klausimus, dauguma testuojamųjų gali pernelyg nerimastingai pateikti savo atsakymą. Ir 

d÷l to, kad dauguma adaptyvių testų yra trumpesni, testuojamieji gali labiau jaudintis d÷l kiekvieno 

jų atsakymo įtaka testui. Jei adaptyvus testas pilnai neapr÷pia testo programos turinio, testuojamieji 

gali jaustis neturintys palankių sąlygų, tuo požiūriu, kad jų stipriosios žinių pus÷s n÷ra pilnai 

išreiškiamos ar net vertinamos. Kintamo ilgio testai gali trikdyti testuojamuosius, nes jie nežinos, 

kokio ilgio bus testas ir kaip atsakingai paskirstyti laiką ir energiją. Kai kintamo ilgio testas trunka 

labai neilgai, testuojamieji gali jaustis taip, lyg jiems n÷ra suteikiama galimyb÷ pademonstruoti 

pilną įgūdžių lygį. Testuojamieji taip pat gali netinkamai interpretuoti testo adaptyvumą, tuo atveju, 

kai jie pagalvoja, jog staiga buvo pateiktas lengvesnis klausimas, ši prielaida apie prieš tai 

neteisingai atsakytą klausimą gali sukelti stresą. 

Rekomenduojama, jei tik įmanoma, kad testavimo programa tur÷tų leisti testuojamajam 

praleisti, peržiūr÷ti klausimus ir pakeisti atsakymus. Taip pat verta skirti d÷mesio testų 

sud÷tingumui – klausimai tur÷tų tur÷ti sud÷tingumo lygmenis, bet atsakymo į klausimą tikimyb÷ 

tur÷tų būti didesn÷ nei 0,5. Šie testo administravimo pakeitimai gali nežymiai sumažinti testo 

efektyvumą. Taip pat reik÷tų skirti laiko ir paaiškinti testuojamiesiems apie adaptyvaus testavimo 

aspektus, tam kad jie mažiau nerimautų. Tur÷tų būti paaiškinamas vertinimo modelis bei žinių 

turinio padengimas. 

1.9. ECDL Advanced klausimyno sudarymo modelis 

Kintant technologijoms kartu kinta ir žmonių naudojimosi technologijomis įpročiai. Tod÷l 

kartu atitinkamai turi keistis ir ECDL Advanced klausimynas, kad užtikrintai išliktų kaip tinkama 

sertifikavimo priemon÷. Tod÷l ECDL Advanced klausimynas turi būti nuolat peržiūrimas. 

Klausimyno tikslinimo metu turi būti vadovaujamasi Projektavimo principais, kurie suteikia loginį 

pagrindą atliekant klausimyno peržiūrą, nurodo pagrindinius šio proceso žingsnius. 

1.9.1. Bendrieji klausimyno sudarymo motyvai 

Planuojant klausimyno peržiūrą, reikia atsižvelgti į šiuos pagrindinius ECDL Advanced 

klausimyno sudarymo motyvus: 

o Paplitimas: Turi būti siekiama išlaikyti ECDL Advanced klausimyno žinių/įgūdžių 

elementų ir modulių struktūros aktualumą bei paplitimą. 

o Kokyb÷: Turi būti siekiama pateikti tikslesnį klausimyno apibr÷žimą, kad būtų 

išlaikomas aukštos kokyb÷s sertifikavimo programos vystymas, įskaitant mokomosios 

programos ir testų. 
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o Struktūra:  Turi būti siekiama pateikti tobulesnę kategorijų, įgūdžių grupių, užduočių 

elementų struktūrą. 

o Tęstinumas: Turi būti siekiama užtikrinti, kad ECDL Core ir ECDL Advanced 

klausimynai yra atitinkamai suvienyti. 

o Prieinamumas: Turi būti projektuojama atsižvelgiant į prieinamumą visuose lygiuose 

nuo klausimyno apibr÷žimo etapo iki testų specifikavimo etapo. 

o Naujoviškumas: Turi būti siekiama siūlyti veiksmingumo ir produktyvumo koncepcijos 

žinioms ir įgūdžiams, aprašomiems ECDL Advanced moduliuose. 

1.9.2. Klausimyno projektavimo principai 

Remiantis ankstesniame skyriuje išvardintais klausimyno sudarymo motyvais, sudaromi 

penki pagrindiniai klausimyno projektavimo principai: 

o Technologinis pokytis. Kai kurie didieji programin÷s įrangos pardav÷jai vis kuria 

naujas programin÷s įrangos versijas, kuriose atsiranda naujų naudojamų įrankių. Tai 

sukuria naujus reikalavimus mokymui ir sertifikavimui. 

o Geroji praktika. Gerosios praktikos elementai palaiko produktyvų ir veiksmingą 

klausimyne aprašomų įgūdžių įgyvendinimą. 

o Vartotoj ų praktika. Būdas, kuriuo tipiniai ECDL Advanced kandidatai naudojasi 

atitinkamomis technologijomis, taip pat kinta. Ko gero, dabar labiau akcentuojama 

taikomųjų programų integracija nei ankstesniais metais. Be to, galima prid÷ti naujų 

Advanced modulių, kad programa išsipl÷stų už savo dabartin÷s keturių modulių 

(Advanced Word, Advanced Spreadsheets, Advanced Database, Advanced Presentation) 

struktūros ribų. 

o Patobulinimai. Svarbi ECDL Advanced klausimyno projektavimo dalis yra apsvarstyti 

galimus ar reikalingus klausimyno apibr÷žimo patobulinimus, atsižvelgiant į vartotojų 

pasiūlymus. ECDL klausimyno maksimalaus prieinamumo priemon÷s ir standartai bus 

kuriami tiek klausimynui, tiek testų baz÷s projektavimui. Tai paveiks formatavimą, 

išd÷stymą, taip pat klausimyno elementų ir klausimų sudarymo principą. 

o Programų valdymas. Įgūdžių grup÷s skirtos sugrupuoti klausimyno elementus. Geram 

įgūdžių grup÷s aprašui naudojama tiksli kalba įgūdžių srities detalizavimui; turi 

atitinkamą svorį, balansą ir seką, atitinkančią jame esančius elementus; tai užtikrina 

įgūdžių grup÷s susietumą su visu modulio turiniu. 
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2. SIŪLOMA ECDL TESTAVIMO SISTEMOS ARCHITEKT ŪRA 

Viena pagrindinių problemų įgyvendinant kompiuterizuotą testavimą yra testo konstrukcija 

ir testo įgyvendinimo modelis. Kompiuterizuotam testavimui naudojami modeliai, aptarti 

ankstesniuose šio darbo skyriuose, yra fiksuotų elementų testai (fixed-item), tiesiniai testai (linear 

on-the-fly), automatizuoto surinkimo (automated test assembly), adaptyvūs testai (adaptive). 

Problema yra ta, kad kiekvienam iš šių modelių reikia skirtingų sistemų ir operacinių procedūrų 

testavimo įgyvendinimui ir palaikymui. 

Bet kurį iš testavimo modelių galima patalpinti į vieną iš dviejų plačių kategorijų: iš anksto 

sukonstruotų testų; arba realiu laiku sukonstruotų testų. Iš anksto sukonstruoti tetai surenkami 

neprisijungus ir kai reikia persiunčiami testavimo centrams. Testams, kurie konstruojami realiu 

laiku, dažniausiai reikia testo pateikimo tvarkykl÷s – pagrindinio komponento , kuris suteikia 

didelio funkcionalumo duomenų valdymo, testų surinkimo, konstravimo, testų administravimo ir 

rezultatų vertinimo atžvilgiu. Tokiu atveju, testuojamajam pateikiama unikali testo forma, bet kartu 

reikalaujama, kad sistema tvarkytų didžiulius galimų testų kiekis. Dar sud÷tingiau yra tai, kad 

konkreti testo forma n÷ra žinoma, kol testuojamasis nebaig÷ testo. 

Kompiuterizuoto testo konstravimas sukeliu didelių rūpesčių operacinei sistemai, ypač 

kalbant apie sistemos našumą ar efektyvumą, duomenų valdymą, testo formų kokyb÷s kontrolę. 

Žvelgiant iš testų vystymo perspektyvos, galima būtų ginčytis, kad yra tam tikrų testų vystymo ir 

konstravimo kokyb÷s užtikrinimo aspektų, kuriuos geriausiai kontroliuoja ar bent jau stebi žmon÷s. 

Tačiau šis požiūris nesudaro kliūčių naudoti kompiuterizuotą adaptyvų testavimą (CAT). Testas gali 

būti adaptyvus ir kartu sukonstruotas tokiu būdu, kuris suteikia kokyb÷s garantijos peržiūros 

galimybę. Pavyzdžiui, kompiuterizuotas adaptyvus nuoseklusis testų pateikimo metodas naudoja 

adaptyviai administruojamus daugiapakopius testus kartu su pilnai iš anksto sukonstruota 

konfigūracija, kuri leidžia testų kūr÷jams įgyvendinti griežtą kokyb÷s kontrolę testų formoms prieš 

tai, kai jos pateikiamos testuojamiesiems. 

Operacin÷ testavimo sistema. Šią aukšto lygio testavimo sistemą sudaro penkios sistemos 

(8 pav.): 

1. Klausimų konstravimo ir saugojimo sistema 

2. Testų surinkimo ir sudarymo sistema 

3. Testuojamųjų registracijos ir tvarkaraščių sudarymo sistema 

4. Testų pateikimo sistema 

5. Apdorojimo po testavimo sistema 

Kiekviena šių sistemų taip pat turi po keletą smulkesnių posistemių, kurios atlieka 

specializuotas funkcijas (8 pav.). visos šios sistemos ir jų posistem÷s turi veikti integruotai kartu. 
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Savaime aišku, kuriant šias visas posistemes turi būti atsižvelgta į ateities pakeitimus. Tai reiškia, 

kad nenusp÷jamų pasekmių visai sistemai rizika turi būti minimali, kai atliekami menkiausi 

pakeitimai mažiesiems sistemos elementams. Taigi, pirmiausia reikia apibr÷žti funkcinius 

reikalavimus individualioms sistemoms integruotoje aukšto lygio testavimo sistemoje. 

 

ECDL testavimo sistemos architektūra

Testų Pateikimas

Testavimo Centrai

Testo Pateikimo Tvarkykl÷

Testuojamųjų Registracija ir 

Tvarkaraščiai

Peržiūra ir Saugumas

Prisijungimo Galimyb÷s ir 

Duomenų Persiuntimas

Testų Surinkimas ir 

Sudarymas

Apdorojimas po Testavimo

Klausimų konstravimas ir 

Saugojimas

Gerosios Praktikos 

Elementų Valdymas

AQTB

Resursų Kontrol÷ ir 

Valdymas

Klausimų Sudarymas ir 

Maketavimas Testų Medžiagos 

Kokyb÷s Kontrol÷

Testo Sudarymas

Automatinis Testų 

Surinkimas

ATA

Testuojamųjų 

Tinkamumas

Registracija ir Mokestis

Testų tvarkaraštis

Duomenų Sutikrinimas

Psichometrin÷ Analiz÷

Duomenų Archyvavimas

Galutinis Vertinimas

Rezultatų Pateikimas ir 

Komunikacija

 
Šaltinis: sudaryta autoriaus pagal BARTRAM D.; HAMBLETON R.K. (2006) OMPUTER-Based Testing and the 
Internet, p. 94. 

7 pav. ECDL testavimo sistemos architektūra. 
 

Klausimų konstravimo ir saugojimo sistema 

Šią sistemą sudaro keturios posistem÷s, kurios dirbdamos kartu generuoja, saugo ir išlaiko 

elementus, reikalingus pilnai aprūpinti testų konstravimo sistemą. Šios posistem÷s yra: AQTB, 
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Klausimų sudarymo ir maketavimo modulis, Resursų kontrol÷s ir valdymo modulis, Gerosios 

praktikos elementų valdymo modulis. 

AQTB – klausimų ir atsakymų testų baz÷. Tai sud÷tinga duomenų saugykla, kuri gali 

saugoti įvairių duomenų objektų, jų ryšių ir susijusių funkcijų rinkinius. Šiame modulyje 

dažniausiai naudojami tokie duomenų modeliai, kurie veikia paskirstytose Interneto platformose, 

arba duomenų bazių klasteriai. Ši duomenų baz÷ saugo įvairius duomenis, kaip tekstas, 

paveiksliukai, nuorodos, taikomųjų programų duomenys, turinio vykdomosios programos,  įgūdžių 

vykdomosios programos bei kiti kategoriniai atributai, kurie susieti su elementais (žodžių skaičius, 

skaitomumo indikatorius, statistiniai duomenys ir kt.). Pagrindiniai funkciniai reikalavimai AQTB 

apima laukus, apibr÷žiamus vartotojo, lanksčios duomenų struktūros hierarchinius duomenų 

objektus palaikantis modelis, įvairiakalbiškumo galimyb÷, importavimo ir eksportavimo galimyb÷ 

XML ar kitu formatu, greitas klaidų taisymas, portatyvumas tarp platformų, skaičiavimo 

palaikymas statistinių elementų saugyklai. 

Klausimų Sudarymas ir Maketavimas. Ši posistem÷ svarbi d÷l neišvengiamai didelio 

elementų poreikio. Tod÷l elementų sudarymo procedūros bei redagavimo palaikymo sistemos 

komponentai turi būti efektyvūs bei išplečiami. Pirmiausia, turi būti standartizuotas elementų 

įvedimas. Tai reiškia, kad posistem÷ tur÷tų naudoti šablonus, kurie autoriams leistų pateikti 

tinkamus duomenis šablono laukeliuose. Tuomet elementas (klausimas) būtų pateikiamas 

kompiuteryje suliejant šabloną su elemento duomenimis. Tokiu būdu griežtai apribojamas elementų 

kūrimas. Sudarymo sistema tur÷tų būti pagrįsta WYSIWYG1 atvaizdavimo galimyb÷mis. Ši 

posistem÷ tur÷tų suteikti maketuotojams komponentinę greito maketavimo galimybę, kuri leistų 

kurti naujus elementų tipus. 

Resursų Kontrol÷ ir Valdymas. Ši posistem÷ tai gamybos procesas, kur resursų valdymas 

yra esmin÷ funkcija, užtikrinanti, kad atsargos (klausimai) atitiks dabartinius ir ateities poreikius 

(testo formos). Šios sistemos veiklą užtikrina penkios funkcijos. Pirma – resursų posistem÷ 

identifikuoja ir generuoja ataskaitas ir žym÷tuosius mechanizmus, susijusius su testų 

specifikacijomis. Antra – posistem÷ turi steb÷ti elementų atsargas. Trečia – elementų saugykla turi 

žym÷ti ir kurti naujas užklausas, kad papildytų pasenusiu ar neapsaugotus elementus. Ketvirta – 

sistema turi nuolat ir kruopščiai steb÷ti klonus ir elementus, kurie negali  pasirodyti tose pačiose 

testų formose. Penkta -  posistem÷ turi identifikuoti ir įvertinti kiekybiškai pagrindinius kaštų 

faktorius, susijusius su elementų konstravimu. 

Gerosios praktikos Elementų Valdymas. Posistem÷ turi užtikrinti gerosios praktikos 

elementų peržiūra, atnaujinimą ir įterpimą į klausimų sudarymo ir maketavimo posistemę. 

 
                                                 
1 What you see is what you get. 
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Testų surinkimo ir sudarymo sistema 

 Tai labai svarbi sistemos dalis, kuri susideda iš trijų žingsnių proceso. Pirmame 

žingsnyje parenkami elementai iš elementų saugyklos konkrečioms testų formoms. Antrame 

žingsnyje kokyb÷s kontrol÷ patikrina testo formą. Trečiame žingsnyje pasirinkti elementai 

sujungiami su priimtina testo forma, kurie atvaizduojami testo pateikimo programin÷s įrangos. 

Automatinis Testų Surinkimas. Šiai posistemei keliami trys pagrindiniai reikalavimai. 

Pirmas – posistem÷ turi ištraukti tinkamus duomenis ir elementų duomenų baz÷s. Antra – elementų 

išrinkimo posistemei reikalinga interaktyvi duomenų baz÷s taikomoji programa, kuri saugotų ir 

valdytų įvairius ATA statistinius apribojimus. Trečia -  reikalingas ATA programinis modulis, kuris 

iš tiesų atrinktų elementus testų formoms. 

Testų Medžiagos Kokyb÷s kontrol÷. Si posistem÷ dažniausiai naudojama po to, kai ATA 

procedūros priskiria elementus testų formoms. Tai tarsi testo formų  pripažinimo testavimas prieš 

pateikiant jas aktyvavimui. 

Testo Sudarymas. Ši posistem÷ pasiima ATA pasirinkimo rezultatus, iš elementų duomenų 

baz÷s pasiima visą reikalingą informaciją testo formų pateikimui, prideda reikalingą testų 

administravimo informaciją, pakeičia visų šių duomenų formatą ir saugo tokiame faile, kurį naudoja 

kompiuterizuoto testavimo tvarkykl÷. 

 
Testuojamųjų registracijos ir tvarkaraščių sudarymo sistema 

 Ši sistema tai pirmasis kontakto taškas tarp testuojamųjų ir testavimo sistemos. Ši posistem÷ 

leidžia testuojamajam užsiregistruoti, sumok÷ti reikalingus mokesčius, suderinti testo datą, laiką ir 

vietą. Ji turi būti pasiekiama internetu ar per skambučių centrą. 

Testuojamųjų Tinkamumas. Ši posistem÷ turi filtruoti, kurie asmenys gali laikyti testus, o 

kurie ne. Posistem÷ dirba su duomenimis iš registracijos ir tvarkaraščių posistemių. 

Registracija ir Mokestis. Posistem÷s tikslas – įgyvendinti testo apmok÷jimą. Dažniausiai 

naudojamas internetinis apmok÷jimas, pagrįstas SSL ar kitu saugiu protokolu, šifruotų duomenų 

perdavimu bei autentiškumo patvirtinimu. 

Testų Tvarkaraštis. Ši posistem÷ veikia kartu su registracijos ir apmok÷jimo posistem÷mis. 

Jos pagrindin÷s funkcijos yra: 

• palaikyti duomenų bazę, kurioje saugomos dabartin÷s laisvos vietos laikyti testus, 

sugrupuotos pagal testavimo centrus, datas, laikus; 

• testavimo centrų paieška 

• tvarkaraščių sudarymas, atsižvelgiant į ypatingus poreikius įrangai 
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• reliacinio ryšio sudarymas tarp testuojamųjų ir duomenų testuojamųjų tinkamumo 

posistem÷s, registracijos ir apmok÷jimo posistem÷s bei datos, laiko, vietos duomenų 

šioje posistem÷je. 

 

Testų pateikimo sistema 

Testavimo Centrai. Ši posistem÷ valdo informacija apie organizacijos valdomus testavimo 

centrus. Ji užtikrina duomenų apsikeitimo tarp testavimo centrų galimybę. 

Prisijungimo Galimyb÷ ir Duomenų Persiuntimas. Šią posistemę apibūdina dvi 

pagrindin÷s charakteristikos – kanalo talpumas (pralaidumas) ir duomenų perdavimo sparta. 

Priežiūra ir Saugumas. Ši posistem÷ gali susid÷ti iš įvairių programin÷s įrangos, aparatin÷s 

įrangos bei žmonių veiklos kombinacijų. Jei su testu yra susijusi bent menka rizika, kai kurie 

testuojamieji neišvengiamai m÷gins sukčiauti. Yra įvairių sukčiavimo būdų. Tod÷l priežiūros ir 

saugumo posistem÷ turi kovoti su keik įmanoma daugiau potencialių sukčiavimo gr÷smių. 

Testo Pateikimo Tvarkykl÷. Tai sud÷tinga programin÷ taikomoji programa, kuri daro 

daugiau nei tik pateikiam klausimus testuojamiesiems ir surenka atsakymus. Tai detaliai parengta 

programin÷ vartotojo sąsaja, suderinta su daugybe duomenų apdorojimo galimybių ir skaičiavimo 

algoritmų. 

 

Apdorojimo po testavimo sistema 

Duomenų Sutikrinimas tai svarbi apskaitos funkcija, užtikrinanti nesugadinto testo įrašo 

patvirtinimą kiekvienam tinkamam testuojamajam, laikiusiam testą paskirtu laiku paskirtame 

testavimo centre. 

Duomenų Archyvavimo posistem÷ patalpina testų rezultatus į ilgalaikio saugojimo 

duomenų bazę. Saugoma testuojamųjų identifikavimo informacija, elementų identifikatoriai, 

atsakymai, atsakymų vert÷s, atliktų užduočių laiko kumuliatyvin÷ suma. 

Galutinis Vertinimas. Šį procesą sudaro trys lygiai. Pirmajame lygmenyje neapdoroti 

testuojamojo atsakymai konvertuojami į tam tikro tipo elementų taškus. Antrame lygyje vertinimas 

sudaromas iš elementų ar testo vienetų. Trečias lygmuo yra antrojo lygmens vertinimo funkcijos 

transformacija. 

Rezultatų Pateikimas ir Komunikacija. Kai rezultatai suskaičiuojami ir patalpinami į 

duomenų bazę, ši posistem÷ naudoja duomenų bazių ataskaitų funkciją. Šios ataskaitos 

generuojamos elektroniniu formatu, gali būti ir spausdinamos. 

Nors visos šios penkios sistemos ir jų posistem÷s pristatomos iš programin÷s įrangos kūrimo 

perspektyvos, reikia nepamiršti, kad yra daugyb÷ užsl÷ptų procedūrų ir operacijų, kurias taip pat 
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atlieka ar valdo žmon÷s. Tai yra, daugelis žmogaus veiksmų ir sprendimų yra esminiai siekiant 

s÷kmingai įgyvendinti ir palaikyti kompiuterizuoto testavimo veiklą. 

2.1. Geroji praktika 

Geroji praktika tai id÷ja, kuri tvirtina, kad yra technologija, metodas, procesas, veikla, 

paskatinimas ar atlygis, kurie yra efektyvesni atliekant konkretų veiksmą nei bet kurie kiti metodai 

ar procesai. Remiantis šia id÷ja ir tinkamais procesais, kontrole, testavimu gali būti pasiektas 

pageidaujamas rezultatas susiduriant su mažesniu problemų kiekiu ir išvengiant nenumatytų 

komplikacijų. Geroji praktika taip pat gali būti apibr÷žta kaip veiksmingiausias ir efektyviausias 

būdas atlikti užduotį, remiantis pasikartojančiomis procedūromis, kurios per ilgą laiko tarpą 

pasiteisino dideliam skaičiui žmonių. 

Konkrečios pramon÷s šakos ar bet kokios srities profesionalai gali keistis tarpusavyje 

gerosios praktikos patarimais. Tačiau prieš pritaikant taip vadinamąja gerąją praktiką reikia 

kruopščiai ją įvertinti. Kadangi vieno žmogaus geroji praktika nebūtinai gali tikti kitam žmogui, 

kompanijai ar valstybei. Vadovavimasis netinkama gerąja praktika gali sukelti neigiamą poveikį. 

Taigi kontekstas ir prielaidos gerajai praktikai turi būti išnagrin÷tos ir suprastos iš anksto. 

Gerosios praktikos taikymo sritys: 

• Laipsniškas ir iteratyvus projektavimas 

• Kokyb÷s užtikrinimas 

• Funkcionalumo inžinerija 

• Rizikos valdymas 

• Pokyčių procesai 

• Gair÷s 

• Defektų steb÷jimas 

• Panaudojimo atvejai 

• Reikalavimų valdymas 

• Automatizuoto testavimo procesai 

• Gair÷s slaugai 

• Įkalčių medicina 

• Vietin÷s valdžios institucijos 

• Ir kt. 

Geroji praktika naudojama technologijų kūrimui, tokių kaip nauja programin÷ įranga, taip 

statybų, transportavimo, verslo valdymo, palaikomosios pl÷tros ir kituose įvairiuose projektuose. 

Gerąja praktika taip pat remiamasi teikiant aukšto lygio sveikatos priežiūros paslaugas. Daugelis 
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įmonių gal÷tų dokumentuoti ir fiksuoti gerosios praktikos procedūras, kurios gal÷tų pad÷ti įmon÷s 

efektyviai sureguliuoti įvairius jos veiklos procesus. Tačiau tai yra sud÷tingas ir daug laiko 

reikalaujantis procesas, tod÷l dažnai įmon÷s jį praleidžia. 

Kalbant apie ECDL gerąją praktiką, tai būtų užduočių atlikimas greičiau ir paprasčiau, nei 

jas atliekant įprastu būdu. Tai būtų ir sparčiųjų klavišų naudojimas, macro komandos, dešiniu pel÷s 

klavišu iškviečiamo meniu naudojimas ir kiti veiksmai, taupantys laiką bei mažinantys žingsnių 

skaičių, reikalingų konkrečiai užduočiai atlikti. 

Remdamasi savo įgytomis žiniomis ir įgūdžiais naudojantis MS Excel skaičiuokl÷mis 

sudarysiu ECDL klausimyno užduočių sprendimus ir kur įmanoma pateiksiu gerosios praktikos 

patarimų. Užduotys išvardintos pagal ECDL Fondo pateikiamą ECDL Advanced Syllabus Version 

1.0 klausimyną, skirtą pažengusiems vartotojams. 

2.1.1.  ECDL modulio AM4 Advanced Skaičiuokl÷s užduotys 

Redagavimas / Editing 

AM4-1.1. Duomenys 

AM4-1.1.1. Pakeisti celių grup÷s(-ių) vardą skaičiuokl÷je 

Nukreipimai į celes gali būti formuojami pagal nuorodas į jų adresus: pavien÷ms cel÷ms 

(C1; AA23; IV16; A1), greta esančių celių sričiai (A1:A6; B3:X3; B16:F20), ne greta esančių celių 

grupei (A2,F6,H2; B7,D2:D8,F4:H7,R5). Taip pat įmanoma celes ar jų grupes pavadinti 

prasmingais pavadinimais, pavyzdžiui „mokesciai“. Tuomet yra žymiai lengviau suprasti formules, 

tokias kaip ši „=prekes_kaina*mokesciai“, negu tokias, kaip ši „=A9*B84” . 

Keičiant celių pavadinimus reikia laikytis keleto taisyklių: 

• Pavadinimas paprastai prasideda raide ar apatinio pabraukimo simboliu. 

• Pavadinimuose negali būti brūkšnelių ar tarpo simbolių. 

• Pavadinimo apribojimas yra 255 simbolių. 

• Reikia atkreipti d÷mesį, kad iškrentančiuose meniu matomi tik 10-15 simbolių pavadinimai. 

Nor÷dami pervadinti, pasirinkite celę, celių grupę ar ne gretimas celes, kurias norite 

pervadinti. Tuomet spragtelkite laukelį „Name“, esantį kair÷je pus÷je, šalia formulių laukelio. 

 1 – „Name“ laukelis. Jame įrašykite norimą celių vardą ir paspauskite Enter. 

Pastaba. Cel÷s pavadinimo negal÷site pakeisti, jei tuo pat metu redaguojate cel÷s turinį. 

Nor÷dami patekti į pervadintą celę ar jų grupę, spragtel÷kite žemyn iškrentančio meniu 

rodyklę šalia „name“ laukelio ir pasirinkite norimos cel÷s pavadinimą. Nor÷dami panaikinti celių 

pavadinimus, meniu juostoje pasirinkite Insert→Name→Define. Iššokančiame Define Name 

meniu pasirinkite pavadinimą, kurį norite ištrinti ir spragtelkite Delete mygtuką. Kai ištrinsite visus 

norimus pavadinimus, spragtelkite OK. 



40 
 

AM4-1.1.2. Pritaikyti automatinį formatavimą celių grupei 

Nor÷dami pritaikyti AutoFormat funkciją, pasirinkite celių grupę, eilutę ar stulpelį, kuriems 

norite pritaikyti automatinį formatavimą. Viršutin÷je meniu juostoje pasirinkite 

Format→AutoFormat . Iššokusiame meniu lange pateikiamame Table Format sąraše, pasirinkite 

reikiamą formatą ir spragtelkite OK. Atkreipkite d÷mesį, kad paspaudę Options, mygtuką, gal÷site 

nurodyti papildomas tinkinimo savybes. Pažym÷jus šiuos laukelius, automatinis formatavimas 

pritaikomas atitinkamiems elementas. Pasirinkite tik tuos laukelius, kuriems norite taikyti 

automatinį formatavimą. 

 

Nor÷dami panaikinti AutoFormat funkciją, pasirinkite tą pačią celių grupę ir pakartokite 

anksčiau atliktus veiksmus (Format→AutoFormat) , iššokusiame meniu lange pasirinkite „None“ . 

AM4-1.1.3. Sukurti savo formatą skaičiams 

Pažym÷kite celes, kurioms norite sukurti savo skaičių formatą. Viršuje meniu juostoje 

pasirinkite Format→Cells, arba ant pasirinktų celių paspaudę dešinį pel÷s klavišą pasirinkite 

Format Cells. Iššokusiame meniu lange pasirinkite Number skirtuką. Category sąraše 

spragtel÷kite Custom, o sąraše Type pasirinkite skaičių formatą, kokį norite redaguoti ar ištrinti. 

Jūsų pasirinktas skaičių formatas atsiranda laukelyje Type virš sąrašo Type. 

Pastaba. Kai pasirenkate esamą skaičių formatą Type sąraše, Excel skaičiuokl÷ išsaugo 

skaičių formato originalą ir sukuria kopiją, kurią jūs galite redaguoti. Originalus skaičių formatas 

sąraše Type negali būti pakeistas ar ištrintas. 

Taip pat galite sukurti savo formatavimą kodų pagalba, kiekvieną jų atskirkite kabliataškiu. 

Šiais kodais galite apibr÷žti formatą kartu ir teigiamiems skaičiams, ir neigiamiems skaičiams, ir 

nulin÷ms vert÷ms, ir tekstui. Jums nebūtina apibr÷žti visas šias keturias sekcijas. 

Pastaba. Sukurtas skaičių formatas saugomas tik toje darbaknyg÷je, kitose darbaknyg÷se jie 

nepasiekiami. Jei norite, kad jūsų skaičių formatai būtų prieinami ir kitose darbaknyg÷se, galite 

susikurti šablonus. 

AM4-1.1.4. Panaudokite sąlyginio formatavimo galimybę 

Sąlyginis formatavimas reiškia, kad galima pabr÷žti duomenis, atitinkančius kažkokį 

konkretų kriterijų. Pavyzdžiui, kurie yra didesni ar mažesni už tam tikrą vertę. 

Pažym÷kite celes, kurioms norite pritaikyti, pakeisti ar panaikinti sąlyginį formatavimą. 

Meniu juostoje spragtel÷kite Format→Conditional Formatting . 
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Galite atlikti tokius veiksmus: 

•••• Nor÷dami panaudoti pasirinktų celių vertes kaip formatavimo kriterijus, spregtel÷kite Cell 

Value Is, pasirinkite palyginimo frazę (tarp – between; lygu – equal to ir pan.) ir įrašykite 

konstantos vertę arba formulę. Įrašydami formulę, ją prad÷kite lygyb÷s ženklu (=). 

•••• Nor÷dami panaudoti formulę, kaip formatavimo kriterijų, spragtel÷kite Formula Is ir 

įveskite formulę, kuri išreiškiama login÷mis TRUE arba FALSE reikšm÷mis. 

Užpildę norimas formatavimo sąlygas, spragtel÷kite Format ir įprastame teksto 

formatavimo lange pasirinkite norimą formatavimo variantą, kurį taikysite, jei cel÷s vert÷ atitiks 

sąlygą arba formul÷ grąžins TRUE reikšmę. 

Nor÷dami prid÷ti dar vieną sąlygą, spragtel÷kite Add ir pakartokite sąlygos įterpimo 

žingsnius. Galite nurodyti iki trijų sąlygų. Jei nei viena iš nurodytų sąlygų n÷ra tenkinama, cel÷s 

reikšm÷ priklauso nuo esamo formato. 

AM4-1.1.5. Panaudokite Paste Special galimybę 

Nukopijavę duomenis, galite panaudoti Paste Special komandą Edit  meniu juostoje, kad 

įterptum÷te konkrečias celių reikšmes ar atributus tokius, kaip formul÷s, formatai ar mainų srities 

(Clipboard) komentarai. Paste Special komandą taip pat galite naudoti, nor÷dami įterpti nuorodą į 

Excel skaičiuokl÷s duomenis ar duomenis iš kitos programos, tokios kaip MS Word, Lotus 1-2-3 

skaičiuokl÷. 

Darbaknyg÷je pasirinkite celes, kuriose yra reikšm÷s ar atributai, kuriuos norite kopijuoti. 

Spragtel÷kite Copy , arba paspauskite CTRL+C, arba meniu juostoje spragtelkite Edit→Copy. 

Pasirinkite celę, esančią aukščiau kair÷je, nei jūsų norima kopijavimo vieta. Meniu juostoje 

spragtel÷kite Edit→Paste Special, arba dešinį pel÷s klavišą ir tuomet Paste Special. Kopijavimo 

meniu Paste galite pasirinkti tokius variantus: 

•••• Nor÷dami įkopijuoti statinius duomenis, pasirinkite reikalingų nukopijuotų duomenų 

atributą (vertes – values; formules – formulas ir t.t.). 

•••• Nor÷dami įkopijuoti susietus duomenis, spragtel÷kite All  arba All except borders. 

Kopijavimo meniu Operation galite nurodyti, kokią matematinę operaciją, norite pritaikyti 

nukopijuotiems duomenims. 
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Nor÷dami išvengti verčių pakeitimo tuščiomis cel÷mis kopijavimo vietoje, pasirinkite Skip 

Blanks. Nor÷dami išvengti verčių pakeitimo tuščiomis cel÷mis kopijavimo vietoje, pasirinkite Skip 

Blanks. Nor÷dami pakeisti nukopijuotų duomenų stulpelius į eilutes, ir atvirkščiai, pasirinkite 

Transpose. Nor÷dami susieti nukopijuotus duomenis su originaliais, spragtel÷kite Paste Link. 

AM4-1.1.6. Importuokite tekstinį failą ir atribokite kableliais, tarpais ar tabuliacijomis 

Duomenų importavimo funkcija reikalinga, jei jūsų turimi duomenys n÷ra Excel formato. 

Tuomet duomenis reikia importuoti ir konvertuoti,  kad MS Excel programa juos pažintų ir gal÷tų 

apdoroti. Importuojamų duomenys gali būti teksto ar CSV formato. 

Meniu juostoje spragtel÷kite File→Open ir pasirinkite failą, kurį nor÷site importuoti. Šalia 

užrašo Files of type iškrentančiame meniu pasirinkite Text Files. Suraskite ir pasirinkite norimą 

tekstinį failą ir spragtel÷kite Open mygtuką. Automatiškai atsivers teksto importavimo vedlys: 

 

Apatin÷je vedlio lango dalyje matomi jūsų importuojami duomenys, ar jie yra atskirti tam 

tikrais simboliais, ar ne. Viršutin÷je skydelio dalyje pažym÷kite Delimited ir spauskite Next. 

Kitame importavimo vedlio lange viršutin÷je dalyje pažym÷kite, kokiu skirtuku atskirti žodžiai jūsų 

importuotame tekstiniame faile. Numatytasis pasirinkimas yra tabuliacijos simboliu atskirti žodžiai. 

Galite pasirinkti tokius simbolius kaip tarpas (Space), kablelis (Comma) ar kabliataškis 

(Semicolon). Kai pasirenkate norimą skirtuką, žemiau pateikiamas vaizdas, kaip atrodys apdorotas 

tekstas. Kai tekstas atrodo taip, kaip reikia, spragtel÷kite mygtuką Next. 

 

Paskutiniame importavimo vedlio lange galite pasirinkti duomenų formatą kiekvienam 

stulpeliui. Taip pat galite nuspręsti, kuriuos stulpelius norite importuoti, o kuriuos – ne. 
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Kai apsisprend÷te d÷l pasirinkimų, spragtel÷kite mygtuką Fininsh. 

AM4-1.2. Vaizdavimas 

AM4-1.2.1. Sustingdykite eilučių ar stulpelių pavadinimus 

Eilučių sustingdymo funkcija naudinga, kai norima matyti stulpelių ar eilučių pavadinimus 

slenkant Excel failu žemyn ar į šoną. 

Nor÷dami sustingdyti eilutes, pažym÷kite eilutę žemiau tų, kurias norite atskirti. Nor÷dami 

atskirti stulpelius, pažym÷kite stulpelį į dešinę nuo tų, kuriuos norite atskirti. Nor÷dami sustingdyti 

ir stulpelį, ir eilutę, pažym÷kite celę, esančią žemiau ir į dešinę nuo tos vietos, kurią norite atskirti. 

 

Meniu juostoje spragtel÷kite Window→Freeze Panes. Nor÷dami atšaukti eilučių ar 

stulpelių sustingdymą, meniu juostoje spragtelkite Window→Unfreeze Panes. 

AM4-1.2.2. Pasl÷pkite/Nesl÷pkite eilutes ar stulpelius 

Pasirinkite eilutes ar stulpelius, kuriuos norite pasl÷pti. Visos eilut÷s ar stulpelio žym÷jimui 

naudokite spragtel÷jimą ant antrašt÷s (A, B, W, 1, 17, 23). Nor÷dami pažym÷ti nuoseklią eilučių ar 

stulpelių grupę, spragtelkite ant pirmosios eilutes (stulpelio) antrašt÷s, tuomet, laikydami Shift 

klavišą, spragtelkite ant paskutin÷s eilut÷s (stulpelio) antrašt÷s. 

Meniu juostoje pasirinkite Format→Row (arba Column), priklausomai, ką norite pasl÷pti, 

spragtel÷kite Hide, arba Unhide. Tai atliksite greičiau, jei pažym÷ję norimas eilutes ar stulpelius 

paspausite dešinį pel÷s mygtuką ir iššokusiame meniu spragtel÷site Hide. 

Nor÷dami v÷l matyti pasl÷ptas eilutes (stulpelius), pažym÷kite eilutes (stulpelius), tarp kurių 

yra pasl÷ptieji, ir meniu juostoje spragtelkite Format→Row (Column|)→Unhide, arba paspaudę 

dešinį pel÷s klavišą ir Unhide. 
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AM4-1.2.3. Pasl÷pkite/Nesl÷pkite darbalapius 

Pasirinkite darbalapius, kuriuos norite pasl÷pti. Meniu juostoje pasirinkite submeniu 

Format→Sheet→Hide, nor÷dami matyti pasl÷ptą darbalapį  →Unhide. Arba spragtel÷ję dešinį 

pel÷s klavišą ant pasirinkto darbalapio pavadinimo pasirinkite Hide (Unhide). 

AM4-1.2.4. Panaudokite tarpin÷s sumos (Subtotals) funkciją 

Nor÷dami panaudoti Subtotals funkciją, pirmiausia turite surūšiuoti duomenis. Tuomet 

meniu juostoje pasirinkite Data→Subtotals. Subtotals dialogo lange At each change in 

iškrentančiame meniu pasirinkite stulpelį, pagal kurį norite grupuoti duomenis. Pasirinkite, kokį 

norite atlikti skaičiavimą iš  Use function iškrentančio meniu. Tai gali būti sumavimas (Sum), 

skaičiavimas (Count), vidurkis (Average), minimumas (Min ), maksimumas (Max) ir kitos. 

Pasirinkite stulpelius, su kuriais norite atlikti veiksmus, pažym÷dami jį varnel÷ Add subtotal to 

sąraše. Jei norite pakeisti esamus duomenis, pažym÷kite Replace current subtotals. Jei norite 

kiekvieną grupę atskirti puslapio lūžiu, pažym÷kite Page break between groups. Jei norite, kad 

tarpin÷ suma ir bendroji suma būtų rodoma po duomenų grupe, pažym÷kite Summary below data. 

Jei prieš duomenų grupę – nežym÷kite šio punkto. Nor÷dami panaikinti tarpines sumas, meniu 

juostoje spragtel÷kite Data→Subtotal→Remove all mygtuką. 

AM4-1.2.5. Panaudokite vienos arba dviejų įvesčių Duomenų lenteles/ What-if lenteles 

Duomenų lentel÷ paprasčiausiai yra celių grup÷, kuri leidžia steb÷ti, kaip kintančios 

reikšm÷s paveikia darbaknyg÷je esančių formulių rezultatus. 

Turint įvestus reikalingus duomenis, pavyzdžiui, galime steb÷ti, kaip kintanti palūkanų 

norma paveikia pinigų kiekį, kurį turime grąžinti pasi÷mę paskolą. Skaičiavimui naudojama 

funkcija PMT(rate, nper, pv, fv, type), kur rate – paskolos palūkanų norma, nper – įmokų kiekis, pv 

dabartin÷ vert÷, fv – būsimoji vert÷, type – 0 arba 1, priklausomai, ar mok÷jimai yra postnumerando 

ar prenumerando. Pažymime reikalingas celes, funkcija cel÷je C5: 

  

Meniu juostoje pasirinkite Data→Table. Iššokusiame meniu lange reikia pasirinkti Column 

input cell, kuri šiuo atveju yra C5. Paspaudę OK , pamatysite what-if  (kas-jeigu) mok÷jimų 

rezultatus: 
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Tai buvo vieno įvesties parametro pavyzdys, kai kas-jeigu klausimas susijęs tik su 

palūkanų norma. Tačiau galima kas-jeigu klausimą užduoti esant dviem parametrams – palūkanų 

normai ir paskolos m÷nesių kiekiui. 

Jei norite, tur÷ti du įvesties parametrus, atlikite tokius veiksmus: 

Pažym÷kite reikalingas celes, pagal kurių reikšmes bus atliekami skaičiavimai (šiuo atveju, 

tai stulpelyje ir 4 eilut÷je esantys duomenys), funkcija cel÷je B4. Meniu juostoje spragtel÷kite 

Data→Table. 

  

Iššokusio langelio Row input cell langelyje pažym÷kite reikiamą celę (šiuo atveju tai C17 

cel÷, kadangi reikšm÷s kinta eilut÷je). Iššokusio langelio Column input cell langelyje pažym÷kite 

reikiamą celę (šiuo atveju tai C18 cel÷, kadangi reikšm÷s kinta stulpelyje). 

 

Paspaudę OK , pamatysite atsiradusias kas-rezultatus: 
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AM4-1.3. Apsauga / Protection 

AM4-1.3.1. Apsaugokite darbalapį slaptažodžiu 

Nor÷dami apsaugoti darbalapį slaptažodžiu meniu juostoje pasirinkite Tools→Protection. 

Pasirinkite Protect Sheet ir iššokusiame meniu langelyje pasirinkite, norimą apsaugojimo būdą: 

•••• Slaptažodis. Slaptažodis yra nebūtinas ir gali būti iki 255 simbolių. 

•••• Turinys. Galite apsaugoti darbalapio celes ir lenteles. 

•••• Objektai. Galite apsaugoti grafinius darbalapio objektus. 

•••• Scenarijai. Galite apsaugoti scenarijus ir neleisti atlikti pakeitimų scenarijų aprašymuose. 

Nor÷dami panaikinti apsaugą slaptažodžiu, meniu juostoje pasirinkite Tools→Unprotect 

Sheet ir jei reik÷s, įveskite buvusį slaptažodį. 

AM4-1.3.2. Apsaugokite slaptažodžiu pažym÷tas celes darbalapyje 

Nor÷dami apsaugoti darbalapį slaptažodžiu, pažym÷kite celes, kurias norite apsaugoti. 

Meniu juostoje pasirinkite Cells→Format, iššokusiame Format Cells meniu pasirinkite 

Protection kortelę. 

• Locked reikšm÷ neleidžia atlikti cel÷je jokių pakeitimų, kai darbalapis yra apsaugotas. 

• Hidden reikšm÷ paslepia formules, kai darbalapis yra apsaugotas. 

Pažym÷kite Locked opciją ir spragtel÷kite OK. Tuomet atlikite veiksmus, skirtus apsaugoti 

darbalapį (žr. AM4-1.3.1. punktą). Celių apsauga neįsijungs tol, kol daebalapis nebus apsaugotas 

slaptažodžiu (pažym÷jus turinio (Content) apsaugą). Pagal numatytuosius nustatymus, visose 

cel÷se yra uždrausta atlikti pakeitimus. Reikia panaikinti redagavimo apsaugą (Locked) tose cel÷se, 

kurias vartotojai gal÷tų redaguoti. 

Nor÷dami panaikinti celių apsaugą, meniu juostoje spragtelkite Format→Cells, 

iššokusiame meniu lange pasirinkite Protection kortelę. Įsitikinkite, kad n÷ra varnel÷s prie punkto 

Locked spragtel÷kite OK . Tuomet apsaugokite darbalapį slaptažodžiu (žr. AM4-1.3.1. punktą) ir 

jūsų pasirinktas celes bus galima redaguoti. 

AM4-1.4. Saugumas / Security 

 AM4-1.4.1. Užd÷kite apsaugą darbaknygei slaptažodžiu 

Nor÷dami užd÷ti slaptažodį darbaknyg÷s atidarymui, meniu juostoje pasirinkite 

File→Save_As, tuomet spragtelkite Tools ikoną. Iškrentančiame meniu pasirinkite General 

Options→Save Options. 
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Įveskite slaptažodį eilut÷je Password to open ir spauskite OK . Jūsų bus paprašyta pakartoti 

slaptažodį. Slaptažodžio ilgis iki 15 simbolių. Nor÷dami atidaryti šį failą, tur÷site įvesti šį sugalvotą 

slaptažodį. Įvesti slaptažodį taip pat bus prašoma, kai skaičiavimam naudosite duomenis iš 

apsaugotos darbaknyg÷s. Atkreipkite d÷mesį, kad jei pamiršite slaptažodį, informacijos iš apsaugoto 

darbaknyg÷s pasiimti nebegal÷site. 

Slaptažodį taip pat galite užd÷ti ir pakeitimų išsaugojimui. Šį slaptažodį reikia įvesti eilut÷je 

Password to modify. Šis apsaugos būdas leidžia atidaryti failą, jį peržiūr÷ti ir redaguoti, tačiau 

norint išsaugoti pakeitimus, bus reikalaujama slaptažodžio. Pakeitimus išsaugoti galima naujoje 

darbaknyg÷je (File→Save As) nauju pavadinimu. 

Pažym÷jus paukščiuku Read-only recommended galimybę, kiekvieną kartą atidarius 

darbaknygę bus pranešama, kad n÷ra galimyb÷s redaguoti šią darbaknygę, ją galima tik peržiūr÷ti. 

Pažym÷jus paukščiuku Always create backup galimybę, kiekvieną kartą išsaugojus 

darbaknygę Excel programa sukuria atsarginę darbaknyg÷s kopiją. Šio failo pl÷tinys yra BAK . Jis 

saugomas tame pačiame kataloge, kaip ir originalus failas. Šia atsargine kopija galite pasinaudoti, 

kai originalusis failas sugadinamas. 

 AM4-1.4.2. Panaikinkite darbaknygei apsaugą slaptažodžiu 

Nor÷dami panaikinti darbaknyg÷s apsaugą slaptažodžiu, atidarykite šią darbaknygę. Įvedę 

slaptažodį, meniu juostoje pasirinkite File→Save_As, tuomet spragtelkite Tools ikoną. 

Iškrentančiame meniu pasirinkite General Options→Save Options. Išvalykite abu slaptažodžių 

laukus, spragtelkite OK . Išsaugokite failą. Jums siūlys pakeisti jau esantį failą šiuo pavadinimu, 

spragtelkite Yes ir darbaknyg÷s slaptažodis bus panaikintas. 

Duomenų apdorojimas / Data Handling 

AM4-2.1. Rūšiavimas 

AM4-2.1.1. Išrikiuokite duomenis pagal keletą stulpelių 

Tur÷dami duomenų sąrašą pasirinkite celę, esančią sąraše. Meniu juostoje pasirinkite 

Data→Sort. Iššokusiame Sort dialogo lange galite pasirinkit rūšiavimo taisykles. Iškrentančiame 

meniu Sort by pasirinkite pagal kurį stulpelį rikiuoti pirmiausiai ir kokia tvarka – did÷jimo 

(Ascending) ar maž÷jimo (Descending). Iškrentančiame meniu Then by pasirinkite antrąjį 

rūšiavimo kriterijų – antrąjį stulpelį bei kokia tvarka turi būti rikiuojama. 
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Jei nepažym÷site mygtuko, kad lentel÷ turi antraštinę eilutę (Header row), tuomet lentel÷s 

antrašt÷ taip pat bus surūšiuota ir įsipainios tarp duomenų. 

AM4-2.1.2. Atlikite pasirinktinį vartotojo rūšiavimą 

Ši funkcija naudinga, kai norite duomenis surikiuoti tokiu būdu, kurio neįgyvendina 

automatinsi rūšiavimas pagal ab÷c÷lę, ar reikšmių dydį. Pavyzdžiui, kai duomenis reikia surikiuoti 

pagal savait÷s dienas. 

Pažym÷kite celę, esančią sąrašo ribose, kurį nor÷site rūšiuoti. Meniu juostoje pasirinkite 

Data→Sort→Options ir iššokusiame dialogo lange Sort Options gal÷site pasirinkti rūšiavimo 

būdą. Iškrentančiame meniu First key sort order pasirinkite tinkamą duomenų rūšiavimo būdą iš 

keleto siūlomų ir spragtel÷kite OK . 

 

AM4-2.2. Užklausos ir filtravimas 

AM4-2.2.1. Sukurkite vieno ar keleto parametrų užklausą, naudodamiesi prieinamomis 

parinktimis 

AutoFilter  funkcija leidžia rodyti tik tuos įrašus, kurie atitinka nurodytus kriterijus. 

Duomenis filtruoti galima dviem būdais, AutoFilter  ir išpl÷stiniu filtru (Advanced Filter). 

AutoFilter turi paprastą sąsają ir tam tikrus standartinius apribojimus. Išpl÷stinis filtras randamas 

Data→Filter , pasižymi sud÷tingesniu naudojimu, tačiau yra daug efektyvesnis. 

Nor÷dami naudoti AutoFilter paspauskite ant bet kurios sąrašo cel÷s. Meniu pasirinkite 

Data→Filter→AutoFilter . Šalia kiekvieno laukelio pavadinimo bus rodomas išplečiamasis meniu. 

Galite pasirinkti bet kurį išplečiamo meniu punktą, nor÷dami filtrą pritaikyti pasirinktam laukui. 

Pavyzdžiui, jei paspaud÷te Supplier Email (tiek÷jo el. paštas) išplečiamą meniu, matytum÷te tokius 

punktus: 
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• Jei pasirinkote Jon, tik įrašai, kuriuose kaip tiek÷jo el. paštas nurodytas Jon bus rodomi. 

 

T.y. matysite tik tuos įrašus, kurie tenkinta filtro sąlygas, šiuo atveju tik knygas pirktas iš 

Jon. Nor÷dami v÷l rodyti visus įrašus, išplečiamame meniu galite pasirinkti All  (visi). Tokiu būdu 

panaikinamas paieškos kriterijus nurodytam laukui! 

Norint atlikti kelet ą užklausų. Sakykime, kad norite peržiūr÷ti duomenis tik iš šiaur÷s 

regiono ir tik pardavimu, viršijančius 50,000. Pirmiausia spragtelkite pele duomenų lauką, tuomet 

meniu pasirinkite Data→Filter→AutoFilter . Rodomas vaizdas pasikeis, kaip pavaizduota žemiau 

dešin÷je. 

   

Nor÷dami duomenis filtruoti taip, kad būtų rodomi tik šiaur÷s regiono pardavimai, 

paspauskite ant rodykl÷s, rodomos šalia Sales Regions. Iš išplečiamojo sąrašo pasirinkite North , 

kaip pavaizduota paveiksl÷lyje kair÷je. Bus rodomi tik šiaur÷s regiono pardavimai. 

      

Nor÷dami toliau filtruoti duomenis, kad būtų rodomi tik šiaur÷s regiono pardavimai virš 

50,000 tur÷site atlikti tokius veiksmus. Paspauskite ant rodykl÷s, esančios šalia Sales Value. 

Pamatysite išplečiamąjį sąrašą. Pasirinkite Custom, kaip pavaizduota žemiau kair÷je. Iššokusiame 

dialogo lange pasirinkite is greater than (yra didesnis už) laukui Sales Value, įveskite 50000, kaip 

pavaizduota žemiau viduryje. Spauskite OK  ir gausite pavaizduotus rezultatus dešin÷je: 
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Jei norite nurodyti sąlygini filtravimo kriterijų, AutoFilter gali filtruoti pagal nurodytas 

sąlygas. Pavyzdžiui, galite rodyti tik knygas, kainuojančias daugiau, nei £17. Tam reik÷s atlikti 

toliau aprašytus veiksmus. Pirmiausia įsitikinkite, kad neįjungti jokie filtrai. Pasirinkite Price 

išplečiamąjį meniu, bus rodomas sąrašas, pateiktas žemiau dešin÷je. Pasirinkite Custom – bus 

rodomas Custom AutoFilter dialogo langas. 

   

Pasirinkite Price išplečiamame meniu (Custom AutoFilter dialogo lange). Bus rodomos 

sąlygin÷s išraiškos. Šiuo atveju pasirinkite is greater than (daugiau už). Įvedimo laukelyje dešin÷je 

įveskite skaičių 17, ir spauskite OK  mygtuką. Sąraše bus rodomos tik knygos, kainuojančios 

daugiau, nei £17. 

Pasirinktinio AutoFilter galimos išraiškos: 

= Equal to (lygu) 

> Greater than (daugiau už) 

< Less than (mažiau už) 

>= Greater than or equal to (daugiau arba lygu už) 

<= Less than or equal to (mažiau arba lygu už) 

<> Not equal to (nelygu) 

And/Or filtrų naudojimas. Galite naudoti And/Or  mygtukus, jei norite į savo filtrą įterpti 

papildomus kriterijus. Pavyzdžiui, galite rodyti knygas, kainuojančias daugiau, nei £20, bet mažiau, 

nei £30.  

Nor÷dami pašalinti visus AutoFilters, meniu pasirinkite Data→Filter . Jei AutoFilter  

komanda pažym÷ta, tai reiškia, kad AutoFilters  įjungta. Paspaudę AutoFilter,  pašalinsite visus 

filtrus ir matysite visus įrašus. 

Top 10 AutoFilter naudojimas. Top 10 AutoFilter leidžia duomenis filtruoti įvairiais būdais 

ir ne tik į top dešimt, kaip nurodo pavadinimas. Paspaudę ant bet kurios sąrašo cel÷s, išplečiamame 

meniu pasirinkite Data→Filter→AutoFilter . Šalia kiekvieno lauko bus rodomas išplečiamojo 

meniu valdymas. 
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Pasirinktame išplečiamajame filtro valdyme spauskite Top 10. Bus rodomas Top 10 

AutoFilter  dialogo langas (pavaizduota paveiksl÷lyje aukščiau). Pirmiausia iš išplečiamo meniu 

pasirinkti ‘Top’ (viršus) ar ‘Bottom’ (apačia). Antrasis punktas leis nurodyti skaičių tarp 1 ir 

500. Trečiajame išplečiamajame meniu gal÷site pasirinkti ‘Items’ (įrašai) ar ‘Percent’ (procentai).  

T.y. įrašų top 5 arba mažiausi 15%. 

 AM4-2.2.2. Panaudokite išpl÷stines užklausų/filtr ų parinktis 

Unikalių įrašų rodymas. Tarkime, yra pateiktas sąrašas su vardais ir kompanijos ID 

numeriais. Įrašas Tom įrašytas du kartus. Šiuo atveju sąrašas trumpas, tod÷l pasikartojimus rasti 

nesunku. Bet įsivaizduokite tokią paiešką tūkstančio įrašų sąraše! Filtruosime sąrašą, kad 

išvengtume pasikartojančių įrašų. Pirmiausia paspauskite Name stulpelį ir Sort Ascending ikoną, 

nor÷dami surūšiuoti įrašus pagal vardą. Meniu pasirinkite Data→Filter→Advanced Filter. 

Atsiv÷rusiame dialogo lange pasirinkite Unique records only (tik unikalūs įrašai) ir spauskite OK  

mygtuką.  Sąrašas bus rodomas be pasikartojančių įrašų. 

       

Išpl÷stinių AutoFilter parinkčių naudojimas. Žemiau pateiktas sąrašas bus filtruojamas taip, 

kad būtų rodomi tik pardavimai didesni už £3,000, Robert atlikti Prancūzijoje arba Švedijoje. 

Pirmiausiai reikia pasirinkti filtravimo kriterijų. Tai atliekama laukų pavadinimus pateikiant kitoje 

darbalapio vietoje, o po jais surašomi kriterijai, kaip iliustruojama žemiau dešin÷je. 

  

Pažym÷kite bet kurią pardavimų sąrašo celę, meniu pasirinkite Data→Filter→Advanced 

Filter . Atvertame dialogo lange Excel automatiškai įrašys sąrašo ribas List range lauke. 
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Spragtelkite Criteria range laukelį. Pele pažym÷kite filtruojamą sąrašą, šiuo atveju celes 

A25:D27.  Excel šį ruožą įves į Criteria range lauką. 

 

Jei reikia, Excel gali išfiltruotą sąrašą rodyti kitoje darbalapio vietoje. Tur÷site pasirinkti 

Copy to another location (kopijuoti į kitą vietą) ir nurodyti celių ruožą Copy to laukelyje. 

Paspaudus OK  mygtuką Excel filtruos sąrašą, rodydamas tik nurodytus kriterijus atitinkančius 

įrašus. 

 

AM4-2.3. Susiejimas 

AM4-2.3.1. Susiekite duomenis ir grafiką darbalapyje 

Atskirų celių susiejimas darbalapyje. Nor÷dami celę susieti su kitos cel÷s duomenimis, 

įveskite žemiau pateiktą formulę. Šiame pavyzdyje cel÷ C4 susieta su cele A2. Jeigu keičiami 

duomenys cel÷je A2, cel÷je C4 rodomi duomenys automatiškai atnaujinami. 

 

Grafikų susiejimas su darbalapio duomenimis. Pažym÷ję darbalapyje esančius duomenis ir 

pagal juos sukūrę grafiką, automatiškai susiesite grafiką su duomenimis. Bet kokie su duomenimis 

atlikti pakeitimai matysis grafike. 
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AM4-2.3.2. Susiekite duomenis su grafiku skirtingose darbalapiuose (vienoje 

darbaknyg÷je) 

Nor÷dami susieti skirtingų darbalapių celes (toje pačioje darbaknyg÷je), pasirinkite 

duomenis, kuriuos norite susieti su kito darbalapio cel÷mis. Paspaudę Ctrl+C  (arba dešinį pel÷s 

mygtuką ir Copy), nukopijuokite duomenis į tarpinę atmintinę (Clipboard). Pasirinkite norimo 

darbalapio skirtuką (rodomą lango apačioje). Pasirinktame darbalapyje paspauskite ant vietos, 

kurioje norite susieti duomenis. Pasirinkite Edit  išplečiamąjį sąrašą ir jame rinkit÷s Paste Special. 

Rodomame dialogo lange pasirinkite Paste Link mygtuką. Jeigu paspausite ant vienos iš susietų 

celių, pamatysite susiejimo formulę, kuri bus panašaus formato į pavaizduotąją žemiau. 

=Sheet1!A1 

 

Nor÷dami susieti duomenis viename darbalapyje su grafiku kitame (toje pačioje 

darbaknyg÷je), sukurkite Excel darbalapį ir įveskite jame duomenis. Toje pačioje byloje pasirinkite 

kitą darbalapį. Spauskite Chart Wizard  ikoną. Bus rodomas pirmasis Chart Wizard dialogo lango 

puslapis. Pasirinkite norimą grafiko tipą (ir, jei reikia, potipį), ir spauskite Next mygtuką. Bus 

rodomas žemiau dešin÷je pavaizduotas dialogo langas. 

  

Duomenų srities pasirinkimo lange turime pasirinkti kito darbalapio duomenų sritį pagal 

kurią bus sukurtas grafikas. Galite įvesti ją rankomis. Bet yra lengvesnis būdas! Paspauskite ant 

darbalapio, kuriame yra reikalingi duomenys, skirtuko (lango apačioje). Pasirinkite reikalingą 
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duomenų sritį ir pasteb÷site, kad ji automatiškai įvedama į Chart Wizard dialogo lango laukelį, kaip 

pavaizduota pavyzdyje žemiau. Jums nereik÷s rūpintis sud÷tinga sintakse. 

 

Spauskite Next mygtuką ir tęskite kitus Chart Wizard žingsnius, kaip įprasta. Chart Wizard 

lange paspaudę mygtuką Finish pasteb÷site, kad grafikas rodomas kitame darbalapyje, nei jam 

naudojami duomenys. 

 Nor÷dami susieti skirtinguose darbalapiuose esančius grafikus, darbalapyje sukurkite grafiką, 

(Excel byloje, kurioje yra keli darbalapiai). Nukopijuokite grafiką į tarpinę atmintinę (pažym÷kite 

grafiką ir spauskite Ctrl +C). Lango apačioje pasirinkite kito darbalapio skirtuką. Įkelkite 

nukopijuotą grafiką į pasirinktą darbalapį (spauskite Ctrl +V). 

AM4-2.3.3. Susiekite duomenis su grafiku skirtingose darbaknyg÷se 

Nor÷dami susieti duomenis skirtingose bylose, atverkite dvi Excel bylas. Pirmoje byloje 

pažym÷kite norimą celę ar celes. Nukopijuokite pažym÷tą sritį į tarpinę atmintinę (spauskite 

Ctrl +C). Pasirinkite kitos bylos darbalapį. Paspauskite pele toje vietoje, kur norite susieti celes. 

Spragtelkite Edit→Paste Special. Pasirinkite Paste Link mygtuką. Spauskite OK  mygtuką, 

formul÷s lauke bus rodoma reikiama formul÷. Žemiau pateikiamas pavyzdys: 

 

Nor÷dami susieti vienos bylos grafiką su kita byla, Sukurkite Excel bylą ir joje sukurkite 

grafiką iš norimų duomenų. Pirmoje byloje pažym÷kite grafiką. Nukopijuokite grafiką į tarpinę 

atmintinę (spauskite Ctrl +C). Atverkite naują Excel kopiją (t.y. neatidarin÷kite antros bylos tame 

pačiame Excel lange). Pasirinkite vietą, į kurią nor÷site įkelti grafiką. Spragtelkite Edit→Paste 

Special. Pasirinkite Paste Link mygtuką. Įsitikinkite, kad As: dialogo lange pasirinktas Microsoft 

Excel Chart Object. Spauskite OK  mygtuką ir grafikas iš pirmos Excel kopijos bus įkeltas ir 

susietas su antrąja kopija. 



55 
 

 

Grafiko kopijavimas iš vienos bylos į kitą. Atverkite dvi bylas. Vienoje iš jų turi būti 

grafikas. Išplečiamame meniu pasirinkite Window→Arrange komandą. Atvertame dialogo lange 

pasirinkite Tiled ir paspausite OK  mygtuką, dvi bylos bus išd÷stytos, kaip parodyta paveiksl÷lyje. 

   

Pasirinkite grafiką pirmame lange, paspausdami ant jo. Spausdami mygtuką Ctrl  tempkite 

grafiką į antrą bylą. Atleidus pel÷s mygtuką, grafikas bus nukopijuotas į kitą bylą. 

 

Pastaba. Jeigu tempdami grafiką nespaustum÷te Ctrl mygtuko, grafikas būtų ne nukopijuotas, o 

perkeltas. 

AM4-2.3.4. Susiekite duomenis/grafiką su duomenimis Word dokumente 

Įtraukimas. Įtraukiant duomenis iš vienos programos į kitą, iš esm÷s informacijos kopija 

patalpinama antroje programoje. Dukart paspaudę šį įtrauktą objektą galite jį redaguoti 
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nepaveikdami originalios duomenų kopijos. Yra du OLE tipai, dar vadinami OLE 1 ir OLE 2; Excel 

naudoja OLE 2. Pasirinkę OLE2 įtrauktą objektą pasiliksite programoje, kurioje objektas įtrauktas, 

tuo metu reikalingi valdymo ar redagavimo įrankiai bus rodomi iš pradin÷s su OLE suderinamos 

programos, kuria buvo sukurtas objektas. 

Susiejimas. Susiejimas išsprendžia įtraukimo problemą, kai reikia atskirai keisti kiekvieną 

duomenų kopiją. Tarp dviejų bylų gali būti sukurtą sąsaja (priklausanti byla, kuri naudos duomenis 

ir šaltinio byla, kurioje yra originalūs duomenys). Kaskart pakeitus duomenis šaltinio byloje, 

duomenys susietoje priklausančioje byloje bus atnaujinti. Tai leis tuos pačius duomenis naudoti 

kelete bylų, tuo pačiu būsite užtikrinti, kad bylos bus vienu metu atnaujinamos. 

Nor÷dami nukopijuoti duomenis į tarpinę atmintinę, Excel lange pažym÷kite norimus 

kopijuoti duomenis (ar grafikos objektą) ir spragtelkite Crtl+C , arba dešinį pel÷s klavišą ir Copy, 

arba meniu juostoje Edit→Copy. 

Nor÷dami įtraukti Excel duomenis (ar grafiką) į Word dokumentą, Excel lange pažym÷kite 

duomenis ar grafiką, kuriuos norite įtraukti į Word dokumentą. Paspauskite Copy mygtuką Excel 

lange. Įjunkite Word ar panašią programą. Žymeklį pad÷kite toje vietoje, kur nor÷site įkelti 

duomenis ar grafiką. Word lange paspauskite Paste ikoną, arba Crtl+V . 

Nor÷dami susieti Word dokumentą su Excel duomenimis ar grafiku, Excel lange pasirinkite 

duomenis ar grafiką, kuriuos norite kopijuoti. Excel lange spauskite Copy ikoną. Įjunkite Word ar 

panašią programą. Žymeklį pad÷kite toje vietoje, kur norite įkelti duomenis ar grafiką, tuomet Edit  

išplečiamajame meniu rinkit÷s Paste Special. Pažym÷kite Paste link akutę. Spauskite OK  mygtuką 

– dialogo langas bus užvertas ir duomenys Word dokumente bus susieti su Excel dokumentu. 

AM4-2.3.5. Susumuokite duomenis gretimuose darbalapiuose, naudodami 3D sumos 

funkciją 

Sujungimas leidžia susumuoti skirtingų darbalapių duomenų vertes. Pateiktame pavyzdyje 

vaizduojama byla, turinti keletą darbalapių. Kiekviename darbalapyje pateikiami pardav÷jo Elliot 

kasmetiniai pardavimai. Norime susumuoti paskutinių trijų metų pardavimus ir pavaizduoti tai 

pirmame darbalapyje. 

 

Pirmiausia pasirenkame celę, kurioje nor÷sime matyti sujungtus duomenis. Paspauskite 

AutoSum ikoną. Paspaudę antrojo darbalapio auselę, pasirinkite jį. Pažym÷kite sumuojamą sritį ar 

celę, šiuo atveju B2. 
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Spausdami mygtuką Shift, spauskite kitų sumuojamų darbalapių skirtukus, šiuo atveju 

metus tarp 2000 ir 1999. Paspaudus mygtuką Enter, susumuoti trijų metų duomenys bus rodomi 

pirmajame darbalapyje. Paspaudę susumuotus duomenis vaizduojančią celę (pirmame darbalapyje), 

formul÷s lauke matysite tokią formulę: 

 

AM4-2.4. Šablonai 

AM4-2.4.1. Panaudokite šabloną 

Dirbdami su skaičiuokl÷mis ir nor÷dami panaudoti tą patį darbalapio išd÷stymą ar dizainą, 

pageidaujamą darbalapio struktūrą galite atkurti šablonų pagalba. Šablonuose galima išsaugoti 

tekstą, grafiką, formatavimo informaciją (išd÷stymą, stilių), kolontitulus, formules, macro 

komandas. Šablonų failų pl÷tinys yra .xlt, tod÷l sukūrę norimą šabloninę darbaknygę turite ją 

išsaugoti būtent šiuo pl÷tiniu. 

Nor÷dami panaudoti šabloną, spragtelkite meniu File→New. Iššokusiame dialogo lange 

pasirinkite reikalingą šabloną. Jei norite panaudoti vieną iš numatytųjų šablonų, pasirinkite vieną iš 

General skirtuko šablonų ir spragtelkite OK. 

AM4-2.4.2. Paredaguokite šabloną 

Nor÷dami sukurti šabloną, paredaguokite darbaknygę pagal pageidavimus ir spragtelkite 

File→Save As. Iškrentančiame meniu Save as type pasirinkite Template. Automatiškai 

nustatomas saugojimo katalogas Templates, taip pat automatiškai nustatomas .xlt pl÷tinys. 

Nor÷dami paredaguoti šabloną, spragtelkite Open ikoną įrankių juostoje. Iššokusiame 

dialogo lange Files of type pasirinkite Template (*.xlt). Susiraskite norimą šablono failą ir jį 

atsidarykite. Atlikę norimus pakeitimus nepamirškite išsaugoti (Ctrl+S, arba įrankių juostoje 

spragtelkite saugojimo ikoną ). 

AM4-2.5. Diagramos ir grafikai 

AM4-2.5.1. Pakeiskite skritulin÷s diagramos dalių kampą 

Nor÷dami pakeisti diagramos dalių kampą, spragtelkite ant diagramos, tuomet dešinį pel÷s 

klavišą ir pasirinkite Format Data Series. Iššokusiame dialogo lange pasirinkite Options skirtuką. 

Reikiamą kampą galite pakeisti redaguodamis Angle of first slice dydį. 

AM4-2.5.2. Pakeiskite diagramos ašių skaičių ar teksto formatą 

Nor÷dami keisti grafiko/diagramos ašių nustatymus, spragtelkite du kartus pele ant norimos 

ašies. Iššokusiame dialogo lange gal÷site pakeisti įvairius ašių parametrus. Skirtukas Number 



58 
 

skirtas ašių skaičių formato nustatymui. Skirtukas Scale skirtas ašių mastelio/skal÷s parametrų 

nustatymui. Skirtukas Font skirtas ašių teksto formatavimui. 

AM4-2.5.3. Pakeiskite diagramos pavadinimo, legendos ar duomenų pavadinimų poziciją 

Nor÷dami pakeisti diagramos pavadinimo ar legendos poziciją, tiesiog pažym÷kite norimą 

objektą ir nutempkite jį pel÷s pagalba į pageidaujamą vietą. Nor÷dami pakeisti pavadinimo ar 

legendos laukelio dydį, pažym÷kite norimą objektą pele, pastumkite pelę link objekto krašto, kol 

atsiras tempimo kryptį nusakanti rodykl÷. Spragtel÷ję pele, tempkite objektą iki norimo dydžio ir 

atleiskite pel÷s klavišą. 

Nor÷dami pakeisti duomenų pavadinimų poziciją, spragtelkite ant duomenų grafike. Tuomet 

du kartus spragtelkite ant duomenų pavadinimo. Iššokusiame dialogo lange pasirinkite Alignment 

skirtuką ir jame pakeiskite duomenų pavadinimo poziciją. Spragtelkite OK. 

AM4-2.5.4. Panaudokite „explode“ funkciją skritulin÷s diagramos segmentams 

Nor÷dami panaudoti „explode“ funkciją, t.y. diagramos segmentų atskyrimo, skritulinei 

diagramai, pažym÷kite pasirinktą diagramą vienu pel÷s spragtel÷jimu. Spragtel÷jimo ir tempimo 

būdu atskirkite diagramos segmentus tempdami už bet kurio segmento juodos ranken÷l÷s (juodo 

kvadrat÷lio). 

AM4-2.5.5. Ištrinkite duomenų seką diagramoje 

Duomenis iš grafiko ištrinti galite tiesiog pažym÷ję norimą duomenų segmentą ir paspaudę 

Delete mygtuką. 

Nor÷dami įterpti naują duomenų seką į grafiką, tiesiog užtempkite naują duomenų seką 

(pažym÷tą celių grupę) ant grafiko. Duomenų lentel÷je atsiras nauja duomenų seka, o grafike nauji 

duomenys. 

AM4-2.5.6. Pakeiskite diagramos tipą apibr÷žtai duomenų sekai 

Nor÷dami pakeisti diagramos tipą, spragtelkite dešinį pel÷s klavišą ant diagramos ir 

pasirinkite Chart Type. Iššokusiame meniu lange gal÷site pasirinkti norimą grafiko tipą iš daugelio 

galimų. Pasirinkite norimą diagramos tipą ir spragtelkite OK. 
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AM4-2.5.7. Padidinkite tarpą tarp stulpelių 2D diagramoje 

Nor÷dami padidinti tarpą tarp stulpelių 2D diagramoje, spragtelkite dešinį pel÷s klavišą ant 

grafiko ir pasirinkite Format Data Series. Dialogo lange pasirinkite Options skirtuką. Tarpą 

padidinsite pakeitę Overlap reikšmę į neigiamą. 

 

AM4-2.5.8. Įterpkite paveiksl÷lį į 2D diagramą 

Jei norite įterpti paveiksl÷lį kaip diagramos foną, du kartus spragtelkite pele ant diagramos 

fono. Dialogo lange pasirinkit Pattern skirtuką. Paspaudę Fill Effects mygtuką naujame dialogo 

lange pasirinkite Picture skirtuką. Šiame lange spragtelkite Select Picture mygtuką. Susiraskite 

norimą paveiksl÷lį ir spragtelkite Insert mygtuką. 

Jei paveiksl÷lį norite panaudoti grafiko stulpelių spalvinimui, du kartus spragtelkite pele ant 

diagramos stulpelio. Dialogo lange pasirinkite Patterns skirtuką. Paspaudę Fill Effects mygtuką 

naujame dialogo lange pasirinkite Picture skirtuką. Šiame lange spragtelkite Select Picture 

mygtuką. Susiraskite norimą paveiksl÷lį ir spragtelkite Insert mygtuką. Galite nuspręsti, kaip 

paveiksl÷lis bus išd÷stytas ant diagramos stulpelio – užd÷tas su pasikartojimu, išpl÷stas pagal 

mastelį, arba abi šios opcijos kartu. 

 

AM4.3. Funkcijos 

AM4-3.1. Funkcijų naudojimas 

AM4-3.1.1.Panaudokite datos ir laiko funkcijas: TODAY, DAY, MONTH, YEAR 

AM4-3.1.2. Panaudokite matematines funkcijas: SUMIF, SUMPOSITIVE, ROUND 

AM4-3.1.3. Panaudokite statistines funkcijas: COUNT, PURECOUNT, COUNTA, 

COUNTIF 

AM4-3.1.4. Panaudokite teksto funkcijas: PROPER, UPPER, LOWER, 

CONCANTENATE 

AM4-3.1.5. Panaudokite finansines funkcijas: FV, NPV, PMT, RATE 
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AM4-3.1.6. Panaudokite paieškos ir sąsajos funkcijas: HLOOKUP, VLOOKUP 

AM4-3.1.7. Panaudokite logines funkcijas: IF, AND, OR, ISERROR 

AM4-3.1.8. Panaudokite duomenų bazių funkcijas: DSUM, DMIN, DMAX, DCOUNT 

AM4-3.1.2. Panaudokite lizdines funkcijas 

Visos šios funkcijos gali būti iškviečiamos funkcijų vedlio pagalba. Jis iškviečiamas 

mygtuko  pagalba, esančio šalia cel÷s adreso. Funkcijų vedlyje funkcijos yra suskirstytos pagal 

kategorijas ir pagal pavadinimus. 

 

Funkciją galima įterpti naudojantis funkcijų vedlio pagalba suradus norimą funkciją ir 

spragtel÷jus OK. Arba cel÷je įrašius „=“ simbolį ir funkcijos pavadinimą. Kiekviena funkcija turi 

savo parametrus, kuriuos galima nurodyti skliausteliuose su specifine sintakse, arba funkcijų vedlio 

pagalba, įrašius parametrus į funkcijų vedlio langelius, kaip pavaizduota žemiau. 

 

Kai kurios funkcijos n÷ra MS Excel funkcijos, pavyzdžiui, SUMPOSITIVE, PURECOUNT. 

AM4.4. Analiz÷ 

AM4-4.1. Sukiniai 

AM4-4.1.1. Sukurkite sukinį naudodami apibr÷žtus laukų pavadinimus 

Sukiniai (Pivot Table) tai duomenų lentel÷, kuri leidžia grupuoti duomenis įvairiais 

metodais. Nor÷dami sukurti sukinį, pažym÷kite bent vieną duomenų celę ir spragtelkite 

Data→PivotTable and PivotChart Report. Dialogo lange spragtelkite Next, tuomet pasirinkite 

duomenų grupę, kuriems taikysite sukinį. Pasirinkite vietą, į kurią įkelti sukinį ir spragtelkite 

Finish. Jums bus pateikta tuščia sukinio lentel÷. Į ją galite įkelti norimus duomenis tiesiog 

spragtel÷jimo ir tempimo būdu iš sukinio duomenų laukų dialogo lango. 
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AM4-4.1.2. Paredaguokite duomenis ir atnaujinkite sukinį 

Jei norite atlikti pakeitimus su sukinio duomenimis, pirmiausia turite paredaguoti duomenų 

celes. Tuomet spragtelkite ant sukinio lentel÷s, kad būtų iškviestas sukinio įrankių langas. Šiame 

lange spragtelkite Refresh Data mygtuką (raudonas šauktukas). 

 

AM4-4.1.3. Sugrupuokite duomenis sukinyje pagal apibr÷žtus kriterijus 

Jei norite sugrupuoti sukinio duomenis, pavyzdžiui, kad keleto prekių laukai būtų šalia, 

pažym÷kite pirmąjį prek÷s pavadinimą, tuomet laikydami nuspaustą Ctrl mygtuką, pažym÷kite 

antrąjį prek÷s pavadinimą. Atleidę Ctrl mygtuką, spragtelkite dešinį pel÷s klavišą virš pažym÷tų 

celių ir iš meniu pasirinkite Group and Outline→Group. Duomenys bus sugrupuoti. 

AM4-4.2. Scenarijai/Versijos 

AM4-4.2.1. Sukurkite ir pavadinkite scenarijų/versiją iš apibr÷žtų celių grupių 

Scenarijus leidžia keisti keleto celių duomenis ir steb÷ti celių pasikeitimus, taip pat saugoti 

informaciją, kurią v÷liau galima atspausdinti. 

Nor÷dami sukurti scenarijų, pažym÷kite besikeičiančių celių grupę, spragtelkite 

Tools→Scenarios. Dialogo lange spragtelkite Add, naujame dialogo lange įrašykite scenarijaus 

pavadinimą ir spragtelkite OK. Scenario Values dialogo lange bus pateikiamos celių reikšm÷s, kaip 

iliustruojama žemiau. Šiame lange įveskite pageidaujamas reikšm÷s ir spragtelkite OK. 

 

Nor÷dami pamatyti scenarijų, spragtelkite scenarijų vedlio dialogo langą, pasirinkite norimo 

scenarijaus pavadinimą ir spragtelkite Show mygtuką. 
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AM4-4.2.2. Sukurkite scenarijaus santrauką/versijos ataskaitą 

Scenarijaus santrauka pateikiama spragtel÷jus Summary mygtuką scenarijų vedlio dialogo 

lange. Reikia pažym÷ti Scenario Summary mygtuką ir spragtelti OK. 

 

AM4-4.3. Tikrinimas (Auditas) 

AM4-4.3.1. Aptikite pirmines celes darbalapyje 

AM4-4.3.2. Aptikite priklausomas celes darbalapyje 

Pirminių (predecent) bei priklausomų (dependant) celių aptikimui naudojama Auditing  

įrankių juosta. Ji iškviečiama meniu pagalba Tools→Auditing→Show Auditing Toolbat. Jos 

vaizdas pateikiamas žemiau. 

 

Ikonų reikšm÷s: 

 Naujas komentaras 

 Panaikinti visas rodykles 

panaikinti priklausomų celių rodykles 

 Panaikinti pirmini ų celių rodykles 

 aptikti priklausomas celes 

 Aptikti klaidas 
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 Aptikti pirmines celes 

Panaudojus pirminių celių paieškos komandą gaunamas žemiau kair÷je pateikiamas vaizdas, 

o priklausomų celių – žemiau dešin÷je. 

  

AM4-4.3.3. Parodykite visas formules arba jų buvimo vietą darbalapyje 

Jei norite matyti visas darbalapyje esančias formules, meniu pasirinkite Tools→Options. 

Dialogo lange pasirinkite View kortelę, joje paukščiuku pažym÷kite Formulas ir spragtelkite OK. 

Matysite žemiau pateikiamą vaizdą. 

 

AM4-4.3.4. Prid÷kite/panaikinkite darbalapio komentarą 

Komentarą galite įterpti meniu pagalba - Insert→Comment. Cel÷s komentaro langelyje 

įveskite norimą tekstą ir spragtelkite už šio laukelio ribų. 

Nor÷dami pamatyti komentaro tekstą, palaikykite užvedę pelę virš cel÷s raudono komentaro 

indikatoriaus. Nor÷dami panaikinti komentarą, spragtelkite dešinį pel÷s klavišą ir pasirinkite Delete 

Comment komandą. 

AM4-4.3.5. Paredaguokite darbalapio komentarus 

Komentarų redagavimui spragtelkite dešinį pel÷s klavišą ant cel÷s, kurios komentarą norite 

redaguoti ir pasirinkite Edit Comment komandą. Redaguokite tekstą. Kai atliksite norimus 

pakeitimus, spragtelkite už komentaro ribų. 
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AM4.5. Specialūs įrankiai 

AM4-5.1. Macro komandos 

AM4-5.1.1. Įrašykite paprastą macro komandą (pvz.: puslapio sąrankos pakeitimai) 

Macro komandos palengvina automatizuoti pasikartojančius procesus, pavyzdžiui, lapo 

parametrų nustatymai. Macro komandas galima redaguoti ir vykdyti bet kuriuo metu. 

Nor÷dami sukurti macro komandą, meniu pasirinkite Tools→Macro→Record New Macro. 

Laukelyje Macro name įrašykite komandos pavadinimą. Spragtelkite OK ir prad÷kite veiksmus, 

kuriuos norite įrašyti į macro komandą, Excelis juos išsaugos. Nor÷dami nutraukti veiksmų 

įrašymą, spragtelkite Stop Recording mygtuką įrankių juostoje arba meniu pasirinkite 

Tools→Macro→Stop recording. 

AM4-5.1.2. Įvykdykite macro komandą 

Paleisti macro komandą galite priskirtu macro sparčiųjų klavišų deriniu. Macro komandai 

priskirti spartųjį klavišą galite meniu pasirinkę Tools→Macro. Dialogo lange pasirinkite macro 

komandos pavadinimą, spragtelkite Options. Macro Options dialogo lange įrašykite pasirinktą 

raidę šalia Ctrl+  teksto laukelio ir spragtelkite OK. Jūsų pasirinktas klavišų derinys iškvies macro 

komandą. 

AM4-5.1.3. Priskirkite macro komandą pasirinktam mygtukui įrankių juostoje 

Nor÷dami priskirti macro komandą mygtukui įrankių juostoje, spragtelkite dešinį pel÷s 

klavišą įrankių juostoje ir pasirinkite Customize komandą. Pasirinkite Commands skirtuką, 

kategorijų lauke susiraskite Macros ir pažym÷kite šį lauką. Komandų laukelyje atsiras macro 

komandų sąrašas, pažym÷kite norimą macro komandą ir tempkite ją pele į pasirinktą įrankių juostą. 

Įrankių juostoje atsiras ikona, žyminti jūsų macro komandą. 

2.2.2. MS Excel spartieji klavišai 

Klavišų kombinacija Funkcija 

Formatavimas 

[Ctrl] B Paryškinti pasirinktą tektą 

[Ctrl] I Pakeisti tekstą kursyvu 

[Ctrl] U Pabraukti pasirinktą tekstą 

[Ctrl] 5 Perbraukti pasirinktą tekstą 

[Alt] ` Atidaryti Style meniu 

[Ctrl] 1 Atidaryti Format Cells meniu 

[Ctrl] [Shift] ~ Pritaiko bendrąjį formatą 
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[Ctrl] [Shift] $ Pritaiko procentų formatą 

[Ctrl] [Shift] # Pritaiko datos formatą 

[Ctrl] [Shift] @ Pritaiko laiko formatą 

[Ctrl] [Shift] ! Pritaiko skaičių formatą 

[Ctrl] [Shift] ^ Pritaiko eksponentinį formatą 

[Ctrl] [Shift] & Nubr÷žia kontūro r÷melį 

[Ctrl] [Shift] _ Panaikina kontūro r÷melį 

Navigacija 

[Ctrl] [Page Down] Pereiti į kitą darbalapį darbaknyg÷je 

[Ctrl] [Page Up] Pereiti į ankstesnį darbalapį darbaknyg÷je 

[Ctrl] [F6] Keisti atidarytas darbaknyges 

[Ctrl] ir rodykl÷ Pereina į duomenų grup÷s kraštą 

[Home] Pereina į eilut÷s pradžią 

[Ctrl] [Home] Pereina į darbalapio pradžią 

[Ctrl] [End] Pereina į išnaudoto darbalapio pabaigą 

[F6] Pereiti iš vienos atskirtos srities į kitą 

[Ctrl] [Backspace] Parodyti aktyvią celę 

[Enter] Pereiti į celę apačioje 

[Shift][Enter] Pereiti į celę viršuje 

[Shift] [Tab] Pereiti į celę kair÷je 

[Ctrl] . Pereiti iš vienos kampin÷s cel÷s į kitą kampinę celę pasirinktoje 

grup÷je 

Pasirinkimas 

[Shift] [Space] Pasirinkti eilutę 

[Ctrl] [Space] Pasirinkti stulpelį 

[Ctrl] A Pasirinkti visą darbalapį 

[Shift] [Home] Pasirinkti nuo esamos cel÷s iki eilut÷s pradžios 

[Ctrl] [Shift] [Home] Pasirinkti nuo esamos cel÷s iki darbalapio pradžios 

[Shift] [End] [Enter] Pasirinkti nuo esamos cel÷s iki paskutin÷s eilut÷s cel÷s 

[Ctrl] [Shift] [End] Pasirinkti nuo esamos cel÷s iki paskutin÷s cel÷s darbalapyje 

[Ctrl] * Pasirinkti duomenis, supančius aktyvią celę 

[Ctrl] [Shift] O Pasirinkti celes su komentarais 

[Ctrl] [ Pasirinkti celes, į kurias kreipiasi pasirinkta formul÷ 

[Ctrl] ] Pasirinkti formules, kurios kreipiasi į aktyvią celę 
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Darbaknyg÷s pagrindai 

[Ctrl] O Atidaryti darbaknygę 

[Ctrl] N Sukurti naują darbaknygę 

[Ctrl] S Išsaugoti darbaknygę 

[F12] Atidaryti Save As meniu 

[Ctrl] P Atspausdinti darbaknygę 

[Ctrl] W Uždaryti darbaknygę 

[Shift] [F11] Įterpti naują darbalapį 

[Ctrl] 9 Pasl÷pti pasirinktas eilutes 

[Ctrl] [Shift] 9 Rodyti pasl÷ptas eilutes 

[Ctrl] 0 Pasl÷pti pasirinktus stulpelius 

[Ctrl] [Shift] 0 Rodyti pasl÷ptus stulpelius 

[Ctrl] F Iškviesti Paieškos meniu 

[Ctrl] H Iškviesti Pakeitimo meniu 

[F7] Paleisti gramatikos klaidų taisymo vedlį 

Duomenų apdorojimas 

[Enter] Duomenų įvedimo užbaigimas 

[Alt] [Enter] Naujos eilut÷s cel÷je įvedimas 

[F2] Redaguoti cel÷s turinį 

[Ctrl] [Enter] Įvesti į pasirinktas celes vedamą informaciją 

[Ctrl] D Užpildyti pasirinktas celes duomenimis 

[Ctrl] R Užpildyti pasirinktas celes duomenimis į dešinę 

[Ctrl] [F3] Sukurti cel÷s vardą 

[Ctrl] K Įterpti nuorodą 

[Ctrl] ; Įterpti šios dienos datą 

[Ctrl] : Įterpti dabartinį laiką 

[Ctrl] X Iškirpti pasirinktus duomenis 

[Ctrl] C Kopijuoti pasirinktus duomenis 

[Ctrl] V Įklijuoti nukopijuotus duomenis 

[Ctrl] Y Pakartoti paskutinį veiksmą 

[Ctrl] Z Atšaukti paskutinį veiksmą 

[Ctrl] [Delete] Ištrinti duomenis nuo esamos cel÷s iki eilut÷s pabaigos 

[Ctrl] [Shift] + Prid÷ti tuščių celių 

[Ctrl] - Ištrinti pasirinktas celes 
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[F11] Įterpti grafiką su pasirinktais duomenimis 

[Alt] L Įterpti sukinį pasirinktiems duomenims 

[Alt] U Iškviesti AutoShapes meniu 

Formul÷s 

= Prad÷ti formulę 

[Ctrl] [Shift] [Enter] Įvesti formulę kaip masyvą 

[Shift] [F3] Iškviesti funkcijų įterpimo vedlį 

[F3] Įterpti apibr÷žtą cel÷s vardą į formulę 

[Alt] = Įterpti automatinio sumavimo SUM formulę 

Formul÷s vardas [Ctrl] A Parodo funkcijos argumentų meniu 

[Ctrl] [Shift] “ Kopijuoti cel÷s reikšmę, esančios viršuje, į aktyvią celę 

[Ctrl] ‘ Kopijuoti formulę, esančią viršuje, į aktyvią celę 

[Ctrl] ` Keisti vaizdą tarp formulių ir celių reikšmių 

[F9] Skaičiuoti reikšmes darbalapiuose visose atidarytose 

darbaknyg÷se 

[Shift] [F9] Skaičiuoti reikšmes aktyviame darbalapyje 

[Esc] Atšaukti vedamus duomenis 

Dirbadami su cel÷mis, naudokite dešinį pel÷s klavišą meniu iškvietimui, kuriame rasite 

dažniausiai naudojamas funkcijas. 

[F10] [Alt] Pasirinkti meniu juostą arba uždaryti aktyvų meniu 

[Tab] Keisti meniu skirtukus 

[Shift] [F10] Parodyti spartųjį klavišą pasirinktam meniu elementui 

Kaip matome, patarimų, kaip atlikti užduotis, yra iš tiesų nemažai ir naudojantis jais 

užduotis galima atlikti greičiau ir paprasčiau. Tačiau žmon÷s dažniausiai užduotis atlieka jiems 

įprastu, bet nebūtinai taisyklingu būdu. Gerosios praktikos patarimai taip pat n÷ra naudojami 

daugelio žmonių. Įdiegus gerosios praktikos patarimus į ECDL mokymo programą, daugiau žmonių 

gal÷tų jais naudotis ne tik laikydami testus, bet ir kasdien dirbdami įvairiomis programomis, ypač 

kai šiais mokslo ir technologijų laikais yra akcentuojamas laiko ir resursų taupymas, kad darbas 

taptų kuo efektyvesnis. 

Darydama prielaidą, jog geroji praktika ECDL testavimui yra reikalinga ir labai naudinga 

besimokantiems, sudarau ECDL testavimo kokyb÷s požiūriu apklausos anketą. Anketoje kreipiamas 

d÷mesys į tai, ar būtų reikalinga įtraukti „gerosios praktikos“ patarimų besimokantiems laikyti 

ECDL testus, ar svarbu kokybiškas užduočių atlikimas. 
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3. ECDL GEROSIOS PRAKTIKOS REIKALINGUMO TYRIMAS 

Tyrimo tikslas – nustatyti bei įvertinti, ar svarbu, kad testuojamieji geb÷tų kokybiškai 

atlikti ECDL testų užduotis, ar geroji praktika reikalinga ECDL testavimo kokybei užtikrinti ir jei 

reikalinga, tai kuriems ECDL Advanced moduliams. 

Gauti tyrimo rezultatai leistų įvertinti, kaip ECDL ekspertai vertina užduočių atlikimo 

kokyb÷s svarbą, ką mano apie gerąją praktiką, ar mano, kad ji naudinga ir reikalinga d÷styti. 

Tyrimo imtis – ECDL testavimo centrų darbuotojai (~50 žmonių). 

Tyrimo metodai. Šiam tyrimui buvo taikomas kiekybinis ir kokybinis tyrimo metodai – 

anketinis metodas, priskiriamas prie sociologinių tyrimo metodų, apklausa, palyginimo metodas. 

Analizuojat ir vertinant tyrimo rezultatus taip pat taikytas dokumentų analiz÷s metodas, kartu su 

tyrimo rezultatais interpretuojant statistinę medžiagą. 

Sudarant anketą buvo atsižvelgta, kad respondentai turi daug žinių ir yra gerai nusimanantys 

šioje srityje, tod÷l anketa yra trumpa, paprasta ir aiški. Anketa (žr. Priedą Nr. 2) susideda iš dviejų 

dalių – informacija apie užduočių atlikimo kokybę bei gerąją praktika ir jos naudojimą, antroji – 

ekspertų asmenin÷ nuomon÷ apie tai, kiek, kokių ir kuriuose moduliuose turi būti gerosios praktikos 

elementų. Tyrimo rezultatai leis patvirtinti arba paneigti gerosios praktikos patarimų naudingumą 

ECDL mokymo programai ir testų klausimyno sudarymui. Taip pat pateiks preliminarų siūlymą, 

kiek gerosios praktikos patarimų tur÷tų būti įtraukiama į programą bei kuriem moduliams. 

Tyrimo organizavimas. Tyrimo metu buvo apklausta 50 ekspertų. Visi respondentai buvo 

Lietuvos Respublikos piliečiai. Apklausos atlikimo trukm÷ – vienas m÷nesis. Tyrimo imtis ir 

respondentų kompetencija leidžia gerai ištirti rūpimus klausimus. 

Tyrimo rezultatai. 

Tyrimo rezultatai apdoroti MS Excel programos pagalba. Atlika apklausa pad÷jo įvertinti, 

korektiško ir kokybiško užduočių atlikimo svarbą bei įvertinti optimalų rekomenduojamą gerosios 

praktikos elementų ECDL testuose kiekį. Atsižvelgiant į ekspertų nuomonę, nustatyta, kokie 

gerosios praktikos elementai tur÷tų būti įtraukiami į ECDL programą bei kuriuose ECDL Advanced 

moduliuose naudojami. 

Pirmojo anketos klausimo rezultatai parod÷, jog yra išties svarbu, kad užduotys būtų 

atliekamos kokybiškai ir korektiškai. Testuojamieji negali atlikti užduočių bet kaip, kaip yra įpratę 

daryti kasdieniame darbe. Net 52% ekspertų nurod÷, jog tai yra labai svarbu, o 46% - jog tai svarbu. 

Tik 2% ekspertų atrodo, jog tai nelabai svarbu (8 pav.). 
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Šaltinis: sudaryta autoriaus. 

8 pav. Apklausos respondentų atsakymas į klausimą Nr. 1. 

Tyrimo rezultatai parod÷, jog 78% apklaustųjų nurodo, kad ECDL moduliams reikalingi 

gerosios praktikos elementai (9 pav.). Nei vienas ekspertas nemano, kad tai yra visai nereikalinga. 

 
Šaltinis: sudaryta autoriaus. 

9 pav. Apklausos respondentų atsakymas į klausimą Nr. 2. 

Aiškius rezultatus parod÷ atsakymai į klausimą, kurio produkto užduotis reik÷tų atlikti, 

pasitelkiant gerosios praktikos elementus. 27 ekspertai nurod÷, kad gerąją praktiką reik÷tų remtis 

atliekant ECDL Core užduotis; 43 – ECDL Advanced; 39 – Specializuotų produktų užduotis (10 

pav.). Tik 6 ekspertai nurod÷, jog gerosios praktikos elementų reik÷tų e-Citizen programai. Tai yra 

pakankamai mažas skaičius, tod÷l laikome, kad e-Citizen gerosios praktikos elementai n÷ra būtini. 

Taip jie n÷ra labai svarbūs ECDL Core programai, tod÷l gerosios praktikos elementų čia tur÷tų  būti 

mažiau, nei sud÷tingesniuose ECDL Advanced ar specializuotuose testuose. 



70 
 

 
Šaltinis: sudaryta autoriaus. 

10 pav. Apklausos respondentų atsakymas į klausimą Nr. 3. 

Atsakymai į klausimą, ar gerosios praktikos elementai tur÷tų būti įtraukiami į ECDL 

mokymo programą, pasiskirst÷ taip (11 pav.): beveik pus÷ ekspertų mano, jo gerosios praktikos 

elementus reik÷tų įtraukti į mokymo programą, 24% mano, jog juos būtina įtraukti. 14% ekspertų 

teigia, jog į mokymo programą šių elementų įtraukti nereik÷tų. Remiantis ekspertų pateiktais 

atsakymais, gerosios praktikos elementai tur÷tų būti įtraukiami į ECDL mokymo programą. 

 
Šaltinis: sudaryta autoriaus. 

11 pav. . Apklausos respondentų atsakymas į klausimą Nr. 4. 
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Remiantis ekspertų rekomendacijomis, optimalus gerosios praktikos elementų, įtraukiamų į 

ECDL programą, skaičius tur÷tų neviršyti 4-5 elementų kiekvienam moduliui. Svarbu, kad šių 

patarimų kiekvienam moduliui nebūtų pernelyg daug, nes pagal klausimynus šių elementų galima 

pririnkti išties nemažai. 

Kokie gerosios praktikos elementai tur÷tų būti naudojami ECDL testuose priklauso nuo to,  

kokio sud÷tingumo modulį paimsime. ECDL Core testams tur÷tų būti naudojami vos keli (2-3) 

baziniai gerosios praktikos elementai, o specializuotiems ar ECDL Advanced testams - tam tikri 

specializuoti elementai. 

Gerosios praktikos elementai labai svarbūs tiems ECDL Advanced moduliams, kuriuos 

testuojamieji naudoja dažniausiai, t.y. ECDL Spreadsheets, bei ECDL Word. Mažiau svarbūs jie yra 

ECDL Presentation bei ECDL Database moduliams. 

Kaip rodo tyrimo rezultatai, geroji praktika, ekspertų nuomone, yra pakankamai svarbi 

ECDL testų kokybei užtikrinti. Džiugina tai, jog dauguma ekspertų mano, kad gerosios praktikos 

patarimai būtų traukiami į kursų programas ir yra naudingi. Taigi gerosios praktikos įtraukimas į 

ECDL mokomąją programą būtų išties naudingas. 

3.1. ECDL užduočių praktinis eksperimentas 

Eksperimento tikslas – nustatyti bei įvertinti, kaip žmon÷s atlieka ECDL testų užduotis, ar 

naudojasi gerąja praktika. 

Gauti tyrimo rezultatai leistų palyginti ECDL užduočių teorinį ir praktinį atlikimą kokyb÷s 

požiūriu. 

Eksperimento imtis – žmon÷s, darbe naudojantys MS Word, MS Excel programas (10 

žmonių). 

Eksperimento metodai. Šiam eksperimentui buvo taikomas kokybinis tyrimo metodai – 

praktinis eksperimentas, palyginimo metodas. Analizuojat ir vertinant eksperimento rezultatus taip 

pat taikytas analiz÷s metodas, kartu su tyrimo rezultatais interpretuojant praktinius tyrimo 

duomenis. 

Sudarant užduotis buvo remiamasi ECDL Advanced klausimynu Syllabus 1.0. Sudarant 

eksperimento imtį atsižvelgta, kad respondentai turi praktinių įgūdžių naudojantis MS Office 

produktais. Užduotis (žr. Priedą Nr. 3) susideda iš dviejų dalių – pirmoji skirta MS Word 

praktiniam naudojimui, antroji – MS Excel praktiniam naudojimui. Eksperimento rezultatai leis 

palyginti užduočių atlikimą kokyb÷s požiūriu, kadangi bus fiksuojamas kiekvienas respondentų 

žingsnis. Praktin÷ užduotis taip pat bus lyginama su teoriniu klausimu iš ECDL testo. 



72 
 

Eksperimento organizavimas. Eksperimento metu užduotys buvo pateiktos 10 žmonių. 

Visi respondentai buvo Lietuvos Respublikos piliečiai. Eksperimento atlikimo trukm÷ – viena 

diena. Eksperimento imtis ir respondentų įgūdžiai leidžia gerai ištirti rūpimus klausimus. 

Eksperimento rezultatai. 

Eksperimento rezultatai pad÷jo palyginti kokybiško užduočių atlikimo svarbą bei įvertinti, 

ar žmon÷s naudojo gerosios praktikos patarimus atlikdami ECDL užduotis. Atsižvelgiant į 

respondentų veiksmu, nustatyta, kiek gerosios praktikos elementų buvo panaudota bei kokie 

dažniausia naudojami. 

Siekiant atlikti užduočių palyginimą kokyb÷s požiūriu, buvo sukurta MS Word bei MS 

Excel programoms pritaikytas užduočių rinkinys. Šią užduotį paprašyta atlikti žmonių, kurie savo 

kasdieniniame darbe naudojasi šiomis programomis. Pagrindinis šio tyrimo tikslas – išsiaiškinti, ar 

kokius veiksmus žmon÷s atlieka vykdydami užduotis, kiek laiko užtrunka, ar naudojasi gerąja 

praktika. Tai reikalinga tam, kad būtų galima palyginti praktiškai šias užduotis su teoriniais 

klausimais pateikiamais testavimo programose kokyb÷s požiūriu. 

Rezultatai laiko atžvilgiu pateikiami lentel÷je Nr. 3 ir lentel÷je Nr. 4. 

3 lentel÷ 
Respondentų MS Word užduoties atlikimo trukm÷ 

Užduotis MS Word 

 Laikas Komentaras 

Respondentas Nr. 1W 26 min panaudotas 1 gerosios 
praktikos elementas 

Respondentas Nr. 2W 15 min panaudoti 2 gerosios praktikos 
elementai 

Respondentas Nr. 3W 19 min panaudoti 2 gerosios praktikos 
elementai 

Respondentas Nr. 4W 32 min gerosios praktikos elementai 
nepanaudoti  

Respondentas Nr. 5W 41 min gerosios praktikos elementai 
nepanaudoti  

Šaltinis: sudaryta autoriaus. 

4 lentel÷ 
Respondentų MS Excel užduoties atlikimo trukm÷ 

Užduotis MS Excel 

 Laikas Komentaras 

Respondentas Nr. 1E 59 min gerosios praktikos elementai 
nepanaudoti  

Respondentas Nr. 2E 21 min panaudoti 3 gerosios praktikos 
elementai 

Respondentas Nr. 3E 44 min panaudoti 2 gerosios praktikos 
elementai 
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4 lentel÷s tęsinys   

Respondentas Nr. 4E 36 min panaudoti 2 gerosios praktikos 
elementai 

Respondentas Nr. 5E 52 min panaudotas 1 gerosios 
praktikos elementas 

Šaltinis: sudaryta autoriaus. 

3.1.1. MS Word užduoties analiz÷ 

Užduotį išdaliname žingsniais: 

1 žingsnis. Sukurti dokumentą, kurio parašt÷s būtų: viršuje ir apačioje – 2 cm, kair÷je – 2,5 

cm, dešin÷je – 1,5 cm. 

Respondentas 1W: Dokumento parašt÷s nustatytos meniu pagalba File → Page Setup. 

Respondentas 2W: Dokumento parašt÷s nustatytos meniu pagalba File → Page Setup. 

Respondentas 3W: Dokumento parašt÷s nustatytos rankiniu būdu tempiant liniuotę. 

Respondentas 4W: Dokumento parašt÷s nustatytos meniu pagalba File → Page Setup. 

Respondentas 5W: Dokumento parašt÷s nustatytos meniu pagalba File → Page Setup. 

Respondentas klaidžiojo po meniu (View, Format). 

Kaip matome ir respondentų žingsnių, dokumento parašt÷ms nustatyti yra keletas būdų. 

Respondentai užduoties žingsnį atliko jiems paprasčiausiu ir geriausiai žinomu būdu. Ši užduotis 

n÷ra ECDL Core lygio, tod÷l ji tur÷tų nesukelti problemų patyrusiems vartotojams.  

2 žingsnis. Pirmame dokumento puslapyje turi būti titulinis lapas, kurio viršuje užrašas 

didžiosiomis raid÷mis „VILNIAUS UNIVERSITETAS KAUNO HUMANITARINIS 

FAKULTETAS“, šrifto stilius – Times New Roman, šrifto dydis – 14. Lapo viduryje užrašas 

„ECDL testas MS Word“, “, šrifto stilius – Times New Roman, šrifto dydis – 16. Žemiau dešin÷je 

jūsų vardas, pavard÷ ir data, šrifto stilius – Times New Roman, šrifto dydis – 12.  Puslapio apačioje 

miesto, kuriame gyvenate, pavadinimas didžiosiomis raid÷mis, šrifto stilius – Times New Roman, 

šrifto dydis – 12. 

Respondentas 1W: Dokumento tekstas parašytas įjungus Caps Lock mygtuką, šrifto 

nustatymai pakeisti meniu pagalba Format→Font. Teksto lygiuot÷ nustatyta 

Format→Paragraph→Alignment meniu pagalba. Tarpai tarp užrašų padaryti naudojant Enter 

paspaudimus. 

Respondentas 2W: Dokumento tekstas parašytas įjungus Caps Lock mygtuką, šrifto 

nustatymai pakeisti paspaudus dešinį pel÷s mygtuką →Font. Teksto lygiuot÷ nustatyta paspaudus 

dešinį pel÷s mygtuką →Paragraph→Alignment meniu pagalba. Tarpai tarp užrašų padaryti 

paspaudus dešinį pel÷s mygtuką →Paragraph meniu Spacing After. 
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Respondentas 3W: Dokumento tekstas parašytas įjungus Caps Lock mygtuką, šrifto 

nustatymai pakeisti paspaudus dešinį pel÷s mygtuką →Font. Teksto lygiuot÷ nustatyta paspaudus 

dešinį pel÷s mygtuką →Paragraph→Alignment meniu pagalba. Tarpai tarp užrašų padaryti 

paspaudus dešinį pel÷s mygtuką →Paragraph meniu Spacing After. 

Respondentas 4W: Dokumento tekstas parašytas laikant nuspaudus Shift mygtuką, šrifto 

nustatymai pakeisti paspaudus dešinį pel÷s mygtuką →Font. Teksto lygiuot÷ nustatyta 

Format→Paragraph→Alignment meniu pagalba. Tarpai tarp užrašų padaryti naudojant Enter 

paspaudimus. 

Respondentas 5W: Dokumento tekstas parašytas laikant nuspaudus Shift mygtuką, šrifto 

nustatymai pakeisti meniu pagalba Format→Font. Teksto lygiuot÷ nustatyta 

Format→Paragraph→Alignment meniu pagalba. Tarpai tarp užrašų padaryti naudojant Enter 

paspaudimus. 

Kaip matome, respondentams ši užduotis sunkumų nesuk÷l÷. 2-asis ir 3-iasis respondentai 

dirba sparčiau, naudojasi dešiniuoju pel÷s klavišu. Taip pat šie respondentai panaudojo gerosios 

praktikos elementą – tarpams tarp teksto jie panaudojo tarpo tarp pastraipos padidinimą 

(Paragraph→Spacing). Kiti respondentai nepanaudojo šio elemento ir tarpus tarp užrašų padidino 

Enter paspaudimais. 

3 žingsnis. Antrame dokumento puslapyje įkopijuoti teksto pastraipą, šrifto stilius – Times 

New Roman, šrifto dydis – 12, tarpai tarp eilučių dvigubi, pirmoji pastraipos eilut÷ atitraukta į 

dešinę 1,27 cm, tekstas išlygiuotas pagal abi puses. Po teksto pastraipa padarykite puslapio pločio 

brūkšnį. 

Repondentas 1W: Tekstas įkopijuotas Crtl+C ir Ctrl+V klavišų kombinacijų pagalba. 

Šriftas pakoreguotas meniu pagalba Format→Font, tarpai tarp eilučių taip pat meniu pagalba 

Format→Paragraph→Spacing→Line Spacing kartu ir pirmosios eilut÷s atitraukimas 

Identation→Special→First Line. Linija įterpta pastačius kursorių po pastraipa ir paspaudus apatinio 

r÷melio mygtuką. 

Repondentas 2W: Tekstas įkopijuotas Crtl+C ir Ctrl+V klavišų kombinacijų pagalba. 

Šriftas pakoreguotas paspaudus dešinį pel÷s mygtuką ir Format→Font, tarpai tarp eilučių taip pat 

paspaudus dešinį pel÷s mygtuką ir Paragraph→Spacing→Line Spacing kartu ir pirmosios eilut÷s 

atitraukimas Identation→Special→First Line. Linija įterpta pastačius kursorių po pastraipa ir 

paspaudus apatinio r÷melio mygtuką. 

Repondentas 3W: Tekstas įkopijuotas Crtl+C ir Ctrl+V klavišų kombinacijų pagalba. 

Šriftas pakoreguotas paspaudus dešinį pel÷s mygtuką ir Format→Font. Tarpai tarp eilučių 

paspaudus Line Spacing piktogramą. Pirmosios eilut÷s atitraukimas paspaudus dešinį pel÷s 
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mygtuką ir Paragraph→Identation→Special→First Line. Linija įterpta pastačius kursorių po 

pastraipa ir paspaudus apatinio r÷melio mygtuką. 

Repondentas 4W: Tekstas įkopijuotas dešiniojo pel÷s klavišo ir Copy/Paste kombinacijų 

pagalba. Šriftas pakoreguotas meniu pagalba Format→Font, tarpai tarp eilučių taip pat meniu 

pagalba Format→Paragraph→Spacing→Line Spacing kartu ir pirmosios eilut÷s atitraukimas 

Identation→Special→First Line. Linija įterpta Horizontal Line pagalba. 

Repondentas 5W: Tekstas įkopijuotas dešiniojo pel÷s klavišo ir Copy/Paste kombinacijų 

pagalba. Šriftas pakoreguotas meniu pagalba Format→Font, tarpai tarp eilučių taip pat meniu 

pagalba Format→Paragraph→Spacing→Line Spacing kartu ir pirmosios eilut÷s atitraukimas 

Identation→Special→First Line. Linija neįterpta, daug laiko sugaišta naršant po Insert meniu. 

Respondentai 1W, 2W ir 3W naudojasi klavišų kombinacijomis kopijavimo veiksmams 

paspartinti. Vieni šią užduotį atliko greičiau, kiti l÷čiau. Respondentas 5W nesugeb÷jo įterpti linijos 

po pastraipa, nebuvo panaudotas apatinis r÷melis. Respondentas 4W įterp÷ ne tokio tipo liniją. 

Atitinkamas teorinis klausimas: Norite nustatyti, kad dokumento pastraipose būtų dvigubi 

tarpai tarp eilučių. Kaip tai padaryti? 

a. Kiekvienos eilut÷s pabaigoje paspausti Enter. 

b. Priemonių juostoje paspausti piktogramą  ir pasirinkti skaičių 2.0 

c. Nurodyti komandą FormatParagraph ir atsiv÷rusio lango srityje Spacing laukelyje 

Before arba After parašyti skaičių 2.0 

d. Priemonių juostoje paspausti  mygtuką ir pažym÷ti du langelius. 

Šis klausimas nesuteikia respondentui galimyb÷s pasirinkti atsakymo, kuriame ši užduotis 

būtų atliekama meniu pagalba Format→Paragraph→Spacing→Line Spacing. Ne visi įpratę 

naudotis piktogramomis, kiti naudojasi dešiniuoju pel÷s klavišu ir tuomet Paragraph. 

4 žingsnis. Įkopijuokite antrą teksto pastraipą Šioje pastraipoje padarykite du stulpelius, kur 

pirmasis stulpelis būtų dvigubai trumpesnis už antrąjį. Antrojoje pastraipoje įterpkite komentarą. 

Repondentas 1W: Tekstas įkopijuotas Crtl+C ir Ctrl+V klavišų kombinacijų pagalba. 

Tekstas į stulpelius padalintas stulpelių piktogramos pagalba. Pirmoji pastraipa mažinta Enter 

klavišų pagalba. Komentaras įterptas Reviewing meniu pagalba Insert→Comment. 

Repondentas 2W: Tekstas įkopijuotas Crtl+C ir Ctrl+V klavišų kombinacijų pagalba. 

Tekstas į stulpelius padalintas stulpelių piktogramos pagalba. Pirmoji pastraipa mažinta 

Insert→Page Break→Column Brake pagalba. Komentaras įterptas Reviewing meniu pagalba 

Insert→Comment. 

Repondentas 3W: Tekstas įkopijuotas Crtl+C ir Ctrl+V klavišų kombinacijų pagalba. 

Tekstas į stulpelius padalintas stulpelių piktogramos pagalba. Pirmoji pastraipa mažinta 
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Insert→Page Break→Column Brake pagalba. Komentaras įterptas Reviewing meniu pagalba 

Insert→Comment. 

Repondentas 4W: Tekstas įkopijuotas dešiniojo pel÷s klavišo ir Copy/Paste kombinacijų 

pagalba. Tekstas į stulpelius padalintas stulpelių meniu Format→Columns pagalba. Pirmoji 

pastraipa mažinta Enter klavišų pagalba. Komentaras įterptas Reviewing meniu pagalba 

Insert→Comment. 

Repondentas 5W: Tekstas įkopijuotas dešiniojo pel÷s klavišo ir Copy/Paste kombinacijų 

pagalba. Tekstas į stulpelius padalintas stulpelių piktogramos pagalba. Pirmoji pastraipa mažinta 

Enter klavišų pagalba. Komentaras įterptas Reviewing meniu pagalba Insert→Comment. 

Atitinkamas teorinis klausimas: Rašant tekstą stulpeliais prireikus rašyti kitame stulpelyje 

nebaigus ankstesnio, naudosite: 

a. Įterpsite Page Break (Puslapio trūkis). 

b. Eilut÷s pabaigoje paspausite Enter. 

c. Įterpsite Column Break (Stulpelio lūžis). 

d. Spausite Format→Paragraph→Start New Column. 

Šis teorinis klausimas turi vienintelį teisingą atsakymą – c. Tačiau respondentai dažniausiai 

naudoja Enter paspaudimus, o ne gerosios praktikos elementą. Tod÷l dauguma šį klausimą atsako 

neteisingai. 

5 žingsnis. Po pastraipomis parašykite savo vardą, pavardę ir pasukite šiuos žodžius 90° 

kampu. 

Repondentas 1W: Vardas ir pavard÷ įrašyti į lentel÷s celę. Tekstas pasuktas meniu pagalba 

Format→Text Direction→Orientation. 

Repondentas 2W: Vardas ir pavard÷ įrašyti į lentel÷s celę. Tekstas pasuktas paspaudus 

dešinį pel÷s klavišą ir Text Direction→Orientation. 

Repondentas 3W: Vardas ir pavard÷ įrašyti į lentel÷s celę. Tekstas pasuktas paspaudus 

dešinį pel÷s klavišą ir Text Direction→Orientation. 

Repondentas 4W: Tekstas pasuktas naudojant WordArt priemone meniu pagalba 

Insert→Picture→WordArt įterpus jį į teksto laukelį (TextBox). 

Repondentas 5W: Vardas ir pavard÷ nepasukti. 

Atitinkamas teorinis klausimas: Kurią priemonę naudosite keletui puslapio žodžių 90° 

kampu pasukti? 

a. Teksto lauką. 

b. Piešimo priemonę WordArt. 

c. R÷melius. 
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d. Tekstą galima pasukti ir be papildomų priemonių: pakanka jį pažym÷ti ir nurodyti 

komandą Format→Text Direction. 

e. Tekstą galima pasukti lentel÷je. 

Teisingi atsakymai yra a ir e. Kaip matome, ne visi respondentai teisingai atliko užduotį. 

Tačiau dauguma žino vieną būdą teksto pasukimui. Tai – teksto įterpimas į lentelę. 

3.1.2. MS Excel užduoties analiz÷ 

Užduotį išdaliname žingsniais: 

1 žingsnis. Pateiktiems duomenis suskaičiuokite stulpelių vidurkius kiekvienos pateiktos 

firmos duomenims. 

Respondentas 1E: Nerikiuotiems duomenims buvo taikoma vidurkio skaičiavimo funkcija 

AVERAGE. Pastarosios funkcijos rezultatai ištrinti, sąrašui panaudotas rikiavimas 

Data→Sort→Sort By pagal stulpelį Firma. Kiekvienos firmos duomenims apdoroti v÷l panaudota 

funkcija AVERAGE. 

Respondentas 2E: Duomenims apdoroti panaudotas rikiavimas Data→Sort→Sort By pagal 

stulpelį Firma. Tuomet duomenų grupavimui panaudota Automatinio grupių sumavimo funkcija 

Data→Subtotals, joje nurodyta At each Change – stulpelis Firma, tuomet Use function – Average. 

Respondentas 3E: Duomenims apdoroti panaudotas rikiavimas Data→Sort→Sort By pagal 

stulpelį Firma. Kiekvienos firmos duomenims apdoroti panaudota funkcija AVERAGE. 

Respondentas 4E: Duomenims apdoroti panaudotas rikiavimas Data→Sort→Sort By pagal 

stulpelį Firma. Tuomet duomenų grupavimui panaudota Automatinio grupių sumavimo funkcija 

Data→Subtotals, joje nurodyta At each Change – stulpelis Firma, tuomet Use function – Average. 

Respondentas 5E: Nerikiuotiems duomenims buvo taikoma vidurkio skaičiavimo funkcija 

AVERAGE. Pastarosios funkcijos rezultatai ištrinti, sąrašui panaudotas rikiavimas 

Data→Sort→Sort By pagal stulpelį Firma. Kiekvienos firmos duomenims apdoroti v÷l panaudota 

funkcija AVERAGE. 

Gerosios praktikos patarimus panaudojo antras ir ketvirtas respondentai. Duomenų 

apdorojimui jie panaudojo Subtotal funkciją. Kiti respondentai sprend÷ užduotis ilgesniu, 

sud÷tingesniu būdų, kuris netinka apdoroti dideliems duomenų kiekiams. 

2 žingsnis. Pasl÷pkite duomenis, kad matytųsi tik vidurkiai. 

Respondentas 1E: Nereikalingi duomenys iškirpti pažym÷jus celių grupes ir paspaudus 

dešinį pel÷s mygtuką →Cut. 

Respondentas 2E: Duomenys pasl÷pti pažym÷jus celių grupes ir paspaudus dešinį pel÷s 

mygtuką →Hide. 
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Respondentas 3E: Duomenys pasl÷pti pažym÷jus celių grupes ir paspaudus dešinį pel÷s 

mygtuką →Hide. 

Respondentas 4E: Duomenys pasl÷pti Subtotals grupių valdymo pagalba, paspaudus 

duomenų sutraukimo mygtuką „+“.  

Respondentas 5E: Duomenys pasl÷pti pažym÷jus celių grupes ir paspaudus dešinį pel÷s 

mygtuką →Hide. 

Ne visi vartotojai moka naudotis Hide funkcija. Trys iš penkių respondentų ją panaudojo, 

kiti respondentai rado kitus sprendimo variantus. 

3 žingsnis. Susumuokite stulpelio „Apimtys“ vidurkių rezultatų, kurie yra didesni nei 

20,000. 

Respondentas 1E: Sumavimui panaudota funkcija SUM, reikšmes parenkant rankiniu būdu 

ieškant didesnių nei 20,000. 

Respondentas 2E: Sumavimui panaudota funkcija SUMIF, reikšmes parenkant automatiniu 

būdu pagal apribojimą >20,000. 

Respondentas 3E: Sumavimui panaudota funkcija SUMIF, reikšmes parenkant automatiniu 

būdu pagal apribojimą >20,000. Daug laiko sugaišta, nes pirmą kartą nurodant apribojimus 

skaičiavimui įvesti klaidinti duomenys. 

Respondentas 4E: Sumavimui panaudota funkcija SUMIF, reikšmes parenkant automatiniu 

būdu pagal apribojimą >20,000. 

Respondentas 5E: Sumavimui panaudota funkcija SUM, reikšmes parenkant rankiniu būdu 

ieškant didesnių nei 20,000. 

SUMIF funkcijos panaudojimą taip pat būtų galima laikyti gerąja šio žingsnio praktika. Šią 

funkciją panaudojo trys respondentai. Kiti duomenis sumavimui rinko rankomis. Tą būtų padaryti 

labai sunku, jei būtų didelis duomenų kiekis. 

4 žingsnis. Nupieškite visų firmų „Apimtys“ vidurkių stulpelinę diagramą, ir padidinkite 

tarpus tarp stulpelių. 

Respondentas 1E: Diagrama įterpta Insert→Chart→Chart Options, pasirinkus Chart 

Type→Bar. Nurodžius duomenų masyvą, nubr÷žta diagrama. Tarpai tarp stulpelių nepadidint, nes 

naršant po meniu nepavyko rasti šios galimyb÷s. 

Respondentas 2E: Diagrama įterpta Insert→Chart→Chart Options, pasirinkus Chart 

Type→Bar. Nurodžius duomenų masyvą, nubr÷žta diagrama. Tarpai tarp stulpelių padidinti 

paspaudus dešinį pel÷s klavišą diagramos srityje, tuomet Format Data Series→Options→Overlap 

nurodyta neigiama reikšm÷. 

Respondentas 3E: Diagrama įterpta Insert→Chart→Chart Options, pasirinkus Chart 

Type→Bar. Nurodžius duomenų masyvą, nubr÷žta diagrama. Tarpai tarp stulpelių padidinti 
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paspaudus dešinį pel÷s klavišą diagramos srityje, tuomet Format Data Series→Options→Overlap 

nurodyta neigiama reikšm÷. Daug laiko sugaišta ieškant galimyb÷s padidinti tarpą tarp stulpelių. 

Respondentas 4E: Diagrama įterpta Insert→Chart→Chart Options, pasirinkus Chart 

Type→Bar. Nurodžius duomenų masyvą, nubr÷žta diagrama. Tarpai tarp stulpelių padidinti 

paspaudus dešinį pel÷s klavišą diagramos srityje, tuomet Format Data Series→Options→Overlap 

nurodyta neigiama reikšm÷. 

Respondentas 5E: Diagrama įterpta Insert→Chart→Chart Options, pasirinkus Chart 

Type→Bar. Nurodžius duomenų masyvą, nubr÷žta diagrama. Tarpai tarp stulpelių nepadidint, nes 

naršant po meniu nepavyko rasti šios galimyb÷s. 

 

Eksperimento išvados. Kaip matome, kai kurie žmon÷s jau įpratę atlikti užduotis 

pasitelkdami gerosios praktikos elementus tiek MS Excel, tiek MS Word programinių paketų 

aplinkoje. Jie užduotis atlieka greičiau bei kokybiškiau. Respondentai, kurie nekorektiškai atliko 

užduotis, užtruko žymiai ilgiau, bei panaudojo mažiau arba visai nepanaudojo gerosios praktikos 

elementų. Taigi, kokyb÷s prasme, testavimas įtraukiant gerosios praktikos elementus į praktines 

užduotis yra žymiai efektyvesnis, nei teorinių žinių tikrinimas atsakin÷jant į įprastus testo 

klausimus. 
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IŠVADOS IR PASIŪLYMAI 

1. Internetinis testavimas greitai populiar÷ja. Pereinama nuo klientin÷je pus÷je esančio valdymo prie 

serverio pus÷s valdymo. Nuo 2010 metų sertifikavimui bus naudojamas automatizuotas testavimas, 

o neautomatizuotas testavimas liks tik kaip labai reta išimtis. Šiuo metu perversmas vyksta ir 

kompiuterinio raštingumo testavimo srityje. 

2. Norint pagerinti ECDL testavimo sistemą, tikslinga panaudoti adaptyvų kompiuterinį testavimą 

specializuotoms ir profesionalioms ECDL programoms. Šiuo metodu galima tiksliau įvertinti 

testuojamojo žinias, nes įvertis perskaičiuojamas po kiekvieno atsakymo bei kitas klausimas 

parenkamas pagal prieš tai buvusio klausimo atsakymą. Pradedančiųjų ir patyrusių vartotojų 

kompiuterinio raštingumo testavimui automatizuoto testavimo metodu pagrįstos sistemos tinka 

labiau. 

3. ECDL testavimams dabar naudojamos kompiuterizuotos testavimo sistemos, kurios dažnai naudoja 

teorinių žinių patikrinimą, tod÷l iš testuojamojo reikalaujama įsiminti įrankių, meniu komandų 

paskirtį, klavišų deriniais inicijuojamus veiksmus, iš dalies ribojamos atsakymo alternatyvos. Kai 

kuriais atvejais toks testavimo būdas sukelia neigiamą testuojamųjų reakciją ar nusiskundimus. 

4. Šiuolaikin÷s technologijos sudaro galimybes kurti naujo tipo testavimo sistemas, kurių pagrindas 

būtų testavimas taikomųjų programų aplinkoje. Tai leistų pašalinti teorinių žinių patikrinimu 

grindžiamų kompiuterizuotų testavimo sistemų trūkumus ir sudarytų sąlygas patikrinti žinias ir 

įgūdžius kokyb÷s požiūriu įprastoje darbo aplinkoje, taipogi leistų realizuoti gerosios praktikos 

elementus. 

5. Darbe pasiūlytas ECDL testavimo sistemos koncepcinis architektūros modelis, įtraukiant gerosios 

praktikos elementų valdymo posistemę. Tokia architektūra pad÷s efektyviai organizuoti ECDL 

testavimą atsižvelgiant į kokyb÷s reikalavimus testuojamųjų įgūdžiams. 

6. Remiantis tyrimo rezultatais nustatyta, kad reik÷tų įtraukti po 4-5 gerosios praktikos elementus į 

ECDL Advanced modulių testavimo programas, kadangi šie elementai padeda kokybiškai ir 

korektiškai atlikti ECDL testų užduotis, o kartu darbą su kompiuterin÷mis programomis padaro 

efektyvesnį ir produktyvesnį tiek laiko, tiek resursų atžvilgiu. 

7. Pasiūlyti gerosios praktikos elementai ECDL Advanced modulių testavimo programoms, kartu 

konstatuojant, jog neįmanoma pasiūlyti bendros jų atrinkimo metodikos ir tenka pasikliauti vien tik 

ekspertų nuomone. 

8. Remiantis ECDL eksperimento rezultatais, nustatyta, kad net ir patyrę MS Office vartotojai mažai 

naudojasi gerosios praktikos patarimais ir užduotis atlieka nevisiškai korektiškai. Šie rezultatai 

leidžia teigti, kad gerosios praktikos elementų įtraukimas į ECDL testavimo sistemas užtikrintų 

reikalavimus įgūdžių kokybei. 

9. Darbo rezultatai aprobuoti pateikiant mokslinį straipsnį 14-ajai tarpuniversitetinei magistrantų ir 

doktorantų mokslinei konferencijai „Informacin÷s technologijos“. 
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1 PRIEDAS 
 

VILNIAUS UNIVERSITETAS 
KAUNO HUMANITARINIS FAKULTETAS 

INFORMATIKOS KATEDRA 
 
 

VERSLO INFORMACIJOS SISTEM Ų MAGISTRANT ŪROS PROGRAMOS 
MOKSLO TIRIAMOJO DARBO PLANAS 

 
 
Magistrantas(÷)  Ieva Ž÷kait÷ Tel. 8 620 51 101 
 (vardas, pavard÷) 

Magistrantūros trukm÷ nuo 2007 m. iki 2009 m. 
 
TEMA  ECDL testavimo būdų palyginimo kokyb÷s požiūriu tyrimas  
 
Vadovas  Eugenijus Telešius, docentas daktaras, VUKHF, VšĮ Informacinių technologijų 

institutas, Tel.: +370 37 750102, Mob. tel.: +370 686 46217,  E-mail: et@ecdl.lt 
 (vardas, pavard÷, mokslinis laipsnis, pedagoginis vardas, darboviet÷, telefonas) 

Darbo anotacija: 

Tikslas: Išanalizuoti ir įvertinti ECDL testavimo būdų galimybes kokyb÷s požiūriu 
 
Uždaviniai:  

6. Išnagrin÷ti esamas įvairias ECDL testavimo sistemas. 
7. Išskirti rankiniam ir automatizuotam testavimui būdingas užduotis. 
8. Remiantis ECDL testavimo būdų galimyb÷mis, palyginti įvairias testavimo sistemas. 
9. Remiantis anksčiau atliktu palyginimu, įvertinti kiekvieno testavimo būdo galimybes 

kokyb÷s požiūriu.  
 
Metodai, kuriuos ketinama ištirti ir panaudoti darbe: mokslin÷s literatūros analiz÷, lyginamoji 
analiz÷, kokybin÷ analiz÷. 
 
Laukiami rezultatai: Atlikta kiekvieno ECDL testavimo būdo analiz÷, kuri leis nustatyti 
konkretaus būdo galimybes skirtingų užduočių testavimui. Skirtingų ECDL testavimo sistemų 
palyginimas, kuris leis įvertinti ECDL testavimo būdų galimyb÷s kokyb÷s požiūriu, ar galima 
efektyviai panaudoti skirtingus būdus įvairių užduočių atlikimo testavimui. 

Mokslo tiriamojo darbo planas 

Semestras (data) Užduotys 

S1 

2007 10 15 
2007 11 01 
2007 11 30 
 
2007 12 01 
2007 12 30 

Preliminarios magistrinio darbo temos formulavimas. 
Literatūros šaltinių parinkimas ir esamos pad÷ties apžvalga. 
Literatūros šaltinių analiz÷, grupavimas, pagrindinių id÷jų 
apžvalga. 
Eksperimentinių duomenų paieška. 
Magistrinio darbo įvado rašymas. 
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S2 

2008 03 01 
2008 04 01 
2008 04 15 
2008 05 01 
2008 06 01 

Teorin÷s dalies rengimas. 
Testavimo metodų paieška. 
Išsami testavimo metodų analiz÷. 
Jų lyginamoji analiz÷: privalumai, trūkumai ir kritika. 
Siūlomas specializuotas ECDL užduočių testavimo būdas pagal 
konkretaus testavimo būdo galimybes. 

S3 

2008 10 01 
2008 11 01 
2008 11 15 
2008 12 10 
2009 01 10 
2009 01 16 

Eksperimentin÷s tyrimo metodikos ruošimas. 
Duomenų ir kitos eksperimentiniam tyrimui reikalingos 
medžiagos rinkimas, apdorojimas ir įvertinimas. 
Eksperimentinių tyrimų atlikimas. 
Preliminarus eksperimentinių tyrimų rezultatų įvertinimas. 
Preliminarių išvadų formulavimas. 

S4 

2009 04 20 
2009 04 27 
2009 03 23 
2009 05 04 
2009 05 11 
2009 05 11 
2009 05 18 
2009 05 18 

Papildomų eksperimentinių tyrimų atlikimas. 
Eksperimentinių tyrimų rezultatų įvertinimas. 
Straipsnio konferencijai ruošimas. 
Teorin÷s dalies papildymas atnaujinta informacija. 
Darbo redagavimas. 
Išvadų rašymas. 
Galutinis magistrinio darbo sutvarkymas. 
Prezentacijos ruošimas. 

 
 
Magistrantas ................................................. Vadovas: ................................................  
 (parašas)  (parašas) 
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APKLAUSOS ANKETA EKSPERTAMS 

ECDL IR GEROJI PRAKTIKA 
 

1. Kiek svarbu testuojamiesiems mok÷ti atlikti ECDL užduotis visiškai korektiškai? 
 Labai svarbu 
 Svarbu 
 Nelabai svarbu 
 Visai nesvarbu 

 
2. Ar ECDL moduliams reikalingi gerosios praktikos elementai? 

 Labai reikalingi 
 Reikalingi 
 Nelabai reikalingi 
 Visai nereikalingi 

 
3. Kurio produkto užduotis reik ÷tų atlikti, pasitelkiant gerosios praktikos elementus? 

 ECDL Core 
 ECDL Advanced 
 Specializuotų testų (ECDL CAD, ECDL ImageMaker ir kt.) 
 e-Citizen 

 
4. Ar gerosios praktikos elementai tur÷tų būti įtraukiami į ECDL mokymo programą? 

 Būtinai 
 Taip, tur÷tų 
 Nebūtinai 
 Ne, netur÷tų 

 
5. Kiek gerosios praktikos elementų tur ÷tų būti įtraukiama į ECDL programą? 

(Parašykite, Jūsų nuomone, optimalų gerosios praktikos elementų skaičių vienam 
ECDL moduliui).  
                                                                       
 

6. Kokie gerosios praktikos elementai tur÷tų būti naudojami ECDL testuose (baziniai, 
tam tikri specializuoti elementai ar kt.)? Parašykite trumpą komentarą. 
                                                                          
                                                                          
                                                                          
                                                                          
                                                                           
 

7. Kuriems ECDL Advanced moduliams gerosios praktikos patarimai būtų labai 
svarbūs, kuriems mažiau svarbūs? 

 Labai svarbu Svarbu Nelabai 
svarbu 

Visai 
nesvarbu 

ECDL Spreadsheets     

ECDL Word processing     

ECDL Presentation     

ECDL Database     
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ECDL EKSPERIMENTO UŽDUOTYS 

 

Užduotis MS Word 

Sukurti dokumentą, kurio parašt÷s būtų: viršuje ir apačioje – 2 cm, kair÷je – 2,5 cm, dešin÷je 

– 1,5 cm. 

Pirmame dokumento puslapyje turi būti titulinis lapas, kurio viršuje užrašas didžiosiomis 

raid÷mis „VILNIAUS UNIVERSITETAS KAUNO HUMANITARINIS FAKULTETAS“, šrifto 

stilius – Times New Roman, šrifto dydis – 14, lygiuot÷ pagal centrą. Lapo viduryje užrašas „ECDL 

testas MS Word“, “, šrifto stilius – Times New Roman, šrifto dydis – 16, lygiuot÷ pagal centrą. 

Žemiau dešin÷je jūsų vardas, pavard÷ ir data, šrifto stilius – Times New Roman, šrifto dydis – 12, 

lygiuot÷ pagal dešinįjį kraštą. Puslapio apačioje miesto, kuriame gyvenate, pavadinimas 

didžiosiomis raid÷mis, šrifto stilius – Times New Roman, šrifto dydis – 12, lygiuot÷ pagal centrą. 

Antrame dokumento puslapyje įkopijuoti teksto pastraipą, šrifto stilius – Times New 

Roman, šrifto dydis – 12, tarpai tarp eilučių dvigubi, pirmoji pastraipos eilut÷ atitraukta į dešinę 

1,27 cm, tekstas išlygiuotas pagal abi puses. Po teksto pastraipa padarykite puslapio pločio brūkšnį. 

Įkopijuokite antrą teksto pastraipą Šioje pastraipoje padarykite du stulpelius, kur pirmasis 

stulpelis būtų dvigubai trumpesnis už antrąjį. Antrojoje pastraipoje įterpkite komentarą. 

Po pastraipomis parašykite savo vardą, pavardę ir pasukite šiuos žodžius 90° kampu. 

 

Užduotis MS Excel 
 

Pateiktiems duomenis suskaičiuokite stulpelių vidurkius kiekvienos pateiktos firmos 

duomenims. Susumuokite stulpelio „Apimtys“ vidurkių rezultatus, kurie yra didesni nei 20,000. 

Nupieškite visų firmų „Apimtys“ vidurkių stulpelinę diagramą ir padidinkite tarpus tarp stulpelių. 


